summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-24 18:55:48 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-24 18:55:48 +0000
commit34b5c5dc8b1983c0bb943833808f02e6d8967b1b (patch)
tree13618203531b6b5255da4037f54b7da4b8815d78 /x11-misc/xchm/xchm-0.9.ebuild
parentInherit eutils to silence EXTRA_FUNCTIONS.SH warnings. (Manifest recommit) (diff)
downloadgentoo-2-34b5c5dc8b1983c0bb943833808f02e6d8967b1b.tar.gz
gentoo-2-34b5c5dc8b1983c0bb943833808f02e6d8967b1b.tar.bz2
gentoo-2-34b5c5dc8b1983c0bb943833808f02e6d8967b1b.zip
Version bumped.
Diffstat (limited to 'x11-misc/xchm/xchm-0.9.ebuild')
-rw-r--r--x11-misc/xchm/xchm-0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xchm/xchm-0.9.ebuild b/x11-misc/xchm/xchm-0.9.ebuild
new file mode 100644
index 000000000000..adf8613c9d9c
--- /dev/null
+++ b/x11-misc/xchm/xchm-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/xchm-0.9.ebuild,v 1.1 2004/02/24 18:55:48 mholzer Exp $
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz
+ doc? ( mirror://sourceforge/xchm/${P}-doc.tar.gz )"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="doc"
+DEPEND=">=app-doc/chmlib-0.31
+ >=x11-libs/wxGTK-2.4.0"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc COPYING AUTHORS README
+
+ if [ "`use doc`" ]; then
+ cd ${S}"-doc"
+ dohtml html/*
+ fi
+}