summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-27 20:42:57 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-27 20:42:57 +0000
commitffed5b6b09c6d86ff87e99e3a8918432651ff5d8 (patch)
tree6c6074fa3c3f2011dc418f6d55474fc4687f7b59 /x11-misc/xfractint/xfractint-20.04_p07.ebuild
parentBlock net-misc/xf4vnc as it collides, bug #203513 (diff)
downloadgentoo-2-ffed5b6b09c6d86ff87e99e3a8918432651ff5d8.tar.gz
gentoo-2-ffed5b6b09c6d86ff87e99e3a8918432651ff5d8.tar.bz2
gentoo-2-ffed5b6b09c6d86ff87e99e3a8918432651ff5d8.zip
Correct versioning scheme; rename stable 20.4.03 to 20.04_p03 and add 20.04_p07 as version bump. Reverting commit for bug 48923, couldn't care less about users adding -funroll-all-loops into global CFLAGS. Fixing bug 203498, manpage installation location. More foo..
(Portage version: 2.1.4_rc11, RepoMan options: --force)
Diffstat (limited to 'x11-misc/xfractint/xfractint-20.04_p07.ebuild')
-rw-r--r--x11-misc/xfractint/xfractint-20.04_p07.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xfractint/xfractint-20.04_p07.ebuild b/x11-misc/xfractint/xfractint-20.04_p07.ebuild
new file mode 100644
index 000000000000..b30c912a2209
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.04_p07.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfractint/xfractint-20.04_p07.ebuild,v 1.1 2007/12/27 20:42:56 drac Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="a fractal generator"
+HOMEPAGE="http://www.fractint.org"
+SRC_URI="http://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+# x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ # Untested, any x86 archteam dev. is allowed to uncomment this.
+ local myasm="foo"
+# use x86 && myasm="/usr/bin/nasm"
+ emake CC="$(tc-getCC)" AS="${myasm}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ newenvd "${FILESDIR}"/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+ elog "XFractInt requires the FRACTDIR variable to be set in order to start."
+ elog "Please re-login or \`source /etc/profile\` to have this variable set."
+}