summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-18 04:50:04 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-18 04:50:04 +0000
commitcbf56ae4774fc1299ab7e2215c6a8a6d56d2b1b3 (patch)
tree500bb5808e269d57f92dedf1c793c37e50699c88 /x11-misc/xvkbd
parentVersion bump. (diff)
downloadgentoo-2-cbf56ae4774fc1299ab7e2215c6a8a6d56d2b1b3.tar.gz
gentoo-2-cbf56ae4774fc1299ab7e2215c6a8a6d56d2b1b3.tar.bz2
gentoo-2-cbf56ae4774fc1299ab7e2215c6a8a6d56d2b1b3.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/xvkbd')
-rw-r--r--x11-misc/xvkbd/ChangeLog10
-rw-r--r--x11-misc/xvkbd/xvkbd-3.2.ebuild44
-rw-r--r--x11-misc/xvkbd/xvkbd-3.5.ebuild60
3 files changed, 68 insertions, 46 deletions
diff --git a/x11-misc/xvkbd/ChangeLog b/x11-misc/xvkbd/ChangeLog
index de9ef1b97045..465e368afd78 100644
--- a/x11-misc/xvkbd/ChangeLog
+++ b/x11-misc/xvkbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xvkbd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/ChangeLog,v 1.32 2013/11/01 12:40:24 yac Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/ChangeLog,v 1.33 2014/05/18 04:50:04 jer Exp $
+
+*xvkbd-3.5 (18 May 2014)
+
+ 18 May 2014; Jeroen Roovers <jer@gentoo.org> -xvkbd-3.2.ebuild,
+ +xvkbd-3.5.ebuild:
+ Version bump.
01 Nov 2013; Jan Matejka <yac@gentoo.org> xvkbd-3.4a-r1.ebuild:
+ epatch_user
diff --git a/x11-misc/xvkbd/xvkbd-3.2.ebuild b/x11-misc/xvkbd/xvkbd-3.2.ebuild
deleted file mode 100644
index 8e9ef27ea8b7..000000000000
--- a/x11-misc/xvkbd/xvkbd-3.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/xvkbd-3.2.ebuild,v 1.5 2011/08/02 05:50:13 mattst88 Exp $
-
-DESCRIPTION="virtual keyboard for X window system"
-HOMEPAGE="http://homepage3.nifty.com/tsato/xvkbd/"
-SRC_URI="http://homepage3.nifty.com/tsato/xvkbd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="x11-libs/libXtst
- x11-libs/libXmu
- x11-libs/libXaw
- x11-libs/libXaw3d
- x11-libs/libXt"
-DEPEND="${RDEPEND}
- x11-misc/imake
- x11-misc/gccmakedep
- x11-proto/xproto
- x11-proto/inputproto
- app-text/rman
- x11-proto/xextproto"
-
-src_compile() {
- xmkmf -a || die
-
- emake \
- XAPPLOADDIR="/usr/share/X11/app-defaults" \
- LOCAL_LDFLAGS="${LDFLAGS}" \
- CDEBUGFLAGS="${CFLAGS}" || die
-}
-
-src_install() {
- emake XAPPLOADDIR="/usr/share/X11/app-defaults" DESTDIR="${D}" \
- install || die
-
- rm -rf "${D}"/usr/lib "${D}"/etc
-
- dodoc README
- newman ${PN}.man ${PN}.1
-}
diff --git a/x11-misc/xvkbd/xvkbd-3.5.ebuild b/x11-misc/xvkbd/xvkbd-3.5.ebuild
new file mode 100644
index 000000000000..13018c79dea7
--- /dev/null
+++ b/x11-misc/xvkbd/xvkbd-3.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xvkbd/xvkbd-3.5.ebuild,v 1.1 2014/05/18 04:50:04 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="virtual keyboard for X window system"
+HOMEPAGE="http://homepage3.nifty.com/tsato/xvkbd/"
+SRC_URI="http://homepage3.nifty.com/tsato/xvkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXaw3d
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) LD=$(tc-getCC) \
+ XAPPLOADDIR="/etc/X11/app-defaults" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake \
+ XAPPLOADDIR="/etc/X11/app-defaults" \
+ DESTDIR="${D}" \
+ install
+
+ rm -rf "${D}"/usr/lib "${D}"/etc || die
+
+ dodoc README
+ newman ${PN}.man ${PN}.1
+}