summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-08-27 18:29:11 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-08-27 18:29:11 +0000
commit1439f90e125cf41bf413b52def4f37e42258e654 (patch)
treea3fafcca56a2c60e646513ada2af895dad2b653d /x11-misc
parentUnmasking catalyst 2.0... thanks to Peter Volkov (pva) for reminding me. (diff)
downloadgentoo-2-1439f90e125cf41bf413b52def4f37e42258e654.tar.gz
gentoo-2-1439f90e125cf41bf413b52def4f37e42258e654.tar.bz2
gentoo-2-1439f90e125cf41bf413b52def4f37e42258e654.zip
add patch for bug #140811
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/notification-daemon/ChangeLog9
-rw-r--r--x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r23
-rw-r--r--x11-misc/notification-daemon/files/notification-daemon-0.3.5-unrealize-in-destroy.patch12
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.3.5-r2.ebuild33
4 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/notification-daemon/ChangeLog b/x11-misc/notification-daemon/ChangeLog
index e604a88470f6..31cdfca17ba0 100644
--- a/x11-misc/notification-daemon/ChangeLog
+++ b/x11-misc/notification-daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/notification-daemon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.15 2006/08/17 20:19:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/ChangeLog,v 1.16 2006/08/27 18:29:11 compnerd Exp $
+
+*notification-daemon-0.3.5-r2 (27 Aug 2006)
+
+ 27 Aug 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/notification-daemon-0.3.5-unrealize-in-destroy.patch,
+ +notification-daemon-0.3.5-r2.ebuild:
+ revbump to add patch for bug #140811
17 Aug 2006; Markus Rothe <corsair@gentoo.org>
notification-daemon-0.3.5.ebuild:
diff --git a/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r2 b/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r2
new file mode 100644
index 000000000000..b466389ed87e
--- /dev/null
+++ b/x11-misc/notification-daemon/files/digest-notification-daemon-0.3.5-r2
@@ -0,0 +1,3 @@
+MD5 7977c4c15139f9d53ddbfa8af707270f notification-daemon-0.3.5.tar.gz 383582
+RMD160 5251ce4dcc2ae3cc637077ea71eb65a17c9102b4 notification-daemon-0.3.5.tar.gz 383582
+SHA256 83a15eb99bb7a895d52e31be1c1548789a8bc29e83d30e758cf034a6627a1184 notification-daemon-0.3.5.tar.gz 383582
diff --git a/x11-misc/notification-daemon/files/notification-daemon-0.3.5-unrealize-in-destroy.patch b/x11-misc/notification-daemon/files/notification-daemon-0.3.5-unrealize-in-destroy.patch
new file mode 100644
index 000000000000..ed066e709d93
--- /dev/null
+++ b/x11-misc/notification-daemon/files/notification-daemon-0.3.5-unrealize-in-destroy.patch
@@ -0,0 +1,12 @@
+--- notification-daemon-0.3.5/src/daemon.c 2006/07/25 23:15:28 1.1
++++ notification-daemon-0.3.5/src/daemon.c 2006/07/25 23:17:19
+@@ -658,6 +658,9 @@ _remove_bubble_from_poptart_stack(GtkWin
+ priv->poptart_stack = g_slist_remove_link(priv->poptart_stack,
+ remove_link);
+ }
++
++ if (GTK_WIDGET_REALIZED (GTK_WIDGET (nw)))
++ gtk_widget_unrealize (GTK_WIDGET (nw));
+ }
+
+ static void
diff --git a/x11-misc/notification-daemon/notification-daemon-0.3.5-r2.ebuild b/x11-misc/notification-daemon/notification-daemon-0.3.5-r2.ebuild
new file mode 100644
index 000000000000..e68aa04d229b
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-0.3.5-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notification-daemon/notification-daemon-0.3.5-r2.ebuild,v 1.1 2006/08/27 18:29:11 compnerd Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Notifications daemon"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=gnome-base/gconf-2.4.0
+ >=x11-libs/libsexy-0.1.3
+ >=sys-apps/dbus-0.36
+ x11-libs/libwnck
+ dev-libs/popt"
+RDEPEND="${DEPEND}
+ >=sys-devel/gettext-0.14"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.3.5-icon-data.patch
+ epatch ${FILESDIR}/${PN}-0.3.5-unrealize-in-destroy.patch
+}