summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-31 15:22:58 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-31 15:22:58 +0000
commit2b05d5c88bed02030bd795a818831ea5122e2f46 (patch)
tree79e2cbfc7eeae586df04637e4fc72451cf309014 /x11-misc
parentAdd USE dependency default in preparation for the removal of the semantic-des... (diff)
downloadgentoo-2-2b05d5c88bed02030bd795a818831ea5122e2f46.tar.gz
gentoo-2-2b05d5c88bed02030bd795a818831ea5122e2f46.tar.bz2
gentoo-2-2b05d5c88bed02030bd795a818831ea5122e2f46.zip
Version bump (bug 459612, thanks Alastair Murray and poncho)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/zim/ChangeLog11
-rw-r--r--x11-misc/zim/files/zim-0.60-remove-ubuntu-theme.patch18
-rw-r--r--x11-misc/zim/zim-0.60.ebuild70
3 files changed, 96 insertions, 3 deletions
diff --git a/x11-misc/zim/ChangeLog b/x11-misc/zim/ChangeLog
index fec57ee63b2c..f8db040d39e8 100644
--- a/x11-misc/zim/ChangeLog
+++ b/x11-misc/zim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/zim
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/zim/ChangeLog,v 1.21 2012/12/13 16:49:49 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/zim/ChangeLog,v 1.22 2013/05/31 15:22:57 xmw Exp $
+
+*zim-0.60 (31 May 2013)
+
+ 31 May 2013; Michael Weber <xmw@gentoo.org>
+ +files/zim-0.60-remove-ubuntu-theme.patch, +zim-0.60.ebuild:
+ Version bump (bug 459612, thanks Alastair Murray and poncho)
*zim-0.57 (13 Dec 2012)
@@ -118,4 +124,3 @@
10 Sep 2006; Steev Klimaszewski <steev@gentoo.org> +Changelog,
+metadata.xml, +zim-0.16.ebuild:
Initial import. Finally closes bug #112957
-
diff --git a/x11-misc/zim/files/zim-0.60-remove-ubuntu-theme.patch b/x11-misc/zim/files/zim-0.60-remove-ubuntu-theme.patch
new file mode 100644
index 000000000000..ba70ab5b8f89
--- /dev/null
+++ b/x11-misc/zim/files/zim-0.60-remove-ubuntu-theme.patch
@@ -0,0 +1,18 @@
+# don't install /usr/share/icons/ubuntu-mono-{dark,light}
+# it's only used in conjunction with appindicator
+# and clutters the icon-themes menu in gnome
+--- zim-0.60/setup.py
++++ zim-0.60/setup.py
+@@ -94,12 +94,6 @@
+ files = [os.path.join(dir, f) for f in files]
+ data_files.append((target, files))
+
+- # mono icons -> PREFIX/share/icons/ubuntu-mono-light | -dark
+- for theme in ('ubuntu-mono-light', 'ubuntu-mono-dark'):
+- file = os.path.join('icons', theme, 'zim-panel.svg')
+- target = os.path.join('share', 'icons', theme, 'apps', '22')
+- data_files.append((target, [file]))
+-
+ # data -> PREFIX/share/zim
+ for dir, dirs, files in os.walk('data'):
+ if '.zim' in dirs:
diff --git a/x11-misc/zim/zim-0.60.ebuild b/x11-misc/zim/zim-0.60.ebuild
new file mode 100644
index 000000000000..c87fb0d7074c
--- /dev/null
+++ b/x11-misc/zim/zim-0.60.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/zim/zim-0.60.ebuild,v 1.1 2013/05/31 15:22:57 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 gnome2-utils fdo-mime virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="http://zim-wiki.org/"
+SRC_URI="http://zim-wiki.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-misc/xdg-utils
+ test? (
+ dev-vcs/bzr
+ dev-vcs/git
+ dev-vcs/mercurial )"
+
+PATCHES=( "${FILESDIR}"/${P}-remove-ubuntu-theme.patch )
+
+python_prepare() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ VIRTUALX_COMMAND="${PYTHON}" virtualmake test.py
+}
+
+python_install() {
+ distutils-r1_python_install --skip-xdg-cmd
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ einfo "Please emerge these packages for additional functionality"
+ einfo " dev-lang/R"
+ einfo " dev-python/gtkspell-python"
+ einfo " dev-vcs/bzr"
+ einfo " gnome-extra/zeitgeist"
+ einfo " media-gfx/graphviz"
+ einfo " media-gfx/imagemagick"
+ einfo " media-gfx/scrot"
+ einfo " media-sound/lilypond"
+ einfo " sci-visualization/gnuplot"
+ einfo " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}