summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 19:16:56 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 19:16:56 +0000
commitc3754c3fd2720ddaa77b99853451de367b98ccac (patch)
treeddbe88307427e3c12dc791479b9826f494f3882a /x11-misc
parentMask media-tv/linuxtv-dvb-firmware for removal. (diff)
downloadgentoo-2-c3754c3fd2720ddaa77b99853451de367b98ccac.tar.gz
gentoo-2-c3754c3fd2720ddaa77b99853451de367b98ccac.tar.bz2
gentoo-2-c3754c3fd2720ddaa77b99853451de367b98ccac.zip
Respect CC, LDFLAGS, CFLAGS (bug #241548).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdesktopwaves/ChangeLog10
-rw-r--r--x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch38
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.3-r1.ebuild46
3 files changed, 92 insertions, 2 deletions
diff --git a/x11-misc/xdesktopwaves/ChangeLog b/x11-misc/xdesktopwaves/ChangeLog
index 9feac7c1cece..50d1ce72054c 100644
--- a/x11-misc/xdesktopwaves/ChangeLog
+++ b/x11-misc/xdesktopwaves/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xdesktopwaves
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdesktopwaves/ChangeLog,v 1.13 2008/03/23 22:41:42 opfer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdesktopwaves/ChangeLog,v 1.14 2010/02/08 19:16:55 jer Exp $
+
+*xdesktopwaves-1.3-r1 (08 Feb 2010)
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> +xdesktopwaves-1.3-r1.ebuild,
+ +files/xdesktopwaves-1.3-gentoo.patch:
+ Respect CC, LDFLAGS, CFLAGS (bug #241548).
23 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
xdesktopwaves-1.3.ebuild:
diff --git a/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch
new file mode 100644
index 000000000000..accbb4d9baec
--- /dev/null
+++ b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch
@@ -0,0 +1,38 @@
+--- xdesktopwaves-1.3/Makefile.org 2004-12-18 06:47:40.000000000 +0100
++++ xdesktopwaves-1.3/Makefile 2010-02-08 20:05:31.000000000 +0100
+@@ -11,14 +11,13 @@
+
+ #=========================== C compiler configuration ==========================
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
++CFLAGS += $(shell pkg-config --cflags x11 xext)
+
+ #============================= Linker configuration ============================
+
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib
+-LIBS = -lm -lX11 -lXext
++LINK = $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell pkg-config --libs x11 xext)
+
+ #============================ Installer configuration ==========================
+
+--- xdesktopwaves-1.3/xdwapi/Makefile.org 2004-12-18 06:47:40.000000000 +0100
++++ xdesktopwaves-1.3/xdwapi/Makefile 2010-02-08 20:08:14.000000000 +0100
+@@ -1,10 +1,9 @@
+ # Makefile for the xdesktopwaves API and its demo program
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib
+-LIBS = -lm -lX11
++CFLAGS += $(shell pkg-config --cflags x11 xext)
++LINK = $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell pkg-config --libs x11 xext)
+
+ all: xdwapidemo
+
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r1.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r1.ebuild
new file mode 100644
index 000000000000..ccc2328ff03d
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r1.ebuild,v 1.1 2010/02/08 19:16:55 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+LICENSE="GPL-2"
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "failed building program"
+ cd xdwapi
+ emake || die "failed building demo"
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves "xdesktopwaves" xdesktopwaves.xpm
+ dodoc README
+}
+
+pkg_preinst() {
+ elog "To see what xdesktopwaves is able to do, start it by running"
+ elog "'xdesktopwaves' and then run 'xdwapidemo'. You should see the"
+ elog "supported effects on your desktop"
+}