summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-27 16:24:10 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-27 16:24:10 +0000
commitcb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef (patch)
tree207ff6103b70e886034364a903d5ce20cd365bf8 /x11-misc
parentRespect LDFLAGS wrt bug 333979. Thanks to Diego for the report. (diff)
downloadgentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.tar.gz
gentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.tar.bz2
gentoo-2-cb40e0bcab1e2a7cfe79880b978e58d5cb0f6aef.zip
Respect CC and LDFLAGS wrt bug 334565. Thanks to Diego for the report.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pogo/ChangeLog10
-rw-r--r--x11-misc/pogo/files/Makefile-r129
-rw-r--r--x11-misc/pogo/pogo-2.2-r1.ebuild41
3 files changed, 78 insertions, 2 deletions
diff --git a/x11-misc/pogo/ChangeLog b/x11-misc/pogo/ChangeLog
index dcada3e6ff07..df0b6270937a 100644
--- a/x11-misc/pogo/ChangeLog
+++ b/x11-misc/pogo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/pogo
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/ChangeLog,v 1.13 2007/07/22 03:56:37 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/ChangeLog,v 1.14 2010/08/27 16:24:10 xarthisius Exp $
+
+*pogo-2.2-r1 (27 Aug 2010)
+
+ 27 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> +pogo-2.2-r1.ebuild,
+ +files/Makefile-r1:
+ Respect CC and LDFLAGS wrt bug 334565. Thanks to Diego for the report.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; pogo-2.2.ebuild:
Drop virtual/x11 references.
diff --git a/x11-misc/pogo/files/Makefile-r1 b/x11-misc/pogo/files/Makefile-r1
new file mode 100644
index 000000000000..767499c8f3de
--- /dev/null
+++ b/x11-misc/pogo/files/Makefile-r1
@@ -0,0 +1,29 @@
+IMLIB_LIBS=$(shell exec pkg-config --libs imlib)
+IMLIB_CFLAGS=$(shell exec pkg-config --cflags imlib)
+
+all: pogo pogo-remote
+
+pogo: pogo.c
+ $(CC) $(LDFLAGS) $(CFLAGS) $(IMLIB_CFLAGS) -o pogo pogo.c -Wall $(IMLIB_LIBS)
+
+pogo-remote: pogo-remote.c
+ $(CC) $(LDFLAGS) $(CFLAGS) $(IMLIB_CFLAGS) -o pogo-remote pogo-remote.c -Wall
+
+install:
+ mkdir -p ${DESTDIR}/usr/bin
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/images
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/scripts
+ mkdir -p ${DESTDIR}/usr/share/pogo-2.2/configs
+
+ cp images/*.jpg ${DESTDIR}/usr/share/pogo-2.2/images/
+ cp scripts/*.pogo ${DESTDIR}/usr/share/pogo-2.2/scripts/
+ cp configs/*.config ${DESTDIR}/usr/share/pogo-2.2/configs/
+
+ cp pogo ${DESTDIR}/usr/bin/
+ cp pogo-remote ${DESTDIR}/usr/bin
+
+clean:
+ rm -rf pogo
+ rm -rf pogo-remote
+
diff --git a/x11-misc/pogo/pogo-2.2-r1.ebuild b/x11-misc/pogo/pogo-2.2-r1.ebuild
new file mode 100644
index 000000000000..c172749756e3
--- /dev/null
+++ b/x11-misc/pogo/pogo-2.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pogo/pogo-2.2-r1.ebuild,v 1.1 2010/08/27 16:24:10 xarthisius Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pogo is a neat launcher program for X"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+# upstream no longer exists
+HOMEPAGE="http://packages.gentoo.org/package/x11-misc/pogo"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ media-libs/imlib
+ media-libs/jpeg
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile-r1 Makefile || die
+ sed -i -e "s:/usr/local:/usr/share:g" configs/* pogo.c || die
+}
+
+src_compile() {
+ emake clean || die
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README || die
+}