summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
commitf1ae6ac54ba587173101f6bef77f25beadc137a5 (patch)
tree57c15006b1d9148f9540a8219b4e47d9213bb46f /x11-misc
parentVersion bump. 0.2.4 stable on x86. (diff)
downloadgentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.tar.gz
gentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.tar.bz2
gentoo-2-f1ae6ac54ba587173101f6bef77f25beadc137a5.zip
Add patch to fix compilation with gcc-4 by Brian Merrill <bmerrill AT sfcn DOT org>; bug #111321
(Portage version: 2.1_pre2)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/Manifest13
-rw-r--r--x11-misc/xfe/files/xfe-0.84-gcc4.patch11
-rw-r--r--x11-misc/xfe/xfe-0.84.ebuild11
4 files changed, 34 insertions, 8 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index 363c7b89ba6a..f72a696a8ef6 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.25 2005/08/07 13:17:31 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.26 2005/12/28 20:04:24 halcy0n Exp $
+
+ 28 Dec 2005; Mark Loeser <halcy0n@gentoo.org> +files/xfe-0.84-gcc4.patch,
+ xfe-0.84.ebuild:
+ Add patch to fix compilation with gcc-4 by Brian Merrill <bmerrill AT sfcn
+ DOT org>; bug #111321
07 Aug 2005; Michael Hanselmann <hansmi@gentoo.org> xfe-0.72.ebuild:
Stable on ppc.
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index 5c831b4c49a5..e89b84350368 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1,9 +1,10 @@
-MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
MD5 0e68f5e767be6d5b0deb06b6d249b693 ChangeLog 3030
-MD5 239a961941470ee8275f7f1663562222 xfe-0.72.ebuild 1032
-MD5 75bec72fdc4d3c82106a96ecd55eb2e9 xfe-0.80.ebuild 860
-MD5 4eb557d183729fbbad36a952da97e3c2 xfe-0.84.ebuild 933
+MD5 322d8f7e8c091743501a044efcd8dfe6 files/digest-xfe-0.72 60
+MD5 f515eee36f5eafa1084a91e653ba0962 files/digest-xfe-0.80 60
MD5 0802e60651e2befc91d7b7e42cb034ef files/digest-xfe-0.84 60
MD5 2e471d0d64c75be23f9e68537cf1f6bb files/xfe-0.70-file-association.patch 753
-MD5 f515eee36f5eafa1084a91e653ba0962 files/digest-xfe-0.80 60
-MD5 322d8f7e8c091743501a044efcd8dfe6 files/digest-xfe-0.72 60
+MD5 da7642700c0809578e130ca61d6461a6 files/xfe-0.84-gcc4.patch 301
+MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
+MD5 239a961941470ee8275f7f1663562222 xfe-0.72.ebuild 1032
+MD5 75bec72fdc4d3c82106a96ecd55eb2e9 xfe-0.80.ebuild 860
+MD5 2dae5eefb312c1fa83281c42ea295b13 xfe-0.84.ebuild 1019
diff --git a/x11-misc/xfe/files/xfe-0.84-gcc4.patch b/x11-misc/xfe/files/xfe-0.84-gcc4.patch
new file mode 100644
index 000000000000..baa97ed5a9d1
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-0.84-gcc4.patch
@@ -0,0 +1,11 @@
+--- xfe-0.84/src/FilePanel.cc 2005-11-02 23:30:56.000000000 -0700
++++ xfe-0.84/src/FilePanel.cc 2005-11-02 23:29:37.000000000 -0700
+@@ -296,7 +296,7 @@
+ {
+ FXString buf, filename, filepath;
+
+- int item= (int) ptr;
++ long item= (long) ptr;
+ if(item > -1)
+ {
+ // File name and path
diff --git a/x11-misc/xfe/xfe-0.84.ebuild b/x11-misc/xfe/xfe-0.84.ebuild
index d881e0b63d7b..4e6b7344ac4a 100644
--- a/x11-misc/xfe/xfe-0.84.ebuild
+++ b/x11-misc/xfe/xfe-0.84.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.1 2005/07/05 21:55:45 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.2 2005/12/28 20:04:24 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="MS-Explorer-like minimalist file manager for X"
HOMEPAGE="http://roland65.free.fr/xfe/"
@@ -15,6 +17,13 @@ IUSE="nls"
DEPEND="virtual/x11
=x11-libs/fox-1.4*"
+src_unpack()
+{
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile()
{
econf $(use_enable nls) || die "econf failed"