summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-10-16 23:01:55 +0000
committerDon Seiler <rizzo@gentoo.org>2004-10-16 23:01:55 +0000
commit515fc8c0e3b34d0d9e8242a0e17629f9c989c230 (patch)
tree670d007442f7ba8b7d4f348ff5787701b04f4067 /x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
parentamd64 keyword on 1.26, fix LICENSE syntax (Manifest recommit) (diff)
downloadgentoo-2-515fc8c0e3b34d0d9e8242a0e17629f9c989c230.tar.gz
gentoo-2-515fc8c0e3b34d0d9e8242a0e17629f9c989c230.tar.bz2
gentoo-2-515fc8c0e3b34d0d9e8242a0e17629f9c989c230.zip
Version bump
Diffstat (limited to 'x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild')
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
new file mode 100644
index 000000000000..4cef86af5ecd
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.32.ebuild,v 1.1 2004/10/16 23:01:55 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
+IUSE=""
+RESTRICT="nomirror"
+
+DEPEND=">=net-im/gaim-1.0.1
+ dev-libs/nss"
+
+src_compile() {
+ local myconf
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}