summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:58:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:58:47 +0000
commite29f9882d788de78c89315a2e9b41849c8f8ecfa (patch)
tree17d3c896e788dd7409d49fd50f70b7d6971aa399 /x11-plugins/gkrellmss
parentUse EAPI5 instead of EAPI1. (diff)
downloadgentoo-2-e29f9882d788de78c89315a2e9b41849c8f8ecfa.tar.gz
gentoo-2-e29f9882d788de78c89315a2e9b41849c8f8ecfa.tar.bz2
gentoo-2-e29f9882d788de78c89315a2e9b41849c8f8ecfa.zip
Use EAPI5 instead of EAPI1. Missing inherit eutils for epatch.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins/gkrellmss')
-rw-r--r--x11-plugins/gkrellmss/ChangeLog8
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild23
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild27
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6.ebuild23
4 files changed, 38 insertions, 43 deletions
diff --git a/x11-plugins/gkrellmss/ChangeLog b/x11-plugins/gkrellmss/ChangeLog
index cf20ed034b9e..b978e78c762e 100644
--- a/x11-plugins/gkrellmss/ChangeLog
+++ b/x11-plugins/gkrellmss/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gkrellmss
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.36 2013/06/01 11:36:37 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/ChangeLog,v 1.37 2014/04/07 19:58:47 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> gkrellmss-2.6-r1.ebuild,
+ gkrellmss-2.6-r2.ebuild, gkrellmss-2.6.ebuild:
+ Use EAPI5 instead of EAPI1. Missing inherit eutils for epatch.
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #144305
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
index aa72e828dd7a..549e881b6f2f 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild
@@ -1,33 +1,30 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.8 2012/03/18 12:40:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r1.ebuild,v 1.9 2014/04/07 19:58:47 ssuominen Exp $
-EAPI=1
+EAPI=5
inherit gkrellm-plugin
-IUSE="nls"
-
DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~sparc x86"
+IUSE="nls"
+
RDEPEND="=sci-libs/fftw-3*
media-libs/alsa-lib"
-
DEPEND="${RDEPEND}"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ppc ~sparc x86"
-
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
src_compile() {
local myconf
-
- use nls && myconf="${myconf} enable_nls=1"
+ use nls && myconf+=" enable_nls=1"
addpredict /dev/snd
- emake ${myconf} || die
+ emake ${myconf}
}
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
index 8b23e27c4664..d9f6409ded08 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild
@@ -1,37 +1,34 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild,v 1.2 2012/03/18 12:40:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6-r2.ebuild,v 1.3 2014/04/07 19:58:47 ssuominen Exp $
-EAPI=3
-inherit gkrellm-plugin
-
-IUSE="nls"
+EAPI=5
+inherit eutils gkrellm-plugin
DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="nls"
+
RDEPEND="=sci-libs/fftw-3*
media-libs/alsa-lib"
-
DEPEND="${RDEPEND}"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
src_prepare() {
- epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+ epatch "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
}
src_compile() {
local myconf
-
- use nls && myconf="${myconf} enable_nls=1"
+ use nls && myconf+=" enable_nls=1"
addpredict /dev/snd
- emake ${myconf} || die
+ emake ${myconf}
}
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
index d58c47cada8b..d4351d2e12a8 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
@@ -1,33 +1,30 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.14 2012/03/18 12:40:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.15 2014/04/07 19:58:47 ssuominen Exp $
-EAPI=1
+EAPI=5
inherit gkrellm-plugin
-IUSE="nls"
-
DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc sparc x86"
+IUSE="nls"
+
RDEPEND="=sci-libs/fftw-2*
media-libs/alsa-lib"
-
DEPEND="${RDEPEND}"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha amd64 ppc sparc x86"
-
PLUGIN_SO="src/gkrellmss.so"
PLUGIN_DOCS="Themes"
src_compile() {
local myconf
-
- use nls && myconf="${myconf} enable_nls=1"
+ use nls && myconf+=" enable_nls=1"
addpredict /dev/snd
- emake ${myconf} || die
+ emake ${myconf}
}