summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-30 01:49:27 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-30 01:49:27 +0000
commitf2e174785b68976ed0c6fcbcadf06854456df7a5 (patch)
tree219a53aefef7f6ed0512986779de0b473e46757a /x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild
parentremoved gkrellkam (diff)
downloadgentoo-2-f2e174785b68976ed0c6fcbcadf06854456df7a5.tar.gz
gentoo-2-f2e174785b68976ed0c6fcbcadf06854456df7a5.tar.bz2
gentoo-2-f2e174785b68976ed0c6fcbcadf06854456df7a5.zip
moved to x11-plugins
Diffstat (limited to 'x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild')
-rw-r--r--x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild b/x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild
new file mode 100644
index 000000000000..97fdaa64c500
--- /dev/null
+++ b/x11-plugins/gkrellweather/gkrellweather-0.2.7-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /home/cvsroot/gentoo-x86/app-misc/gkrellm-volume-0.8.ebuild,v 1.0
+# 26 Apr 2001 21:30 CST blutgens Exp $
+
+S=${WORKDIR}/${P}
+DEBPATCH=${PN}_${PV}-1.diff.gz
+DESCRIPTION="GKrellM Plugin that monitors a METAR station and displays weather
+info"
+SRC_URI="http://www.cse.unsw.edu.au/~flam/repository/c/gkrellm/${P}.tar.gz
+ http://ftp.debian.org/debian/pool/main/g/${PN}/${DEBPATCH}"
+HOMEPAGE="http://www.cse.unsw.edu.au/~flam/programs/gkrellweather.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND=">=app-admin/gkrellm-1.2.9
+ >=net-misc/wget-1.5.3"
+
+RDEPEND="${DEPEND}
+ >=sys-devel/perl-5.6.1"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ zcat ${DISTDIR}/${DEBPATCH} | patch -d ${P} -p1
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ exeinto /usr/share/gkrellm
+ doexe GrabWeather
+
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellweather.so
+ dodoc README ChangeLog COPYING
+}