summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-12-31 07:12:28 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-12-31 07:12:28 +0000
commit918819eb0c49703d483aecf26bf3e521f49532b1 (patch)
treefe4c21957bc78eeb38f5379a68a3c036061170ce /x11-plugins/pidgin-facebookchat
parentwhitespace (diff)
downloadgentoo-2-918819eb0c49703d483aecf26bf3e521f49532b1.tar.gz
gentoo-2-918819eb0c49703d483aecf26bf3e521f49532b1.tar.bz2
gentoo-2-918819eb0c49703d483aecf26bf3e521f49532b1.zip
Version bump, gets rid of the "(via Pidgin)" but when setting status message and fixes some rare crashes
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'x11-plugins/pidgin-facebookchat')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog9
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.47.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
index 2b12c512cd09..105b7fbc9055 100644
--- a/x11-plugins/pidgin-facebookchat/ChangeLog
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/pidgin-facebookchat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.14 2008/12/29 10:06:06 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.15 2008/12/31 07:12:28 voyageur Exp $
+
+*pidgin-facebookchat-1.47 (31 Dec 2008)
+
+ 31 Dec 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-facebookchat-1.47.ebuild:
+ Version bump, gets rid of the "(via Pidgin)" but when setting status
+ message and fixes some rare crashes
*pidgin-facebookchat-1.46 (29 Dec 2008)
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.47.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.47.ebuild
new file mode 100644
index 000000000000..271652c8c8b4
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.47.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.47.ebuild,v 1.1 2008/12/31 07:12:28 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-im/pidgin-2.3.0"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Grabbed from makefile
+ FACEBOOK_SOURCES="libfacebook.c fb_blist.c fb_connection.c fb_info.c fb_managefriends.c fb_messages.c fb_notifications.c fb_search.c"
+ # Remove NO_ZLIB when it's working
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -DNO_ZLIB -shared -fPIC -DPIC \
+ ${FACEBOOK_SOURCES} -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}