summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 23:05:10 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 23:05:10 +0000
commit9406c36dcb8289c22b90d5da4c05746e658525e3 (patch)
treed13c4a3808704c66db6b98f3f593accb8ec37b1d /x11-plugins/wmrack/wmrack-1.2.0.ebuild
parentInitial import of x11-plugins/wmblob, version 1.0.1. Closes #54942 (Manifest ... (diff)
downloadgentoo-2-9406c36dcb8289c22b90d5da4c05746e658525e3.tar.gz
gentoo-2-9406c36dcb8289c22b90d5da4c05746e658525e3.tar.bz2
gentoo-2-9406c36dcb8289c22b90d5da4c05746e658525e3.zip
Initial import of x11-plugins/wmrack, version 1.2.0. Closes #54554
Diffstat (limited to 'x11-plugins/wmrack/wmrack-1.2.0.ebuild')
-rw-r--r--x11-plugins/wmrack/wmrack-1.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmrack/wmrack-1.2.0.ebuild b/x11-plugins/wmrack/wmrack-1.2.0.ebuild
new file mode 100644
index 000000000000..cc12a928640d
--- /dev/null
+++ b/x11-plugins/wmrack/wmrack-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmrack/wmrack-1.2.0.ebuild,v 1.1 2004/07/17 23:05:10 s4t4n Exp $
+
+IUSE=""
+MY_P=${P/2.0/2}
+
+DESCRIPTION="A WindowMaker Dock CD+Sound Applet"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://wmrack.sf.net/"
+DEPEND="virtual/x11
+ || ( >=x11-wm/windowmaker-0.62.0
+ x11-wm/windowmaker-cvs )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile()
+{
+ cd ${S}
+ econf --with-x --prefix=/usr --sysconfdir=/etc || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install()
+{
+ cd ${S}
+ einstall MANDIR=${D}/usr/share/man || die "Installation failed"
+
+ dodoc README TODO WARRANTY
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}