summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-14 19:15:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-14 19:15:02 +0000
commit7ff0212f0113fc3a2243c43ba28d6ac9cf6b99be (patch)
tree391873533a7db72ed55dbcd1133b3500b7f91744 /x11-plugins/wmsound
parentInitial commit (diff)
downloadgentoo-2-7ff0212f0113fc3a2243c43ba28d6ac9cf6b99be.tar.gz
gentoo-2-7ff0212f0113fc3a2243c43ba28d6ac9cf6b99be.tar.bz2
gentoo-2-7ff0212f0113fc3a2243c43ba28d6ac9cf6b99be.zip
Update this ancient ebuild to not use /usr/X11R6 anymore. Use toolchain-funcs.eclass to pass correct CC. Convert from "einstall" to "emake install". Missing x11-misc/gccmakedep DEPEND.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmsound')
-rw-r--r--x11-plugins/wmsound/ChangeLog7
-rw-r--r--x11-plugins/wmsound/wmsound-0.9.5.ebuild64
2 files changed, 33 insertions, 38 deletions
diff --git a/x11-plugins/wmsound/ChangeLog b/x11-plugins/wmsound/ChangeLog
index a62b4e22745e..fb629305d4c8 100644
--- a/x11-plugins/wmsound/ChangeLog
+++ b/x11-plugins/wmsound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmsound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsound/ChangeLog,v 1.11 2012/06/14 18:44:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsound/ChangeLog,v 1.12 2012/06/14 19:15:02 ssuominen Exp $
+
+ 14 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> wmsound-0.9.5.ebuild:
+ Update this ancient ebuild to not use /usr/X11R6 anymore. Use
+ toolchain-funcs.eclass to pass correct CC. Convert from "einstall" to "emake
+ install". Missing x11-misc/gccmakedep DEPEND.
14 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> wmsound-0.9.5.ebuild:
x11-libs/libPropList rename to x11-libs/libproplist
diff --git a/x11-plugins/wmsound/wmsound-0.9.5.ebuild b/x11-plugins/wmsound/wmsound-0.9.5.ebuild
index 93fdefdc1f70..be0288613d62 100644
--- a/x11-plugins/wmsound/wmsound-0.9.5.ebuild
+++ b/x11-plugins/wmsound/wmsound-0.9.5.ebuild
@@ -1,56 +1,46 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsound/wmsound-0.9.5.ebuild,v 1.10 2012/06/14 18:44:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsound/wmsound-0.9.5.ebuild,v 1.11 2012/06/14 19:15:02 ssuominen Exp $
-inherit eutils
-
-IUSE=""
+EAPI=4
+inherit eutils multilib toolchain-funcs
DESCRIPTION="WindowMaker sound server"
-SRC_URI="http://largo.windowmaker.org/files/${P}.tar.gz"
HOMEPAGE="http://largo.windowmaker.org/"
+SRC_URI="http://largo.windowmaker.org/files/${P}.tar.gz"
-RDEPEND=">=x11-wm/windowmaker-0.80.2-r1
+RDEPEND="media-sound/wmsound-data
x11-libs/libproplist
- >=media-sound/wmsound-data-1.0.0"
-
+ x11-wm/windowmaker"
DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
x11-misc/imake"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc"
-
-src_unpack()
-{
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/wmsound-config.patch"
- epatch "${FILESDIR}/wmsound-ComplexProgramTargetNoMan.patch"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
- #Fix compilation with --as-needed.
- sed -i 's:-lPropList $(WMSOUNDLIB):$(WMSOUNDLIB) -lPropList:' src/Imakefile
- sed -i 's:-lPropList $(XLIB) $(WMSOUNDLIB):$(WMSOUNDLIB) -lPropList $(XLIB):' utils/Imakefile
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-config.patch \
+ "${FILESDIR}"/${PN}-ComplexProgramTargetNoMan.patch
+
+ # Fix building with -Wl,--as-needed
+ sed -i \
+ -e 's:-lPropList $(WMSOUNDLIB):$(WMSOUNDLIB) -lPropList:' \
+ src/Imakefile || die
+ sed -i \
+ -e 's:-lPropList $(XLIB) $(WMSOUNDLIB):$(WMSOUNDLIB) -lPropList $(XLIB):' \
+ utils/Imakefile || die
}
-src_compile()
-{
- export PATH="${PATH}:/usr/X11R6/bin"
-
- cd "${S}"
- xmkmf -a
- emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "make failed"
+src_compile() {
+ xmkmf -a || die
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}"
}
-src_install()
-{
- cd "${S}"
- einstall PREFIX="${D}/usr" USRLIBDIR="${D}/usr/X11R6/lib" || die "make install failed"
+src_install() {
+ emake PREFIX="${D}/usr" USRLIBDIR="${D}/usr/$(get_libdir)" install
dodoc AUTHORS BUGS ChangeLog
}
-
-pkg_postinst()
-{
- einfo "WMSound currently supports 8 or 16 bit .wav files."
-}