summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 11:25:38 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 11:25:38 +0000
commit60cea2975d15efdae11a0198ef3ea65d92cb41cf (patch)
treec4f0d466860979a51e03c260b712a8b51c6fbd99 /x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
parentVersion bumped, closing bug #56837 (Manifest recommit) (diff)
downloadgentoo-2-60cea2975d15efdae11a0198ef3ea65d92cb41cf.tar.gz
gentoo-2-60cea2975d15efdae11a0198ef3ea65d92cb41cf.tar.bz2
gentoo-2-60cea2975d15efdae11a0198ef3ea65d92cb41cf.zip
Initial import of x11-plugins/wmsystray, version 0.1.1. Closes #54947
Diffstat (limited to 'x11-plugins/wmsystray/wmsystray-0.1.1.ebuild')
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
new file mode 100644
index 000000000000..14cbb0bfeef9
--- /dev/null
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsystray/wmsystray-0.1.1.ebuild,v 1.1 2004/07/17 11:25:37 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
+SRC_URI="http://kai.vm.bytemark.co.uk/~arashi/wmsystray/release/${P}.tar.bz2"
+HOMEPAGE="http://kai.vm.bytemark.co.uk/~arashi/wmsystray/"
+
+DEPEND="virtual/x11"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-cflags.patch
+
+}
+
+src_compile() {
+
+ emake EXTRACFLAGS="${CFLAGS}" || die "Compilation failed"
+
+}
+
+src_install() {
+
+ einstall || die "Installation failed"
+ dodoc AUTHORS HACKING README
+ prepallman
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+
+}