summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2012-01-04 14:29:17 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2012-01-04 14:29:17 +0000
commit18679ce3dde1b41d991a87db58f15378ad01fb5c (patch)
tree25d4864f90910f69c2b3e7aceb73c8a52d7a7083 /x11-plugins
parentVersion bump. (diff)
downloadgentoo-2-18679ce3dde1b41d991a87db58f15378ad01fb5c.tar.gz
gentoo-2-18679ce3dde1b41d991a87db58f15378ad01fb5c.tar.bz2
gentoo-2-18679ce3dde1b41d991a87db58f15378ad01fb5c.zip
Revision bump, with patch to add support for kernel versions >= 3. Closes bug #394105.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmemload/ChangeLog9
-rw-r--r--x11-plugins/wmmemload/files/wmmemload-kernel-3-support.patch13
-rw-r--r--x11-plugins/wmmemload/wmmemload-0.1.6-r1.ebuild33
3 files changed, 53 insertions, 2 deletions
diff --git a/x11-plugins/wmmemload/ChangeLog b/x11-plugins/wmmemload/ChangeLog
index 1104ce218a98..44d668835bf7 100644
--- a/x11-plugins/wmmemload/ChangeLog
+++ b/x11-plugins/wmmemload/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmmemload
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemload/ChangeLog,v 1.19 2008/11/28 18:55:10 tcunha Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemload/ChangeLog,v 1.20 2012/01/04 14:29:17 s4t4n Exp $
+
+*wmmemload-0.1.6-r1 (04 Jan 2012)
+
+ 04 Jan 2012; Michele Noberasco <s4t4n@gentoo.org> wmmemload-0.1.6-r1.ebuild:
+ Revision bump, with patch to add support for kernel versions >= 3. Closes bug #394105.
28 Nov 2008; Tiago Cunha <tcunha@gentoo.org> wmmemload-0.1.6.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmmemload/files/wmmemload-kernel-3-support.patch b/x11-plugins/wmmemload/files/wmmemload-kernel-3-support.patch
new file mode 100644
index 000000000000..601991175323
--- /dev/null
+++ b/x11-plugins/wmmemload/files/wmmemload-kernel-3-support.patch
@@ -0,0 +1,13 @@
+--- wmmemload-0.1.6/src/mem_linux.c 2003-11-03 22:06:39.000000000 +0000
++++ wmmemload-0.1.6/src/mem_linux.c 2011-11-12 11:05:13.000000000 +0000
+@@ -49,8 +49,9 @@
+
+ /* new format ? (kernel >= 2.5.1pre?) */
+ /* see linux/fs/proc/proc_misc.c */
+- if (version >= 2 && patchlevel >= 5 && sublevel >= 1 || \
+- version >= 2 && patchlevel >= 6 && sublevel >= 0)
++ if (version == 2 && patchlevel >= 5 && sublevel >= 1 || \
++ version == 2 && patchlevel >= 6 && sublevel >= 0 || \
++ version >2 )
+ isnewformat = 1;
+ }
diff --git a/x11-plugins/wmmemload/wmmemload-0.1.6-r1.ebuild b/x11-plugins/wmmemload/wmmemload-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..463819a30717
--- /dev/null
+++ b/x11-plugins/wmmemload/wmmemload-0.1.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmemload/wmmemload-0.1.6-r1.ebuild,v 1.1 2012/01/04 14:29:17 s4t4n Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="dockapp that displays memory and swap space usage."
+HOMEPAGE="http://www.markstaggs.net/wmmemload"
+SRC_URI="http://markstaggs.net/${PN}-download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kernel-3-support.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog THANKS
+}