summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-01 14:00:23 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-01 14:00:23 +0000
commitdc02d874bcbdda484364db93c35910de2b199840 (patch)
treee64f2a9968872c868ec6e16c8819856aa8a67510 /x11-plugins
parentx86 stable, bug #208045 (diff)
downloadgentoo-2-dc02d874bcbdda484364db93c35910de2b199840.tar.gz
gentoo-2-dc02d874bcbdda484364db93c35910de2b199840.tar.bz2
gentoo-2-dc02d874bcbdda484364db93c35910de2b199840.zip
Revision bump, with lots of fixes (see CL). Closes bug #207888.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmSpaceWeather/ChangeLog10
-rw-r--r--x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch61
-rw-r--r--x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch27
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild64
4 files changed, 161 insertions, 1 deletions
diff --git a/x11-plugins/wmSpaceWeather/ChangeLog b/x11-plugins/wmSpaceWeather/ChangeLog
index 0ae615834d23..6a4e43de9dd9 100644
--- a/x11-plugins/wmSpaceWeather/ChangeLog
+++ b/x11-plugins/wmSpaceWeather/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/wmSpaceWeather
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSpaceWeather/ChangeLog,v 1.11 2007/07/22 05:32:16 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSpaceWeather/ChangeLog,v 1.12 2008/02/01 14:00:22 s4t4n Exp $
+
+*wmSpaceWeather-1.04_p19 (08 Feb 2008)
+
+ 08 Feb 2008; Michele Noberasco <s4t4n@gentoo.org>
+ wmSpaceWeather-1.04_p19.ebuild :
+ Revision bump, with debian patchset, new SRC_URI and HOMEPAGE,
+ data locations. Now it also honour LDFLAGS, crosscompile, dependancies,
+ etc. Closes bug #207888.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
wmSpaceWeather-1.04.ebuild:
diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch
new file mode 100644
index 000000000000..29cb5f984f13
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-gentoo.patch
@@ -0,0 +1,61 @@
+--- wmSpaceWeather/Makefile.orig 2008-01-28 02:45:07.000000000 +0100
++++ wmSpaceWeather/Makefile 2008-01-28 02:46:04.000000000 +0100
+@@ -1,8 +1,8 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11
++PREFIX = /usr
++LIBDIR ?= /usr/lib
+ # for linux
+ LIBS = -lXpm -lX11 -lXext
+ # for Solaris
+@@ -12,14 +12,14 @@
+
+
+ .c.o:
+- $(CC) $(COPTS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+
+
+ all: wmSpaceWeather.o wmSpaceWeather
+
+ wmSpaceWeather.o: wmSpaceWeather_master.xpm wmSpaceWeather_mask.xbm
+ wmSpaceWeather: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -o wmSpaceWeather $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) -o wmSpaceWeather $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+ clean:
+ for i in $(OBJS) ; do \
+@@ -28,10 +28,10 @@
+ rm -f wmSpaceWeather
+
+ install:: wmSpaceWeather
+- install -d $(DESTDIR)/usr/bin
+- install -d $(DESTDIR)/usr/share/wmspaceweather
+- install -d $(DESTDIR)/usr/share/man/man1
+- install -m 0755 wmSpaceWeather $(DESTDIR)/usr/bin
+- install -m 0755 GetKp $(DESTDIR)/usr/share/wmspaceweather
+- install -m 0644 wmSpaceWeather.1 $(DESTDIR)/usr/share/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -d $(DESTDIR)$(PREFIX)/share/wmspaceweather
++ install -d $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 0755 wmSpaceWeather $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 GetKp $(DESTDIR)$(PREFIX)/share/wmspaceweather
++ install -m 0644 wmSpaceWeather.1 $(DESTDIR)$(PREFIX)/share/man/man1
+
+--- wmSpaceWeather/wmSpaceWeather.c.orig 2008-01-28 03:16:36.000000000 +0100
++++ wmSpaceWeather/wmSpaceWeather.c 2008-01-28 03:22:12.000000000 +0100
+@@ -663,7 +663,7 @@
+ if (GotDoubleClick1) {
+ GotFirstClick1 = 0;
+ GotDoubleClick1 = 0;
+- sprintf(Command, "sensible-browser '%s' &", URL);
++ sprintf(Command, "firefox -remote 'openURL(%s)'", URL);
+ system(Command);
+ }
+
diff --git a/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch
new file mode 100644
index 000000000000..6d6d90137feb
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/files/wmSpaceWeather-1.04_p19-getkp.patch
@@ -0,0 +1,27 @@
+--- wmSpaceWeather/GetKp.orig 2008-01-28 14:20:43.000000000 +0100
++++ wmSpaceWeather/GetKp 2008-01-28 14:22:48.000000000 +0100
+@@ -17,10 +17,10 @@
+ unlink(CUR_INDEX);
+
+
+-# $grabcmd = "cd /tmp; /usr/bin/wget -q ftp://www.sec.noaa.gov/pub/indices/DGD.txt";
++# $grabcmd = "cd /tmp; /usr/bin/wget -q http://www.swpc.noaa.gov/ftpdir/indices/DGD.txt";
+ # system "$grabcmd";
+ #
+- $grabcmd = "/usr/bin/curl -f -s -o " . DGD_FILE . " http://www.sec.noaa.gov/ftpdir/indices/DGD.txt";
++ $grabcmd = "/usr/bin/curl -f -s -o " . DGD_FILE . " http://www.swpc.noaa.gov/ftpdir/indices/DGD.txt";
+ exit 1 if (system "$grabcmd");
+
+
+@@ -69,9 +69,9 @@
+ #
+ # Add in very latest stuff
+ #
+-# $grabcmd = "cd /tmp; /usr/bin/wget -q ftp://www.sec.noaa.gov/pub/latest/curind.txt";
++# $grabcmd = "cd /tmp; /usr/bin/wget -q http://www.swpc.noaa.gov/ftpdir/latest/curind.txt";
+ # system "$grabcmd";
+- $grabcmd = "/usr/bin/curl -f -s -o " . CUR_INDEX . " http://www.sec.noaa.gov/ftpdir/latest/curind.txt";
++ $grabcmd = "/usr/bin/curl -f -s -o " . CUR_INDEX . " http://www.swpc.noaa.gov/ftpdir/latest/curind.txt";
+ exit 1 if (system "$grabcmd");
+ %lmonstr = ( "Jan", 1, "Feb", 2, "Mar", 3, "Apr", 4, "May", 5, "Jun", 6, "Jul", 7, "Aug", 8, "Sep", 9, "Oct", 10, "Nov", 11, "Dec", 12);
+
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild
new file mode 100644
index 000000000000..19b4940b3bc8
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19.ebuild,v 1.1 2008/02/01 14:00:22 s4t4n Exp $
+
+inherit eutils multilib toolchain-funcs
+
+MY_PN="wmspaceweather"
+MY_PV_ORIG="${PV/_p*}"
+MY_PV_PATCH="${PV/_p/-}"
+MY_P_ORIG="${MY_PN}_${MY_PV_ORIG}.orig"
+MY_P_PATCH="${MY_PN}_${MY_PV_PATCH}.diff"
+
+DESCRIPTION="dockapp showing weather at geosynchronous orbit."
+HOMEPAGE="http://packages.debian.org/sid/wmspaceweather"
+SRC_URI="mirror://debian/pool/main/w/${MY_PN}/${MY_P_ORIG}.tar.gz
+ mirror://debian/pool/main/w/${MY_PN}/${MY_P_PATCH}.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~mips ~hppa ~ppc ~sparc"
+IUSE=""
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+RDEPEND="${CDEPEND}
+ net-misc/curl
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
+
+src_unpack() {
+ unpack ${MY_P_ORIG}.tar.gz
+ epatch "${DISTDIR}"/${MY_P_PATCH}.gz
+
+ # need to apply patches from Debian first, do NOT change the order
+ cd "${S}"
+ mv ../debian/patches "${WORKDIR}"/patch
+ EPATCH_SUFFIX="dpatch" EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying Debian patches ..." epatch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-getkp.patch
+}
+
+src_compile() {
+ emake clean || die "make clean failed"
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "parallel make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die install failed
+ dodoc ../{BUGS,CHANGES,HINTS,README}
+}
+
+pkg_postinst() {
+ elog "You need to emerge www-client/mozilla-firefox or www-client/mozilla-firefox-bin"
+ elog "to use the -url functionality - see man ${PN} for more info."
+ elog
+ elog "This version uses curl instead of wget. You may edit /usr/share/wmspaceweather/GetKp"
+ elog "if you don't like it."
+}