summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-10 09:53:27 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-06-10 09:53:27 +0000
commit57e68ef0cd6b4ea69809d5e50feaa074880eca90 (patch)
treee0c7f2271a5d5638ad8337a68673a51d961bd3f7 /x11-proto/xproto
parentChange useflag 'qt' to 'qt4', add dependencies (diff)
downloadgentoo-2-57e68ef0cd6b4ea69809d5e50feaa074880eca90.tar.gz
gentoo-2-57e68ef0cd6b4ea69809d5e50feaa074880eca90.tar.bz2
gentoo-2-57e68ef0cd6b4ea69809d5e50feaa074880eca90.zip
Apply patch for x32 support, bug #395363.
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto/xproto')
-rw-r--r--x11-proto/xproto/ChangeLog8
-rw-r--r--x11-proto/xproto/files/xproto-7.0.23-Xmd_h_x32.patch34
-rw-r--r--x11-proto/xproto/xproto-7.0.23-r1.ebuild29
3 files changed, 70 insertions, 1 deletions
diff --git a/x11-proto/xproto/ChangeLog b/x11-proto/xproto/ChangeLog
index 8ec767e1d10e..c5e76b8f0126 100644
--- a/x11-proto/xproto/ChangeLog
+++ b/x11-proto/xproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xproto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xproto/ChangeLog,v 1.135 2012/04/26 18:30:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xproto/ChangeLog,v 1.136 2012/06/10 09:53:27 chithanh Exp $
+
+*xproto-7.0.23-r1 (10 Jun 2012)
+
+ 10 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xproto-7.0.23-Xmd_h_x32.patch, +xproto-7.0.23-r1.ebuild:
+ Apply patch for x32 support, bug #395363.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> xproto-7.0.23.ebuild:
keyword ~amd64-fbsd
diff --git a/x11-proto/xproto/files/xproto-7.0.23-Xmd_h_x32.patch b/x11-proto/xproto/files/xproto-7.0.23-Xmd_h_x32.patch
new file mode 100644
index 000000000000..f141c79befff
--- /dev/null
+++ b/x11-proto/xproto/files/xproto-7.0.23-Xmd_h_x32.patch
@@ -0,0 +1,34 @@
+From a06fa7fc98b66652df8bbc4734b5010d43744373 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@gentoo.org>
+Date: Tue, 20 Dec 2011 13:43:44 +0000
+Subject: Xmd.h: Treat __ILP32__ targets as LONG32 ones
+
+amd64-x32 ABI defines sizeof(long) == sizeof (void*) == 4
+
+Noticed on build failure of libXmu:
+ libXmu-1.1.0/work/libXmu-1.1.0/src/EditresCom.c: In function '_XEditresGetStringValues':
+ libXmu-1.1.0/work/libXmu-1.1.0/src/EditresCom.c:2198:6: error: duplicate case value
+ libXmu-1.1.0/work/libXmu-1.1.0/src/EditresCom.c:2194:6: error: previously used here
+
+More info about x32: https://sites.google.com/site/x32abi/
+
+Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
+Signed-off-by: James Cloos <cloos@jhcloos.com>
+---
+diff --git a/Xmd.h b/Xmd.h
+index f3868b3..96cc08f 100644
+--- a/Xmd.h
++++ b/Xmd.h
+@@ -64,7 +64,9 @@ SOFTWARE.
+ defined(__s390x__) || \
+ defined(__amd64__) || defined(amd64) || \
+ defined(__powerpc64__)
+-# define LONG64 /* 32/64-bit architecture */
++# if !defined(__ILP32__) /* amd64-x32 is 32bit */
++# define LONG64 /* 32/64-bit architecture */
++# endif /* !__ILP32__ */
+ # endif
+
+ /*
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-proto/xproto/xproto-7.0.23-r1.ebuild b/x11-proto/xproto/xproto-7.0.23-r1.ebuild
new file mode 100644
index 000000000000..753276b11386
--- /dev/null
+++ b/x11-proto/xproto/xproto-7.0.23-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xproto/xproto-7.0.23-r1.ebuild,v 1.1 2012/06/10 09:53:27 chithanh Exp $
+
+EAPI=4
+
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org xproto protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.23-Xmd_h_x32.patch
+)
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}