summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-06-09 14:55:41 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-06-09 14:55:41 +0000
commitcba1c69bc5518ecd7ce1e0d6a14fdce1d9e3d692 (patch)
treeac693fd28a2dad619ba07d949ca7d28b08a648a6 /x11-terms
parentVersion bump (diff)
downloadgentoo-2-cba1c69bc5518ecd7ce1e0d6a14fdce1d9e3d692.tar.gz
gentoo-2-cba1c69bc5518ecd7ce1e0d6a14fdce1d9e3d692.tar.bz2
gentoo-2-cba1c69bc5518ecd7ce1e0d6a14fdce1d9e3d692.zip
Version bumped. Added debug, libssh and xft USE flags.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mlterm/ChangeLog9
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.5-ibus.patch55
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.5-ldflags.patch264
-rw-r--r--x11-terms/mlterm/metadata.xml1
-rw-r--r--x11-terms/mlterm/mlterm-3.0.5.ebuild92
5 files changed, 420 insertions, 1 deletions
diff --git a/x11-terms/mlterm/ChangeLog b/x11-terms/mlterm/ChangeLog
index 7ea40de61f3b..5b92fdf4bb11 100644
--- a/x11-terms/mlterm/ChangeLog
+++ b/x11-terms/mlterm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-terms/mlterm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.77 2011/05/11 23:13:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.78 2011/06/09 14:55:41 matsuu Exp $
+
+*mlterm-3.0.5 (09 Jun 2011)
+
+ 09 Jun 2011; MATSUU Takuto <matsuu@gentoo.org> +mlterm-3.0.5.ebuild,
+ +files/mlterm-3.0.5-ibus.patch, +files/mlterm-3.0.5-ldflags.patch,
+ metadata.xml:
+ Version bumped. Added debug, libssh and xft USE flags.
*mlterm-3.0.3 (11 May 2011)
diff --git a/x11-terms/mlterm/files/mlterm-3.0.5-ibus.patch b/x11-terms/mlterm/files/mlterm-3.0.5-ibus.patch
new file mode 100644
index 000000000000..22b78301379a
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.5-ibus.patch
@@ -0,0 +1,55 @@
+diff -Naur mlterm-3.0.5.orig/configure.in mlterm-3.0.5/configure.in
+--- mlterm-3.0.5.orig/configure.in 2011-06-04 01:26:40.000000000 +0900
++++ mlterm-3.0.5/configure.in 2011-06-09 10:45:00.653322007 +0900
+@@ -671,7 +671,8 @@
+ if test "x$ibus" = "xyes" ; then
+ AC_PROG_CXX
+ PKG_CHECK_MODULES(IBUS, ibus-1.0 >= 1.3.0, has_ibus=yes, has_ibus=no)
+- if test "x$has_ibus" = xyes ; then
++ PKG_CHECK_MODULES(DBUS, dbus-1, has_dbus=yes, has_dbus=no)
++ if test "x$has_ibus" = xyes -a "x$has_dbus" = xyes ; then
+ IM_CFLAGS="$IM_CFLAGS -DUSE_IBUS"
+ MAKE_DIRS="inputmethod/ibus ${MAKE_DIRS}"
+ OUTPUT_FILES="inputmethod/ibus/Makefile ${OUTPUT_FILES}"
+@@ -683,6 +684,8 @@
+ fi
+ AC_SUBST(IBUS_CFLAGS)
+ AC_SUBST(IBUS_LIBS)
++AC_SUBST(DBUS_CFLAGS)
++AC_SUBST(DBUS_LIBS)
+
+ #
+ # --- SCIM ---
+diff -Naur mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in mlterm-3.0.5/inputmethod/ibus/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/ibus/Makefile.in 2011-06-09 10:45:31.063416229 +0900
+@@ -19,11 +19,12 @@
+ @CPPFLAGS@ \
+ @IM_CFLAGS@ \
+ @IBUS_CFLAGS@ \
++ @DBUS_CFLAGS@ \
+ -I$(top_srcdir)/mlterm \
+ -I${top_srcdir}/xwindow \
+ -I/usr/local/include
+
+-LIBS = $(LIBS_LOCAL) @KIK_LIBS_FOR_MODULE@ @IBUS_LIBS@
++LIBS = $(LIBS_LOCAL) @KIK_LIBS_FOR_MODULE@ @IBUS_LIBS@ @DBUS_LIBS@
+
+ CC = @CC@
+ INSTALL = @INSTALL@
+diff -Naur mlterm-3.0.5.orig/inputmethod/ibus/im_ibus.c mlterm-3.0.5/inputmethod/ibus/im_ibus.c
+--- mlterm-3.0.5.orig/inputmethod/ibus/im_ibus.c 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/ibus/im_ibus.c 2011-06-09 10:39:58.560385917 +0900
+@@ -4,11 +4,11 @@
+
+ #include <stdio.h>
+ #include <ibus.h>
++#include <dbus/dbus.h>
+ #include <x_im.h>
+ #include <kiklib/kik_list.h>
+ #include <kiklib/kik_debug.h>
+ #include "../im_info.h"
+-
+ #if 0
+ #define IM_IBUS_DEBUG 1
+ #endif
diff --git a/x11-terms/mlterm/files/mlterm-3.0.5-ldflags.patch b/x11-terms/mlterm/files/mlterm-3.0.5-ldflags.patch
new file mode 100644
index 000000000000..f422c1a7688f
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.5-ldflags.patch
@@ -0,0 +1,264 @@
+diff -Naur mlterm-3.0.5.orig/contrib/scrollbar/extra/Makefile.in mlterm-3.0.5/contrib/scrollbar/extra/Makefile.in
+--- mlterm-3.0.5.orig/contrib/scrollbar/extra/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/scrollbar/extra/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -20,7 +20,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/contrib/scrollbar/pixmap_engine/Makefile.in mlterm-3.0.5/contrib/scrollbar/pixmap_engine/Makefile.in
+--- mlterm-3.0.5.orig/contrib/scrollbar/pixmap_engine/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/scrollbar/pixmap_engine/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -20,7 +20,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in mlterm-3.0.5/contrib/tool/mlcc/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlcc/Makefile.in 2011-06-09 23:29:02.851741057 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJECTS)
+- $(CC) -g -o $(PROG) $(OBJECTS)
++ $(CC) -g -o $(PROG) $(OBJECTS) $(LDFLAGS)
+
+ .SUFFIXES: .c.o
+
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlterm-menu/Makefile.in mlterm-3.0.5/contrib/tool/mlterm-menu/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlterm-menu/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlterm-menu/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -30,7 +30,7 @@
+
+ LIBS = $(LIBS1) $(LIBS2@WIN32TAG@)
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlterm-zoom/Makefile.in mlterm-3.0.5/contrib/tool/mlterm-zoom/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlterm-zoom/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlterm-zoom/Makefile.in 2011-06-09 19:35:38.745471044 +0900
+@@ -21,7 +21,7 @@
+ LIBS = $(LIBS_LOCAL) @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+ #LIBS = $(LIBS_LOCAL) @X_LIBS@ @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/gtk/Makefile.in mlterm-3.0.5/gtk/Makefile.in
+--- mlterm-3.0.5.orig/gtk/Makefile.in 2011-06-04 01:26:09.000000000 +0900
++++ mlterm-3.0.5/gtk/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -18,7 +18,7 @@
+ -DSYSCONFDIR=\"$(SYSCONFDIR)\" @VTE_CFLAGS@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ OBJ = vte.o marshal.o vtetypebuiltins.o reaper.o
+diff -Naur mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in mlterm-3.0.5/inputmethod/ibus/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/ibus/Makefile.in 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/ibus/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/iiimf/Makefile.in mlterm-3.0.5/inputmethod/iiimf/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/iiimf/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/iiimf/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/kbd/Makefile.in mlterm-3.0.5/inputmethod/kbd/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/kbd/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/kbd/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -28,7 +28,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/m17nlib/Makefile.in mlterm-3.0.5/inputmethod/m17nlib/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/m17nlib/Makefile.in 2011-06-04 01:26:37.000000000 +0900
++++ mlterm-3.0.5/inputmethod/m17nlib/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/inputmethod/scim/Makefile.in mlterm-3.0.5/inputmethod/scim/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/scim/Makefile.in 2011-06-04 01:26:34.000000000 +0900
++++ mlterm-3.0.5/inputmethod/scim/Makefile.in 2011-06-09 19:35:38.746471084 +0900
+@@ -33,7 +33,7 @@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+ LIBTOOL_CXX = $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c .cpp
+diff -Naur mlterm-3.0.5.orig/inputmethod/uim/Makefile.in mlterm-3.0.5/inputmethod/uim/Makefile.in
+--- mlterm-3.0.5.orig/inputmethod/uim/Makefile.in 2011-06-04 01:26:35.000000000 +0900
++++ mlterm-3.0.5/inputmethod/uim/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -30,7 +30,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/kiklib/src/Makefile.in mlterm-3.0.5/kiklib/src/Makefile.in
+--- mlterm-3.0.5.orig/kiklib/src/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/kiklib/src/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -30,7 +30,7 @@
+ INC = $(COMOBJ:.o=.h) kik_list.h kik_iterator.h kik_types.h kik_util.h kik_def.h kik_net.h kik_pty.h kik_utmp.h kik_dlfcn.h
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LIBS)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LIBS) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ LIBNAME=libkik
+diff -Naur mlterm-3.0.5.orig/mkf/lib/Makefile.in mlterm-3.0.5/mkf/lib/Makefile.in
+--- mlterm-3.0.5.orig/mkf/lib/Makefile.in 2011-06-04 01:26:16.000000000 +0900
++++ mlterm-3.0.5/mkf/lib/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -52,7 +52,7 @@
+ MINOR = 0
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+
+diff -Naur mlterm-3.0.5.orig/mkf/libtbl/Makefile.in mlterm-3.0.5/mkf/libtbl/Makefile.in
+--- mlterm-3.0.5.orig/mkf/libtbl/Makefile.in 2011-06-04 01:26:15.000000000 +0900
++++ mlterm-3.0.5/mkf/libtbl/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -24,7 +24,7 @@
+ OBJ = $(JAJP_TABLE_OBJ) $(KOKR_TABLE_OBJ) $(ZH_TABLE_OBJ) $(BYTE_TABLE_OBJ)
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: libmkf_jajp.la libmkf_kokr.la libmkf_zh.la libmkf_8bits.la
+diff -Naur mlterm-3.0.5.orig/mlterm/Makefile.in mlterm-3.0.5/mlterm/Makefile.in
+--- mlterm-3.0.5.orig/mlterm/Makefile.in 2011-06-04 01:26:09.000000000 +0900
++++ mlterm-3.0.5/mlterm/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -33,7 +33,7 @@
+ MINOR = 0
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+
+diff -Naur mlterm-3.0.5.orig/scrollbar/sample/Makefile.in mlterm-3.0.5/scrollbar/sample/Makefile.in
+--- mlterm-3.0.5.orig/scrollbar/sample/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/scrollbar/sample/Makefile.in 2011-06-09 19:35:38.747471138 +0900
+@@ -33,7 +33,7 @@
+ LIBTOOL = @LIBTOOL@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ .SUFFIXES: .o .c
+diff -Naur mlterm-3.0.5.orig/tool/mlclient/Makefile.in mlterm-3.0.5/tool/mlclient/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlclient/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlclient/Makefile.in 2011-06-09 23:27:57.251467757 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJ)
+- $(CC) -o $(PROG) $(OBJ) $(LIBS)
++ $(CC) -o $(PROG) $(OBJ) $(LIBS) $(LDFLAGS)
+ cp $(PROG) $(PROG)x
+
+ .SUFFIXES: .c.o
+diff -Naur mlterm-3.0.5.orig/tool/mlconfig/Makefile.in mlterm-3.0.5/tool/mlconfig/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlconfig/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlconfig/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -42,7 +42,7 @@
+
+ LIBS = $(LIBS1) $(LIBS2@WIN32TAG@)
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/tool/mlimgloader/Makefile.in mlterm-3.0.5/tool/mlimgloader/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlimgloader/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlimgloader/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -32,7 +32,7 @@
+ INSTALL_OPT = @INSTALL_OPT@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: $(PROG)
+diff -Naur mlterm-3.0.5.orig/tool/mlmenu/Makefile.in mlterm-3.0.5/tool/mlmenu/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlmenu/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlmenu/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -18,7 +18,7 @@
+ LIBS = $(LIBS_LOCAL) @X_LIBS@ -lX11 @X_EXTRA_LIBS@
+ #LIBS = $(LIBS_LOCAL) @X_LIBS@ @X_PRE_LIBS@ -lX11 @X_EXTRA_LIBS@
+
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ PACKAGE = @PACKAGE@
+diff -Naur mlterm-3.0.5.orig/xwindow/Makefile.in mlterm-3.0.5/xwindow/Makefile.in
+--- mlterm-3.0.5.orig/xwindow/Makefile.in 2011-06-04 01:26:10.000000000 +0900
++++ mlterm-3.0.5/xwindow/Makefile.in 2011-06-09 19:35:38.748471200 +0900
+@@ -64,7 +64,7 @@
+ INSTALL_OPT = @INSTALL_OPT@
+
+ LIBTOOL_CC = $(LIBTOOL) --mode=compile $(CC) $(CFLAGS)
+-LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC)
++LIBTOOL_LINK = $(LIBTOOL) --mode=link $(CC) $(LDFLAGS)
+ LIBTOOL_INSTALL = $(LIBTOOL) --mode=install $(INSTALL)
+
+ all: $(PROG)
diff --git a/x11-terms/mlterm/metadata.xml b/x11-terms/mlterm/metadata.xml
index 38c44c69a73e..259c2bc2e074 100644
--- a/x11-terms/mlterm/metadata.xml
+++ b/x11-terms/mlterm/metadata.xml
@@ -4,6 +4,7 @@
<herd>cjk</herd>
<use>
<flag name='ibus'>Enable <pkg>app-i18n/ibus</pkg> support</flag>
+ <flag name='libssh2'>Enable <pkg>net-libs/libssh2</pkg> support</flag>
<flag name='scim'>Enable <pkg>app-i18n/scim</pkg> support</flag>
<flag name='uim'>Enable <pkg>app-i18n/uim</pkg> support</flag>
</use>
diff --git a/x11-terms/mlterm/mlterm-3.0.5.ebuild b/x11-terms/mlterm/mlterm-3.0.5.ebuild
new file mode 100644
index 000000000000..52596e1cae3c
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.0.5.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-3.0.5.ebuild,v 1.1 2011/06/09 14:55:41 matsuu Exp $
+
+EAPI="3"
+inherit autotools eutils
+
+IUSE="bidi debug gtk ibus libssh2 m17n-lib nls scim static-libs uim xft"
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlterm/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="BSD"
+
+RDEPEND="|| ( sys-libs/libutempter sys-apps/utempter )
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ gtk? ( x11-libs/gtk+:2 )
+ xft? ( x11-libs/libXft )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ ibus? ( >=app-i18n/ibus-1.3 )
+ libssh2? ( net-libs/libssh2 )
+ nls? ( virtual/libintl )
+ uim? ( >=app-i18n/uim-1.0 )
+ scim? ( >=app-i18n/scim-1.4 )
+ m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )"
+# vte? ( x11-libs/vte )
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.9.4-uim15-fix.patch \
+ "${FILESDIR}"/${PN}-3.0.5-ldflags.patch \
+ "${FILESDIR}"/${PN}-3.0.5-ibus.patch
+
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ if use gtk ; then
+ myconf="${myconf} --with-imagelib=gdk-pixbuf"
+ else
+ myconf="${myconf} --with-tools=mlclient,mlcc"
+ fi
+
+ if use xft ; then
+ myconf="${myconf} --with-type-engines=xft"
+ else
+ myconf="${myconf} --with-type-engines=xcore"
+ fi
+
+ # iiimf isn't stable enough
+ #myconf="${myconf} $(use_enable iiimf)"
+
+ econf --enable-utmp \
+ $(use_enable bidi fribidi) \
+ $(use_enable debug) \
+ $(use_enable ibus) \
+ $(use_enable libssh2 ssh2) \
+ $(use_enable nls) \
+ $(use_enable uim) \
+ $(use_enable scim) \
+ $(use_enable m17n-lib m17nlib) \
+ $(use_enable static-libs static) \
+ ${myconf} || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+
+ doicon contrib/icon/mlterm* || die
+ make_desktop_entry mlterm mlterm mlterm-icon TerminalEmulator || die
+
+ dodoc ChangeLog README || die
+
+ docinto ja
+ dodoc doc/ja/* || die
+ docinto en
+ dodoc doc/en/* || die
+}