summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-05-24 23:44:35 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-05-24 23:44:35 +0000
commitf71d9f4b710aa757bf98be030125535bc4675e05 (patch)
treecf3bb29f90127ca371f97d1d2427ac5f67c98695 /x11-terms
parentFixed SRC_URI. (diff)
downloadgentoo-2-f71d9f4b710aa757bf98be030125535bc4675e05.tar.gz
gentoo-2-f71d9f4b710aa757bf98be030125535bc4675e05.tar.bz2
gentoo-2-f71d9f4b710aa757bf98be030125535bc4675e05.zip
(#87320) Version bump.
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/pssh/ChangeLog9
-rw-r--r--x11-terms/pssh/files/digest-pssh-1.2.01
-rw-r--r--x11-terms/pssh/pssh-1.2.0.ebuild38
3 files changed, 46 insertions, 2 deletions
diff --git a/x11-terms/pssh/ChangeLog b/x11-terms/pssh/ChangeLog
index 258ad03c93d8..fbb624793169 100644
--- a/x11-terms/pssh/ChangeLog
+++ b/x11-terms/pssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/pssh
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.3 2004/11/04 11:17:36 voxus Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/ChangeLog,v 1.4 2005/05/24 23:44:35 spyderous Exp $
+
+*pssh-1.2.0 (24 May 2005)
+
+ 24 May 2005; Donnie Berkholz <spyderous@gentoo.org>; +pssh-1.2.0.ebuild:
+ (#87320) Version bump.
*pssh-1.0.0 (04 Nov 2004)
diff --git a/x11-terms/pssh/files/digest-pssh-1.2.0 b/x11-terms/pssh/files/digest-pssh-1.2.0
new file mode 100644
index 000000000000..1f0522dc82fd
--- /dev/null
+++ b/x11-terms/pssh/files/digest-pssh-1.2.0
@@ -0,0 +1 @@
+MD5 9298a4323ff17f5457661bd721da4ecd pssh-1.2.0.tar.gz 33580
diff --git a/x11-terms/pssh/pssh-1.2.0.ebuild b/x11-terms/pssh/pssh-1.2.0.ebuild
new file mode 100644
index 000000000000..c9caffba037a
--- /dev/null
+++ b/x11-terms/pssh/pssh-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/pssh/pssh-1.2.0.ebuild,v 1.1 2005/05/24 23:44:35 spyderous Exp $
+
+DESCRIPTION="This package provides parallel versions of the openssh tools."
+HOMEPAGE="http://www.theether.org/pssh/"
+SRC_URI="http://www.theether.org/pssh/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.2"
+RDEPEND="net-misc/openssh"
+
+src_install() {
+ dodoc AUTHORS COPYING TODO COPYING
+
+# FIXME: how can i get current python version?
+ PY_VER=`ls /usr/lib | grep python | sort | tail -n 1`
+ PY_DIR=/usr/lib/${PY_VER}/site-packages
+
+ cd bin
+
+ for n in `ls`;
+ do
+ sed -e "s/python2\.2/${PY_VER/\./\\.}/" $n > $n.v
+ mv $n.v $n
+ done;
+
+ dobin {pnuke,prsync,pscp,pslurp,pssh}
+
+ cd ..
+
+ insinto ${PY_DIR}
+ doins `find lib -type f`
+}