summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-20 15:29:14 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-20 15:29:14 +0000
commit457db6b4b02f1533af5033adc0cdfcfa316de4c2 (patch)
treeaa4bf2484df11c3fdb94560e78a2a15f26baa5d9 /x11-themes/gtk-theme-switch
parentMove pkgconfig to DEPEND from RDEPEND. (diff)
downloadgentoo-2-457db6b4b02f1533af5033adc0cdfcfa316de4c2.tar.gz
gentoo-2-457db6b4b02f1533af5033adc0cdfcfa316de4c2.tar.bz2
gentoo-2-457db6b4b02f1533af5033adc0cdfcfa316de4c2.zip
Move pkgconfig from RDEPEND to DEPEND. Use toolchain-funcs for CC, respect CFLAGS, use emake, use die messages and fix quoting.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'x11-themes/gtk-theme-switch')
-rw-r--r--x11-themes/gtk-theme-switch/ChangeLog9
-rw-r--r--x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild29
2 files changed, 22 insertions, 16 deletions
diff --git a/x11-themes/gtk-theme-switch/ChangeLog b/x11-themes/gtk-theme-switch/ChangeLog
index 701b5450a286..afa0075235c4 100644
--- a/x11-themes/gtk-theme-switch/ChangeLog
+++ b/x11-themes/gtk-theme-switch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gtk-theme-switch
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.36 2007/12/25 15:24:22 phreak Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/ChangeLog,v 1.37 2008/04/20 15:29:14 drac Exp $
+
+ 20 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ gtk-theme-switch-2.0.0_rc2-r2.ebuild:
+ Move pkgconfig from RDEPEND to DEPEND. Use toolchain-funcs for CC, respect
+ CFLAGS, use emake, use die messages and fix quoting.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing seemant from metadata.xml as per #202469.
diff --git a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild
index 0f2e76cd3d44..712a508d2620 100644
--- a/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild
+++ b/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild
@@ -1,40 +1,41 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild,v 1.10 2006/10/09 20:11:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-theme-switch/gtk-theme-switch-2.0.0_rc2-r2.ebuild,v 1.11 2008/04/20 15:29:14 drac Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P=${P/_/}
-S=${WORKDIR}/${MY_P}
+
DESCRIPTION="Application for easy change of GTK-Themes"
HOMEPAGE="http://www.muhri.net/nav.php3?node=gts"
SRC_URI="http://www.muhri.net/${MY_P}.tar.gz
mirror://gentoo/${MY_P}b.patch.gz"
-SLOT="2"
LICENSE="GPL-2"
+SLOT="2"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="=x11-libs/gtk+-2*
+RDEPEND="=x11-libs/gtk+-2*"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
+S=${WORKDIR}/${MY_P}
+
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${WORKDIR}/${MY_P}b.patch
-
- # fix compilation with gtk+-2.4 (#45105)
- epatch ${FILESDIR}/${P}-gtk+-2.4_fix.patch
-
+ cd "${S}"
+ epatch "${WORKDIR}"/${MY_P}b.patch \
+ "${FILESDIR}"/${P}-gtk+-2.4_fix.patch
}
src_compile() {
- make || die
+ emake GCC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall $(pkg-config --cflags gtk+-2.0)" \
+ || die "emake failed."
}
src_install() {
-
dobin switch2
newman switch.1 gtk-theme-switch2.1
dosym gtk-theme-switch2.1 /usr/share/man/man1/switch2.1