summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr@gentoo.org>2003-11-11 21:09:33 +0000
committerLuke Dashjr <luke-jr@gentoo.org>2003-11-11 21:09:33 +0000
commitc830c7f68d0fa3daec1bcd456124d7697eabe088 (patch)
tree9f4a0e6cfca15964f85373ac276462ecd7aeca6e /x11-themes/psi-themes/psi-themes-0.8.8.ebuild
parentAdded new / missing icon themes (diff)
downloadgentoo-2-c830c7f68d0fa3daec1bcd456124d7697eabe088.tar.gz
gentoo-2-c830c7f68d0fa3daec1bcd456124d7697eabe088.tar.bz2
gentoo-2-c830c7f68d0fa3daec1bcd456124d7697eabe088.zip
Added new / missing icon themes
Diffstat (limited to 'x11-themes/psi-themes/psi-themes-0.8.8.ebuild')
-rw-r--r--x11-themes/psi-themes/psi-themes-0.8.8.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-themes/psi-themes/psi-themes-0.8.8.ebuild b/x11-themes/psi-themes/psi-themes-0.8.8.ebuild
new file mode 100644
index 000000000000..0909c83386e4
--- /dev/null
+++ b/x11-themes/psi-themes/psi-themes-0.8.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/psi-themes/psi-themes-0.8.8.ebuild,v 1.1 2003/11/11 21:09:27 luke-jr Exp $
+
+SRC_URI="http://psi.sourceforge.net/files/common/iconsets/beos/beos.zip
+ http://psi.sourceforge.net/files/common/iconsets/cosmic/cosmic.zip
+ http://psi.sourceforge.net/files/common/iconsets/gabber/gabber.zip
+ http://psi.sourceforge.net/files/common/iconsets/icq2/icq2.zip
+ http://psi.sourceforge.net/files/common/iconsets/licq/licq.zip
+ http://psi.sourceforge.net/files/common/iconsets/mike/mike.zip
+ http://psi.sourceforge.net/files/common/iconsets/smiley/smiley.zip
+ http://psi.sourceforge.net/files/common/iconsets/psi_dudes/psi_dudes.zip
+ http://psi.sourceforge.net/files/common/iconsets/aqualight/aqualight.zip
+ http://psi.sourceforge.net/files/common/iconsets/businessblack/businessblack.zip
+ http://psi.sourceforge.net/files/common/iconsets/bluekeramik/bluekeramik.zip
+ http://psi.sourceforge.net/files/common/iconsets/aquaploum/aquaploum.zip
+ http://psi.sourceforge.net/files/common/iconsets/thomas/thomas.zip
+ http://psi.sourceforge.net/files/common/iconsets/crystal/crystal.zip
+ http://psi.sourceforge.net/files/common/iconsets/jilly/jilly.zip
+
+ "
+DESCRIPTION="Iconsets for Psi, a QT 3.x Jabber Client"
+HOMEPAGE="http://psi.affinix.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND=">=net-im/psi-0.8.7
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ for FILE in ${A}; do
+ DIR=$( basename ${FILE} .zip )
+ unpack ${FILE}
+ mkdir ${DIR} 2>/dev/null
+ mv desc *.png* ${DIR} 2>/dev/null
+ chmod -R 0644 ${DIR}/* 2>/dev/null
+ done
+}
+
+src_install() {
+ dodir /usr/share/psi/iconsets
+ mv * ${D}/usr/share/psi/iconsets/
+}
+