summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-09-12 15:28:37 +0000
committerTroy Dack <tad@gentoo.org>2003-09-12 15:28:37 +0000
commitb1b59bd2369337385146061a4e3edbb15b2cf9f1 (patch)
treee0bd1a3dbd6116cc800ac75efd9e0bf0bf66196d /x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
parentVersion Bump. Closes Bug #26109. (diff)
downloadgentoo-2-b1b59bd2369337385146061a4e3edbb15b2cf9f1.tar.gz
gentoo-2-b1b59bd2369337385146061a4e3edbb15b2cf9f1.tar.bz2
gentoo-2-b1b59bd2369337385146061a4e3edbb15b2cf9f1.zip
Version Bump. Closes Bug #26109.
Diffstat (limited to 'x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild')
-rw-r--r--x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild b/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
new file mode 100644
index 000000000000..93fbfe67720b
--- /dev/null
+++ b/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/silver-xcursors/silver-xcursors-0.4.ebuild,v 1.1 2003/09/12 15:28:30 tad Exp $
+
+MY_P="5533-Silver-XCursors-3D-${PV}"
+DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=5533"
+SRC_URI="http://www.kde-look.org/content/files/$MY_P.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=x11-base/xfree-4.3.0-r2"
+
+
+src_install() {
+ mkdir -p ${D}/usr/share/cursors/xfree/Silver/cursors/
+ cp -d ${WORKDIR}/${MY_P:5}/Silver/cursors/* ${D}/usr/share/cursors/xfree/Silver/cursors/ || die
+ dodoc ${WORKDIR}/${MY_P:5}/{COPYING,README}
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: Silver"
+ einfo ""
+ einfo "Also, you can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo "To globally use this set of mouse cursors edit the file:"
+ einfo " /usr/share/cursors/xfree/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to"
+ einfo " Inherits=Silver"
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your XF86Config:"
+ ewarn "Option \"HWCursor\" \"false\""
+}