summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-07-07 12:21:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-07-07 12:21:43 +0000
commit9a14984b60fd1b507a477fed77b6de601136afeb (patch)
tree611521be0fc42346464d8d80e1ae93823e15f86d /x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild
parentVersion bump and old versions clean up. (diff)
downloadgentoo-2-9a14984b60fd1b507a477fed77b6de601136afeb.tar.gz
gentoo-2-9a14984b60fd1b507a477fed77b6de601136afeb.tar.bz2
gentoo-2-9a14984b60fd1b507a477fed77b6de601136afeb.zip
version bump thanks to boris64 <genzilla@boris64.net> in bug 184330
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild')
-rw-r--r--x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild b/x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild
new file mode 100644
index 000000000000..905bd4ffd9cd
--- /dev/null
+++ b/x11-themes/xcursor-neutral/xcursor-neutral-1.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+MY_P="48837-Neutral_Plus_1.2.tar.bz2"
+MY_PN="Neutral_Plus"
+
+DESCRIPTION="\"Neutral_Plus\", the standard X.Org mouse cursor with shadows and animations."
+HOMEPAGE="http://kde-look.org/content/show.php/show.php?content=48837"
+SRC_URI="http://kde-look.org/CONTENT/content-files/${MY_P}"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXcursor
+ =media-libs/libpng-1.2*"
+DEPEND="${RDEPEND}
+ x11-apps/xcursorgen"
+S="${WORKDIR}/Neutral_Plus"
+
+src_install(){
+ insinto /usr/share/cursors/xorg-x11/${MY_PN}/
+
+ doins -r ${S}/cursors/
+ doins ${S}/index.theme
+ dodoc ${S}/LICENSE
+ dodoc ${S}/COPYRIGHT
+
+ ## install additional cursor source files?
+ if use examples; then
+ doins -r ${S}/source/
+ fi
+}