summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-01-01 21:29:05 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-01-01 21:29:05 +0000
commit9f593e0ec138658bfbf61a41347c43a775a41acc (patch)
tree9332f8ed402a2068680fd83962353ae299c2f0d3 /x11-themes
parentDrop Prefix keywords, the dependencies are too non-Prefix and non-Linux incom... (diff)
downloadgentoo-2-9f593e0ec138658bfbf61a41347c43a775a41acc.tar.gz
gentoo-2-9f593e0ec138658bfbf61a41347c43a775a41acc.tar.bz2
gentoo-2-9f593e0ec138658bfbf61a41347c43a775a41acc.zip
Version bump, #395723 by Ivan S. Titov.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog9
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.9.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 83ffbbf8fd1b..e376fa4f8278 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.129 2011/10/28 20:38:26 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.130 2012/01/01 21:29:05 pesa Exp $
+
+*qtcurve-qt4-1.8.9 (01 Jan 2012)
+
+ 01 Jan 2012; Davide Pesavento <pesa@gentoo.org> +qtcurve-qt4-1.8.9.ebuild:
+ Version bump, #395723 by Ivan S. Titov.
28 Oct 2011; Jonathan Callen <abcd@gentoo.org> -qtcurve-qt4-1.8.4.ebuild,
-qtcurve-qt4-1.8.6.ebuild, -qtcurve-qt4-0.69.2.ebuild:
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.9.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.9.ebuild
new file mode 100644
index 000000000000..05ef54128708
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.8.9.ebuild,v 1.1 2012/01/01 21:29:05 pesa Exp $
+
+EAPI=4
+KDE_REQUIRED="optional"
+inherit cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde windeco"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ kde? (
+ $(add_kdebase_dep systemsettings)
+ windeco? ( $(add_kdebase_dep kwin) )
+ )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog README TODO"
+
+PATCHES=( "${FILESDIR}/${PN}_kwin_automagic_fix.patch" )
+
+REQUIRED_USE="windeco? ( kde )"
+
+pkg_setup() {
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs
+ if use kde; then
+ mycmakeargs=(
+ $(cmake-utils_use windeco QTC_KWIN)
+ )
+ kde4-base_src_configure
+ else
+ mycmakeargs=(
+ "-DQTC_QT_ONLY=true"
+ )
+ cmake-utils_src_configure
+ fi
+}