summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-05 15:09:57 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-05 15:09:57 +0000
commit9fbada7148d3d24cf680865c9355d1b167faf329 (patch)
treeaadef7ed21e7fea994435c5b296f08e49bb79207 /x11-wm/aewm++
parentRespect LDFLAGS wrt bug 327335. Thanks to Andreis Vinogradovs ( slepnoga ) <s... (diff)
downloadgentoo-2-9fbada7148d3d24cf680865c9355d1b167faf329.tar.gz
gentoo-2-9fbada7148d3d24cf680865c9355d1b167faf329.tar.bz2
gentoo-2-9fbada7148d3d24cf680865c9355d1b167faf329.zip
Respect LDFLAGS wrt bug 336099. Thanks to Diego for the report.
(Portage version: 2.1.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/aewm++')
-rw-r--r--x11-wm/aewm++/ChangeLog9
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r1.ebuild35
-rw-r--r--x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch34
-rw-r--r--x11-wm/aewm++/files/gcc-3.4.patch11
4 files changed, 77 insertions, 12 deletions
diff --git a/x11-wm/aewm++/ChangeLog b/x11-wm/aewm++/ChangeLog
index 8db70c627f8a..238ded5651a1 100644
--- a/x11-wm/aewm++/ChangeLog
+++ b/x11-wm/aewm++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/aewm++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.18 2010/06/06 20:12:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.19 2010/09/05 15:09:56 xarthisius Exp $
+
+*aewm++-1.1.5-r1 (05 Sep 2010)
+
+ 05 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +aewm++-1.1.5-r1.ebuild, +files/aewm++-1.1.5-makefile.patch,
+ -files/gcc-3.4.patch:
+ Respect LDFLAGS wrt bug 336099. Thanks to Diego for the report.
06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> aewm++-1.1.5.ebuild:
Fix HOMEPAGE wrt #239223 by Paweł Szubert.
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r1.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..1b485e154e84
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/aewm++-1.1.5-r1.ebuild,v 1.1 2010/09/05 15:09:56 xarthisius Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm but with the same look and feel."
+HOMEPAGE="http://github.com/frankhale/aewmpp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README || die
+}
diff --git a/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
new file mode 100644
index 000000000000..8b84a9963469
--- /dev/null
+++ b/x11-wm/aewm++/files/aewm++-1.1.5-makefile.patch
@@ -0,0 +1,34 @@
+Respect CFLAGS, LDFLAGS, don't strip binaries
+
+http://bugs.gentoo.org/show_bug.cgi?id=336099
+
+--- aewm++-1.1.5/Makefile
++++ aewm++-1.1.5/Makefile
+@@ -1,9 +1,6 @@
+ CC = g++
+-ADDITIONAL_CFLAGS = -g -O2 -march=i686 -Wall
+
+ prefix = /usr
+-INCLUDES = -I$/usr/X11R6
+-LDPATH = -L/usr/X11R6/lib
+ LIBS = -lXext -lX11
+
+ # SHAPE = Shape Extension
+@@ -28,14 +25,13 @@
+ all: aewm++
+
+ aewm++: $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CXX) $(LDFLAGS) $(OBJS) $(LDPATH) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.cc $(HEADERS)
+- $(CC) $(CFLAGS) $(ADDITIONAL_CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
++ $(CXX) $(CXXFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- mkdir -p $(DESTDIR)$(prefix)/bin
+- install -s aewm++ $(DESTDIR)$(prefix)/bin
++ install -D -m 755 aewm++ $(DESTDIR)$(prefix)/bin/aewm++
+
+ clean:
+ rm -f aewm++ $(OBJS) core
diff --git a/x11-wm/aewm++/files/gcc-3.4.patch b/x11-wm/aewm++/files/gcc-3.4.patch
deleted file mode 100644
index b739f71f89d3..000000000000
--- a/x11-wm/aewm++/files/gcc-3.4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- windowmanager.cc.old 2005-01-07 15:21:55.949614120 +1100
-+++ windowmanager.cc 2005-01-07 15:19:17.414715088 +1100
-@@ -625,7 +625,7 @@
- {
- if( (unsigned)current_desktop != ks - XK_1 )
- {
-- (unsigned)current_desktop = ks - XK_1;
-+ current_desktop = ks - XK_1;
- goToDesktop(current_desktop);
- }
- }