summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-12-19 18:28:10 +0000
committerThomas Sachau <tommy@gentoo.org>2012-12-19 18:28:10 +0000
commit6c4fb392bf13428698fac1928d5e54a59a3a6489 (patch)
tree9f2dc3a2d5430458cae6d5a485c7f62006e4bbb5 /x11-wm/enlightenment
parentAdd ~ia64, wrt bug #441688 (diff)
downloadgentoo-2-6c4fb392bf13428698fac1928d5e54a59a3a6489.tar.gz
gentoo-2-6c4fb392bf13428698fac1928d5e54a59a3a6489.tar.bz2
gentoo-2-6c4fb392bf13428698fac1928d5e54a59a3a6489.zip
Version bump
(Portage version: 2.2.0_alpha149-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'x11-wm/enlightenment')
-rw-r--r--x11-wm/enlightenment/ChangeLog8
-rw-r--r--x11-wm/enlightenment/enlightenment-0.17.0_beta3.ebuild89
2 files changed, 96 insertions, 1 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index de63932b709f..5b11636c0d7e 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/enlightenment
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.169 2012/12/14 20:13:45 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.170 2012/12/19 18:28:10 tommy Exp $
+
+*enlightenment-0.17.0_beta3 (19 Dec 2012)
+
+ 19 Dec 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +enlightenment-0.17.0_beta3.ebuild:
+ Version bump
*enlightenment-0.17.0_beta2 (14 Dec 2012)
diff --git a/x11-wm/enlightenment/enlightenment-0.17.0_beta3.ebuild b/x11-wm/enlightenment/enlightenment-0.17.0_beta3.ebuild
new file mode 100644
index 000000000000..fff127b452e5
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.17.0_beta3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.17.0_beta3.ebuild,v 1.1 2012/12/19 18:28:10 tommy Exp $
+
+EAPI=5
+
+MY_P=${P/_beta3/-omega}
+
+inherit autotools enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0.17/${PV}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@dialogs +@display +@edgebindings
+ +@interaction +@intl +@keybindings +@menus
+ +@paths +@performance +@randr +@shelves +@theme
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@backlight +@battery +@clock +@comp +@connman +@cpufreq +@dropshadow
+ +@everything +@fileman +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2
+ +@mixer +@msgbus +@notification +@pager +@quickaccess @shot +@start
+ +@syscon +@systray +@tasks +@temperature +@tiling +@winlist +@wizard +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="emotion pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ >=dev-libs/efreet-1.7.3
+ >=dev-libs/eio-1.7.3
+ >=dev-libs/eina-1.7.3[mempool-chained]
+ || ( >=dev-libs/ecore-1.7.3[X,evas,inotify] >=dev-libs/ecore-1.7.3[xcb,evas,inotify] )
+ >=media-libs/edje-1.7.3
+ >=dev-libs/e_dbus-1.7.1[libnotify,udev?]
+ ukit? ( >=dev-libs/e_dbus-1.7.1[udev] )
+ enlightenment_modules_connman? ( >=dev-libs/e_dbus-1.7.1[connman] )
+ enlightenment_modules_shot? ( >=dev-libs/ecore-1.7.3[curl] )
+ || ( >=media-libs/evas-1.7.3[eet,X,jpeg,png] >=media-libs/evas-1.7.3[eet,xcb,jpeg,png] )
+ >=dev-libs/eeze-1.7.1
+ emotion? ( >=media-libs/emotion-1.7.3 )
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ sed -i 's:efl_version="1.7.3":efl_version="1.7.1":g' configure.ac
+ eautoreconf
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ export MY_ECONF="
+ --disable-install-sysactions
+ --disable-elementary
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable emotion)
+ --disable-mount-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ --disable-physics
+ "
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ MY_ECONF+=" $(use_enable ${u} ${c})"
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf || die
+}