summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2004-01-04 03:52:39 +0000
committerBrandon Hale <tseng@gentoo.org>2004-01-04 03:52:39 +0000
commita0c79bd3a81cce202f4f9424d52f3050b33cee1c (patch)
tree928b53494e9bfc7d0a40b83e0ad758f9f68112b7 /x11-wm/fluxbox
parentVersion bump. This version has an all new ebuild that removes commonbox.eclas... (diff)
downloadgentoo-2-a0c79bd3a81cce202f4f9424d52f3050b33cee1c.tar.gz
gentoo-2-a0c79bd3a81cce202f4f9424d52f3050b33cee1c.tar.bz2
gentoo-2-a0c79bd3a81cce202f4f9424d52f3050b33cee1c.zip
Version bump. This version has an all new ebuild that removes commonbox.eclass functionality, and now installs data files in /usr/share/fluxbox
Diffstat (limited to 'x11-wm/fluxbox')
-rw-r--r--x11-wm/fluxbox/ChangeLog8
-rw-r--r--x11-wm/fluxbox/Manifest4
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.9.71
-rw-r--r--x11-wm/fluxbox/fluxbox-0.9.7.ebuild51
4 files changed, 61 insertions, 3 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 64bf01666368..a37837484292 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.82 2003/12/20 01:52:38 tseng Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.83 2004/01/04 03:52:30 tseng Exp $
+
+*fluxbox-0.9.7 (03 Jan 2004)
+
+ 03 Jan 2004; Brandon Hale <tseng@gentoo.org> fluxbox-0.9.7.ebuild:
+ Version bump. This version has an all new ebuild that removes commonbox.eclass
+ functionality, and now installs data files in /usr/share/fluxbox (YAY!).
19 Dec 2003; Brandon Hale <tseng@gentoo.org> fluxbox-0.1.14-r2.ebuild,
fluxbox-0.9.6.ebuild, fluxbox-0.9.6_pre9.ebuild:
diff --git a/x11-wm/fluxbox/Manifest b/x11-wm/fluxbox/Manifest
index da1a1d99e670..46626e70314a 100644
--- a/x11-wm/fluxbox/Manifest
+++ b/x11-wm/fluxbox/Manifest
@@ -1,8 +1,8 @@
-MD5 f07bede6c40a94cb45b25bbbaa78ef67 ChangeLog 17018
+MD5 4b4f03851a229962c2d491f1368493cd ChangeLog 17274
MD5 e16077e6f49f640cabe7d96ab3e8f99f fluxbox-0.1.14-r2.ebuild 1551
MD5 2c62e9868bff0c034d5a9886a0c769ca fluxbox-0.9.6.ebuild 2717
MD5 fb91a86bbf58cb4d7e40f9536c319766 metadata.xml 437
-MD5 14d65fc24a49f75fe736372b0edb4fca fluxbox-0.9.7.ebuild 1209
+MD5 6f8dc67ce043d0a564cb8a83659dde70 fluxbox-0.9.7.ebuild 1308
MD5 1c3ae2ce22f7f2a778a8ad5a5631df28 files/digest-fluxbox-0.1.14-r2 67
MD5 7a8bd89803849aff22030d86ec1e70cf files/digest-fluxbox-0.9.7 65
MD5 c28b191f95d32d2ab4d6c4f353faa070 files/fluxbox 27
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.9.7 b/x11-wm/fluxbox/files/digest-fluxbox-0.9.7
new file mode 100644
index 000000000000..3fc2225c3f0d
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.9.7
@@ -0,0 +1 @@
+MD5 43a252b95c63c6be8152e1b021469552 fluxbox-0.9.7.tar.gz 686357
diff --git a/x11-wm/fluxbox/fluxbox-0.9.7.ebuild b/x11-wm/fluxbox/fluxbox-0.9.7.ebuild
new file mode 100644
index 000000000000..6eef24847685
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-0.9.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.7.ebuild,v 1.1 2004/01/04 03:52:30 tseng Exp $
+
+IUSE="nls xinerama truetype kde gnome"
+
+DESCRIPTION="Fluxbox is a lightweight windowmanager for X featuring tabs."
+SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.gz"
+HOMEPAGE="http://www.fluxbox.org"
+
+# Please note that USE="kde gnome" simply adds support for
+# the respective protocols, and does not depend on external libraries.
+DEPEND=">=sys-devel/autoconf-2.52"
+RDEPEND="virtual/x11
+ truetype? ( media-libs/freetype )
+ nls? ( sys-devel/gettext )"
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+
+ econf \
+ `use_enable nls` \
+ `use_enable xinerama` \
+ `use_enable truetype xft` \
+ `use_enable kde` \
+ `use_enable gnome` \
+ --sysconfdir=/etc/X11/${PN} \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+
+ dodir /usr/share/fluxbox
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README* AUTHORS TODO* COPYING
+}
+
+pkg_postinst() {
+
+ ewarn
+ ewarn "Please note that this release no longer uses commonbox.eclass"
+ ewarn "and now installs data files in /usr/share/fluxbox."
+ ewarn
+}
+