summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-11-16 15:36:27 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-11-16 15:36:27 +0000
commit254a655b3fd87919c26f2ef23bd37e09917fe49d (patch)
tree45c338218da4ef6d0dc015481c66c76bc46ff782 /x11-wm/icewm
parentVersion bump, bug 280908. (diff)
downloadgentoo-2-254a655b3fd87919c26f2ef23bd37e09917fe49d.tar.gz
gentoo-2-254a655b3fd87919c26f2ef23bd37e09917fe49d.tar.bz2
gentoo-2-254a655b3fd87919c26f2ef23bd37e09917fe49d.zip
Enabling support of icewm-menu-gnome2 bug 205133
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog6
-rw-r--r--x11-wm/icewm/files/icewm-1.2.37-gnome2.patch18
-rw-r--r--x11-wm/icewm/icewm-1.2.37.ebuild22
3 files changed, 42 insertions, 4 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 3c3638eec06c..ef292376c522 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/icewm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.139 2009/11/11 21:25:27 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.140 2009/11/16 15:36:27 vostorga Exp $
+
+ 16 Nov 2009; Víctor Ostorga <vostorga@gentoo.org> icewm-1.2.37.ebuild,
+ +files/icewm-1.2.37-gnome2.patch:
+ Enabling support of icewm-menu-gnome2 bug 205133
11 Nov 2009; Víctor Ostorga <vostorga@gentoo.org> icewm-1.2.37.ebuild:
Fixing unrecognized options provided to configure, bug #261728
diff --git a/x11-wm/icewm/files/icewm-1.2.37-gnome2.patch b/x11-wm/icewm/files/icewm-1.2.37-gnome2.patch
new file mode 100644
index 000000000000..89e3d0ffb207
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.2.37-gnome2.patch
@@ -0,0 +1,18 @@
+diff -NrU5 icewm-1.2.37.original/configure.in icewm-1.2.37/configure.in
+--- icewm-1.2.37.original/configure.in 2009-11-16 15:16:24.000000000 -0600
++++ icewm-1.2.37/configure.in 2009-11-16 15:17:39.000000000 -0600
+@@ -818,12 +818,12 @@
+ [ if test "${enable_menus_gnome2}" = "yes"; then
+ AC_PATH_PROG(PKG_CONFIG, pkg-config)
+
+ if test "${PKG_CONFIG}" != ""; then
+ GNOME_VER=2
+- GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0`
+- GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0`
++ GNOME2_CFLAGS=`pkg-config --cflags gnome-desktop-2.0 libgnomeui-2.0`
++ GNOME2_LIBS=`pkg-config --libs gnome-desktop-2.0 libgnomeui-2.0`
+
+ AC_DEFINE(CONFIG_GNOME_MENUS, 1, [Define to make IceWM more GNOME-friendly])
+
+ APPLICATIONS="${APPLICATIONS} icewm-menu-gnome2"
+ GNOME2_PREFIX=`pkg-config --variable=prefix gnome-desktop-2.0`
diff --git a/x11-wm/icewm/icewm-1.2.37.ebuild b/x11-wm/icewm/icewm-1.2.37.ebuild
index f2e43e80f2e8..31c425f49016 100644
--- a/x11-wm/icewm/icewm-1.2.37.ebuild
+++ b/x11-wm/icewm/icewm-1.2.37.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.37.ebuild,v 1.3 2009/11/11 21:25:27 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.37.ebuild,v 1.4 2009/11/16 15:36:27 vostorga Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Ice Window Manager with Themes"
@@ -18,7 +18,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="esd imlib nls truetype xinerama minimal debug uclibc"
+IUSE="esd gnome imlib nls truetype xinerama minimal debug uclibc"
RDEPEND="x11-libs/libX11
x11-libs/libXrandr
@@ -30,6 +30,7 @@ RDEPEND="x11-libs/libX11
x11-libs/libICE
xinerama? ( x11-libs/libXinerama )
esd? ( media-sound/esound )
+ gnome? ( gnome-base/gnome-desktop )
imlib? ( >=media-libs/imlib-1.9.10-r1 )
nls? ( sys-devel/gettext )
truetype? ( >=media-libs/freetype-2.0.9 )
@@ -57,6 +58,12 @@ src_unpack() {
echo "#!/bin/sh" > "$T/icewm"
echo "/usr/bin/icewm-session" >> "$T/icewm"
+
+ cd "${S}"
+ #Fixing gnome2 support
+ epatch "${FILESDIR}/${P}-gnome2.patch"
+
+ eautoreconf
}
src_compile() {
@@ -74,6 +81,7 @@ src_compile() {
--with-cfgdir=/etc/icewm
--with-docdir=/usr/share/doc/${PF}/html
$(use_with esd esd-config /usr/bin/esd-config)
+ $(use_enable gnome menus-gnome2)
$(use_enable nls)
$(use_enable nls i18n)
$(use_with imlib)
@@ -101,3 +109,11 @@ src_install(){
insinto /usr/share/xsessions
doins "${FILESDIR}/IceWM.desktop"
}
+
+pkg_postinst() {
+ if use gnome; then
+ elog "You have enabled gnome USE flag which provides icewm-menu-gnome2 ."
+ elog "It is used internally and generates IceWM program menus from"
+ elog "FreeDesktop .desktop files"
+ fi
+}