summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-12-03 19:49:19 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-12-03 19:49:19 +0000
commitf6e55d317214727cf94c535afd189b047a169bb1 (patch)
tree2df9324d0976cafb9a67fe1979647e785d852b90 /x11-wm/icewm
parentFix cross-compiles by exporting CC for the default ABI, bug 439258. (diff)
downloadgentoo-2-f6e55d317214727cf94c535afd189b047a169bb1.tar.gz
gentoo-2-f6e55d317214727cf94c535afd189b047a169bb1.tar.bz2
gentoo-2-f6e55d317214727cf94c535afd189b047a169bb1.zip
Version bump (bug #490904)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog9
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch113
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-deprecated.patch12
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-menu.patch23
-rw-r--r--x11-wm/icewm/icewm-1.3.8.ebuild132
5 files changed, 288 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index ab2faba855e8..683f985b3f7f 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/icewm
# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.160 2013/11/09 15:19:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.161 2013/12/03 19:49:19 polynomial-c Exp $
+
+*icewm-1.3.8 (03 Dec 2013)
+
+ 03 Dec 2013; Lars Wendler <polynomial-c@gentoo.org> +icewm-1.3.8.ebuild,
+ +files/icewm-1.3.8-build-fixes.patch, +files/icewm-1.3.8-deprecated.patch,
+ +files/icewm-1.3.8-menu.patch:
+ Version bump (bug #490904).
09 Nov 2013; Pacho Ramos <pacho@gentoo.org> icewm-1.3.7-r1.ebuild:
x86 stable, bug #472086
diff --git a/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch b/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch
new file mode 100644
index 000000000000..cec27a79ad0a
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch
@@ -0,0 +1,113 @@
+--- icewm-1.3.8/Makefile.in
++++ icewm-1.3.8/Makefile.in
+@@ -35,7 +35,7 @@
+
+ ################################################################################
+
+-BINFILES = @BINFILES@ icewm-set-gnomewm
++BINFILES = @BINFILES@ "$(srcdir)/icewm-set-gnomewm"
+ LIBFILES = lib/preferences lib/winoptions lib/keys \
+ lib/menu lib/toolbar # lib/programs
+ DOCFILES = README BUGS CHANGES COPYING AUTHORS INSTALL VERSION icewm.lsm
+@@ -83,21 +83,23 @@
+ @echo ------------------------------------------
+ @echo "Installing binaries in $(DESTDIR)$(BINDIR)"
+ @$(INSTALLDIR) "$(DESTDIR)$(BINDIR)"
++#generated files, relative to the build directory
+ @for bin in $(BINFILES); do \
+ $(INSTALLBIN) "$${bin}" "$(DESTDIR)$(BINDIR)"; \
+ done
+
+ @echo "Installing presets and icons in $(DESTDIR)$(LIBDIR)"
+ @$(INSTALLDIR) "$(DESTDIR)$(LIBDIR)"
++# data files from the source directory
+ #-@$(INSTALLDIR) "$(DESTDIR)$(CFGDIR)"
+ @for lib in $(LIBFILES); do \
+- $(INSTALLLIB) "$${lib}" "$(DESTDIR)$(LIBDIR)"; \
++ $(INSTALLLIB) "$(top_srcdir)/$${lib}" "$(DESTDIR)$(LIBDIR)"; \
+ done
+
+ @for xpmdir in $(XPMDIRS); do \
+- if test -d "lib/$${xpmdir}"; then \
++ if test -d "$(top_srcdir)/lib/$${xpmdir}"; then \
+ $(INSTALLDIR) "$(DESTDIR)$(LIBDIR)/$${xpmdir}"; \
+- for pixmap in "lib/$${xpmdir}/"*.xpm; do \
++ for pixmap in "$(top_srcdir)/lib/$${xpmdir}/"*.xpm; do \
+ $(INSTALLLIB) "$${pixmap}" "$(DESTDIR)$(LIBDIR)/$${xpmdir}"; \
+ done; \
+ fi; \
+--- icewm-1.3.8/po/Makefile.in
++++ icewm-1.3.8/po/Makefile.in
+@@ -20,6 +20,7 @@
+ XGETTEXT = @XGETTEXT@
+ MSGMERGE = @MSGMERGE@
+ MSGFMT = @MSGFMT@
++VPATH = .:po:@srcdir@
+
+ .SUFFIXES:
+ .SUFFIXES: .po .mo
+--- icewm-1.3.8/src/Makefile.in
++++ icewm-1.3.8/src/Makefile.in
+@@ -11,7 +11,7 @@
+
+ CXX = @CXX@
+ HOSTCXX = @HOSTCXX@
+-LD = @CXX_LINK@
++LD = gcc
+ HOSTLD = @HOSTCXX_LINK@
+ EXEEXT = @EXEEXT@
+
+@@ -32,12 +32,12 @@
+ -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
+ -DICESMEXE='"icewm-session$(EXEEXT)"' \
+ -DICEHELPEXE='"icehelp$(EXEEXT)"' \
+- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
++ -DICEHELPIDX='"$(DOCDIR)/icewm-common/icewm.html"'
+
+ CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
+ @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ `pkg-config fontconfig --cflags`
+ LFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs`
++LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` -lfontconfig -lm -lsupc++
+
+ CORE_LIBS = @CORE_LIBS@ `pkg-config fontconfig --libs`
+ IMAGE_LIBS = @IMAGE_LIBS@
+@@ -188,6 +188,8 @@
+ TESTCASES = @TESTCASES@
+ OBJECTS = @BASEOBJS@ @TESTOBJS@
+ BINARIES = @BASEBINS@ @TESTBINS@
++BASEOBJS = @BASEOBJS@
++VPATH = .:@srcdir@
+
+ ################################################################################
+
+@@ -205,7 +207,8 @@
+ @echo " CXX " $@
+ @$(CXX) $(CXXFLAGS) $(GCCDEP) -c $<
+
+-$(BINARIES):
++$(BINARIES): $(BASEOBJS)
++# @$(MAKE) --no-print-directory build-dep DEPLIST="$($(@:$(EXEEXT)=)_OBJS)"
+ @echo " LD " $@
+ @$(LD) -o $@ $($(@:$(EXEEXT)=)_OBJS) $(LFLAGS) $($(@:$(EXEEXT)=)_LFLAGS) $(LIBS) $($(@:$(EXEEXT)=)_LIBS)
+
+@@ -217,6 +220,8 @@
+ @echo " HOSTLD " $@
+ @$(HOSTLD) -o $@ $(genpref_OBJS)
+
++build-dep: $(DEPLIST)
++
+ ################################################################################
+
+ gnome2.o: gnome2.cc
+--- icewm-1.3.8/src/WinMgr.h
++++ icewm-1.3.8/src/WinMgr.h
+@@ -128,7 +128,7 @@
+ * this where WIN_WORKSPACE_COUNT comes into play.
+ */
+
+-#define WinWorkspaceInvalid (-1L)
++#define WinWorkspaceInvalid ((unsigned long)-1)
+
+ /* workspaces */
+ #define XA_WIN_WORKSPACES "_WIN_WORKSPACES"
diff --git a/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch b/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch
new file mode 100644
index 000000000000..b956180627bc
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch
@@ -0,0 +1,12 @@
+--- icewm-1.3.8/src/base.h
++++ icewm-1.3.8/src/base.h
+@@ -2,7 +2,9 @@
+ #define __BASE_H
+
+ #if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
++#if ( __GNUC__ == 4 && __GNUC_MINOR__ > 7 ) || __GNUC__ > 3
+ #define _icewm_deprecated __attribute__((deprecated))
++#endif
+ #else
+ #define _icewm_deprecated
+ #endif
diff --git a/x11-wm/icewm/files/icewm-1.3.8-menu.patch b/x11-wm/icewm/files/icewm-1.3.8-menu.patch
new file mode 100644
index 000000000000..e4bab5c5ffc3
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-menu.patch
@@ -0,0 +1,23 @@
+--- icewm-1.3.8/lib/menu.in
++++ icewm-1.3.8/lib/menu.in
+@@ -4,15 +4,9 @@
+ # since modifications to this file will be discarded when you
+ # (re)install icewm.
+ #
+-prog xterm xterm xterm
+-prog rxvt xterm rxvt -bg black -cr green -fg white -C -fn 9x15 -sl 500
+-prog fte fte fte
+-prog NEdit nedit nedit
+-prog Mozilla mozilla mozilla
+-prog XChat xchat xchat
+-prog Gimp gimp gimp
++prog xterm /usr/share/icons/gnome/16x16/apps/terminal.png xterm
++prog "Web browser" /usr/share/icons/gnome/16x16/apps/web-browser.png xdg-open about:blank
+ separator
+-menuprog Gnome folder icewm-menu-gnome2 --list @CONFIG_GNOME2_MENU_DIR@
+-menuprog KDE folder icewm-menu-gnome@GNOME_VER@ --list @CONFIG_KDE_MENU_DIR@
+-menufile Programs folder programs
+-menufile Tool_bar folder toolbar
++prog "Rebuild program menu" /usr/share/icons/gnome/16x16/actions/edit-find-replace.png /usr/share/icewm/startup
++separator
++menufile Programs folder programs.autogen
diff --git a/x11-wm/icewm/icewm-1.3.8.ebuild b/x11-wm/icewm/icewm-1.3.8.ebuild
new file mode 100644
index 000000000000..65c2708eeace
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.3.8.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999- Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.3.8.ebuild,v 1.1 2013/12/03 19:49:19 polynomial-c Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="http://www.icewm.org/"
+LICENSE="GPL-2"
+SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bidi debug gnome minimal nls truetype uclibc xinerama"
+REQUIRED_USE="gnome? ( ${PYTHON_REQUIRED_USE} )"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+#fix for icewm preversion package names
+S=${WORKDIR}/${P/_}
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libSM
+ x11-libs/libICE
+ xinerama? ( x11-libs/libXinerama )
+ bidi? ( dev-libs/fribidi )
+ gnome? (
+ ${PYTHON_DEPS}
+ dev-python/pyxdg
+ gnome-base/gnome-desktop:2
+ gnome-base/gnome-menus
+ gnome-base/libgnomeui )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )
+ media-libs/giflib
+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ >=sys-apps/sed-4
+"
+
+pkg_setup() {
+ if use truetype && use minimal; then
+ ewarn "You have both 'truetype' and 'minimal' use flags enabled."
+ ewarn "If you really want a minimal install, you will have to turn off"
+ ewarn "the truetype flag for this package."
+ fi
+}
+
+src_prepare() {
+ # Fedora patches
+ epatch "${FILESDIR}"/${PN}-1.3.8-menu.patch
+ epatch "${FILESDIR}"/${PN}-toolbar.patch
+ epatch "${FILESDIR}"/${PN}-keys.patch
+ epatch "${FILESDIR}"/${PN}-fribidi.patch
+ epatch "${FILESDIR}"/${PN}-1.3.7-dso.patch
+ epatch "${FILESDIR}"/${PN}-defaults.patch
+ epatch "${FILESDIR}"/${PN}-1.3.7-menuiconsize.patch
+ epatch "${FILESDIR}"/${PN}-1.3.8-deprecated.patch
+
+ epatch "${FILESDIR}"/${PN}-1.3.7-gcc44.patch
+
+ # Get thermal info from proper locations, bug #452730
+ epatch "${FILESDIR}"/${PN}-1.3.7-thermal.patch
+
+ # Debian patch fixing multiple build issues, like bug #470148
+ epatch "${FILESDIR}"/${PN}-1.3.8-build-fixes.patch
+
+ # Fix bug #486710
+ use uclibc && epatch "${FILESDIR}/${P}-uclibc.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ if use truetype
+ then
+ myconf="${myconf} --enable-gradients --enable-shape --enable-shaped-decorations"
+ else
+ myconf="${myconf} --disable-xfreetype --enable-corefonts
+ $(use_enable minimal lite)"
+ fi
+
+ myconf="${myconf}
+ --with-libdir=/usr/share/icewm
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable gnome menus-gnome2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable x86 x86-asm)
+ $(use_enable xinerama)
+ --without-esd-config"
+
+ CXXFLAGS="${CXXFLAGS}" econf ${myconf}
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die "patch failed"
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+}
+
+src_install(){
+ default
+
+ if use gnome; then
+ dobin "${FILESDIR}"/icewm-xdg-menu
+ exeinto /usr/share/icewm/
+ newexe "${FILESDIR}"/icewm-startup startup
+ fi
+
+ dodoc AUTHORS BUGS CHANGES PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/IceWM.desktop"
+}