summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2007-07-18 21:06:05 +0000
committerDavid Shakaryan <omp@gentoo.org>2007-07-18 21:06:05 +0000
commit2d31a10a847e16d255c4a6ad76ac9f88700adeae (patch)
treed1614f1a8ecaace69ddfddf501bb2d2eef41460a /x11-wm/openbox
parentVersion bump. (diff)
downloadgentoo-2-2d31a10a847e16d255c4a6ad76ac9f88700adeae.tar.gz
gentoo-2-2d31a10a847e16d255c4a6ad76ac9f88700adeae.tar.bz2
gentoo-2-2d31a10a847e16d255c4a6ad76ac9f88700adeae.zip
Remove unneeded files; last commit should have had revision bump.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog8
-rw-r--r--x11-wm/openbox/files/digest-openbox-3.4.2-r13
-rw-r--r--x11-wm/openbox/files/openbox.desktop9
-rw-r--r--x11-wm/openbox/openbox-3.4.2-r1.ebuild45
-rw-r--r--x11-wm/openbox/openbox-3.4.2.ebuild4
5 files changed, 57 insertions, 12 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 70e1b8df7227..8e9af3b202a0 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.135 2007/07/18 20:55:32 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.136 2007/07/18 21:06:05 omp Exp $
+
+*openbox-3.4.2-r1 (18 Jul 2007)
+
+ 18 Jul 2007; David Shakaryan <omp@gentoo.org> -files/openbox.desktop,
+ openbox-3.4.2.ebuild, +openbox-3.4.2-r1.ebuild:
+ Remove unneeded files; last commit should have had revision bump.
18 Jul 2007; David Shakaryan <omp@gentoo.org> openbox-3.4.2.ebuild:
Install docs into correct directory. (bug #185796)
diff --git a/x11-wm/openbox/files/digest-openbox-3.4.2-r1 b/x11-wm/openbox/files/digest-openbox-3.4.2-r1
new file mode 100644
index 000000000000..c68e64870508
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-3.4.2-r1
@@ -0,0 +1,3 @@
+MD5 d5d52fa23fe91e1e3b53858a20d12757 openbox-3.4.2.tar.gz 727411
+RMD160 32039007aaeecef357b4f795cfb099cf134e8696 openbox-3.4.2.tar.gz 727411
+SHA256 92a1f2042622474548d9c13c9057e76c621994d0593659c1a434251d545ab148 openbox-3.4.2.tar.gz 727411
diff --git a/x11-wm/openbox/files/openbox.desktop b/x11-wm/openbox/files/openbox.desktop
deleted file mode 100644
index 8f969204fa29..000000000000
--- a/x11-wm/openbox/files/openbox.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=Openbox
-Comment=This session logs you into Openbox
-Exec=openbox
-TryExec=openbox
-# no icon yet, only the top three are currently used
-Icon=
-Type=Application
diff --git a/x11-wm/openbox/openbox-3.4.2-r1.ebuild b/x11-wm/openbox/openbox-3.4.2-r1.ebuild
new file mode 100644
index 000000000000..61f5636dc582
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.4.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.2-r1.ebuild,v 1.1 2007/07/18 21:06:05 omp Exp $
+
+DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
+HOMEPAGE="http://icculus.org/openbox/"
+SRC_URI="http://icculus.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="nls startup-notification xinerama"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libxml2-2.0
+ >=media-libs/fontconfig-2
+ virtual/xft
+ x11-libs/libXrandr
+ x11-libs/libXt
+ >=x11-libs/pango-1.8
+ nls? ( sys-devel/gettext )
+ startup-notification? ( x11-libs/startup-notification )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable nls) \
+ $(use_enable startup-notification) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox-session" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/x11-wm/openbox/openbox-3.4.2.ebuild b/x11-wm/openbox/openbox-3.4.2.ebuild
index 7465ff196b1f..e554f1381401 100644
--- a/x11-wm/openbox/openbox-3.4.2.ebuild
+++ b/x11-wm/openbox/openbox-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.2.ebuild,v 1.8 2007/07/18 20:55:32 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.4.2.ebuild,v 1.9 2007/07/18 21:06:05 omp Exp $
DESCRIPTION="A standards compliant, fast, light-weight, extensible window manager."
HOMEPAGE="http://icculus.org/openbox/"
@@ -29,7 +29,6 @@ DEPEND="${RDEPEND}
src_compile() {
econf \
- --docdir=/usr/share/doc/${PF} \
$(use_enable nls) \
$(use_enable startup-notification) \
|| die "econf failed"
@@ -42,4 +41,5 @@ src_install() {
fperms a+x /etc/X11/Sessions/${PN}
emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ABOUT-NLS AUTHORS CHANGELOG COMPLIANCE README
}