summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2004-03-07 23:22:20 +0000
committerBrandon Hale <tseng@gentoo.org>2004-03-07 23:22:20 +0000
commit4e9e86824b89a28b0c98afe334b8b8e0a283007e (patch)
tree1fb61471f6aa918dcf0096817036edde0c9ddd88 /x11-wm/openbox
parentUpdated the 2.6 headers patch to also work with >=2.6.3 headers. (Manifest re... (diff)
downloadgentoo-2-4e9e86824b89a28b0c98afe334b8b8e0a283007e.tar.gz
gentoo-2-4e9e86824b89a28b0c98afe334b8b8e0a283007e.tar.bz2
gentoo-2-4e9e86824b89a28b0c98afe334b8b8e0a283007e.zip
Add .desktop file in preperation for new GDM, bug #40711
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog8
-rw-r--r--x11-wm/openbox/files/digest-openbox-3.1-r12
-rw-r--r--x11-wm/openbox/files/openbox.desktop9
-rw-r--r--x11-wm/openbox/openbox-3.1-r1.ebuild52
4 files changed, 70 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 532782fe0b84..b5edc691c273 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.72 2004/03/03 14:54:06 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.73 2004/03/07 23:22:20 tseng Exp $
+
+*openbox-3.1-r1 (07 Mar 2004)
+
+ 07 Mar 2004; Brandon Hale <tseng@gentoo.org> openbox-3.1-r1.ebuild,
+ files/openbox.desktop:
+ Add .desktop file in preperation for new GDM, bug #40711
03 Mar 2004; Gustavo Zacarias <gustavoz@gentoo.org> openbox-3.1.ebuild:
stable on sparc
diff --git a/x11-wm/openbox/files/digest-openbox-3.1-r1 b/x11-wm/openbox/files/digest-openbox-3.1-r1
new file mode 100644
index 000000000000..03ac811de4db
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-3.1-r1
@@ -0,0 +1,2 @@
+MD5 3152631bb8c892b919129e2a58978aad openbox-3.1.tar.gz 550425
+MD5 3d69bb394dae0994461172fccedc602a ob-themes-usability.tar.bz2 19204
diff --git a/x11-wm/openbox/files/openbox.desktop b/x11-wm/openbox/files/openbox.desktop
new file mode 100644
index 000000000000..8f969204fa29
--- /dev/null
+++ b/x11-wm/openbox/files/openbox.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Openbox
+Comment=This session logs you into Openbox
+Exec=openbox
+TryExec=openbox
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-wm/openbox/openbox-3.1-r1.ebuild b/x11-wm/openbox/openbox-3.1-r1.ebuild
new file mode 100644
index 000000000000..fe18ce8e60f3
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-3.1-r1.ebuild,v 1.1 2004/03/07 23:22:20 tseng Exp $
+
+S=${WORKDIR}/${P/_/-}
+DESCRIPTION="Openbox is a standards compliant, fast, light-weight, extensible window manager."
+
+SRC_URI="http://icculus.org/openbox/releases/${P/_/-}.tar.gz
+ mirror://gentoo/ob-themes-usability.tar.bz2"
+
+HOMEPAGE="http://icculus.org/openbox/"
+IUSE="nls"
+SLOT="3"
+
+DEPEND="virtual/xft
+ virtual/x11
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2
+ >=dev-libs/libxml2-2.0"
+RDEPEND=${DEPEND}
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc amd64"
+
+src_compile() {
+
+ econf \
+ `use_enable nls` || die
+ emake || die
+}
+
+src_install () {
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ fperms a+x /etc/X11/Sessions/openbox
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/${PN}.desktop
+
+ make DESTDIR=${D} install || die
+ dodoc README AUTHORS ChangeLog TODO
+
+ # Extra styles from http://home.clara.co.uk/dpb/openbox.htm
+ # These are included due to the poor usability of the default themes
+ # for users with limited vision. These are based on Jimmac's
+ # Gorilla and Industrial themes for Metacity.
+
+ dodir /usr/share/themes
+ cp -a ${WORKDIR}/ob-themes-usability/* ${D}/usr/share/themes
+}