summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-21 21:10:48 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-21 21:10:48 +0000
commit66371d71e490116eaf11051acb3cbc582a794d6e (patch)
tree0e5c32042263ba2bef545931a679b3fc16946625 /x11-wm/qtile/qtile-0.6.ebuild
parentadjust case indentation so it is consistent in the whole file (diff)
downloadgentoo-2-66371d71e490116eaf11051acb3cbc582a794d6e.tar.gz
gentoo-2-66371d71e490116eaf11051acb3cbc582a794d6e.tar.bz2
gentoo-2-66371d71e490116eaf11051acb3cbc582a794d6e.zip
Fix python deps and only support a single implementation until xpyb allows multiple.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm/qtile/qtile-0.6.ebuild')
-rw-r--r--x11-wm/qtile/qtile-0.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-wm/qtile/qtile-0.6.ebuild b/x11-wm/qtile/qtile-0.6.ebuild
index b2c8b79881b8..058169012fe1 100644
--- a/x11-wm/qtile/qtile-0.6.ebuild
+++ b/x11-wm/qtile/qtile-0.6.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.6.ebuild,v 1.1 2013/05/16 11:00:57 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/qtile/qtile-0.6.ebuild,v 1.2 2013/05/21 21:10:48 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 virtualx
@@ -16,9 +17,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
-RDEPEND=">=dev-python/pycairo-1.10.0-r3[xcb,${PYTHON_USEDEP}]
+RDEPEND=">=dev-python/pycairo-1.10.0-r4[xcb,${PYTHON_USEDEP}]
dev-python/pygtk:2[${PYTHON_USEDEP}]
- >=x11-libs/xpyb-1.3.1[${PYTHON_USEDEP}]"
+ >=x11-libs/xpyb-1.3.1-r1[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (