summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-29 13:55:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-29 13:55:35 +0000
commit36a8fba473e22a65e52ee971cfdabab5ec757eac (patch)
tree3155b4cd00b25f4d4d2666274e449765d4d9d741 /x11-wm/sawfish
parentSeparated gnome USE flag from gtk USE flag for gdk-pixbuf functionality witho... (diff)
downloadgentoo-2-36a8fba473e22a65e52ee971cfdabab5ec757eac.tar.gz
gentoo-2-36a8fba473e22a65e52ee971cfdabab5ec757eac.tar.bz2
gentoo-2-36a8fba473e22a65e52ee971cfdabab5ec757eac.zip
gnome/gdk-pixbuf separation
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-1.0.1-r31
-rw-r--r--x11-wm/sawfish/sawfish-1.0.1-r3.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-wm/sawfish/files/digest-sawfish-1.0.1-r3 b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r3
new file mode 100644
index 000000000000..3592e2b26ab4
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-1.0.1-r3
@@ -0,0 +1 @@
+MD5 b1587ea76cca08ec951f2536c17a307e sawfish-1.0.1.tar.gz 1326727
diff --git a/x11-wm/sawfish/sawfish-1.0.1-r3.ebuild b/x11-wm/sawfish/sawfish-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..26378e6f2945
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.0.1-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.0.1-r3.ebuild,v 1.1 2002/03/29 13:55:35 seemant Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="http://prdownloads.sourceforge.net/sawmill/"${A}
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-libs/rep-gtk-0.15-r1
+ >=dev-libs/librep-0.14
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 )"
+
+RDEPEND="${DEPEND}
+ >=x11-libs/gtk+-1.2.10-r4
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p0 <${FILESDIR}/capplet-crash.patch || die
+ #fix buggy Makefile with newer libtool
+ patch -p0 <${FILESDIR}/sawfish-${PV}-exec.patch || die
+
+ #update libtool for "relink" bug fix
+ libtoolize --copy --force
+ aclocal
+}
+
+src_compile() {
+
+ local myconf
+
+ use esd \
+ && myconf="--with-esd" \
+ || myconf="--without-esd"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome-prefix=/usr --enable-gnome-widgets --enable-capplet" \
+ || myconf="${myconf} --disable-gnome-widgets --disable-capplet"
+
+ use nls || myconf="${myconf} --disable-linguas"
+
+ use gtk \
+ && myconf="${myconf} --with-gdk-pixbuf" \
+ || myconf="${myconf} --without-gdk-pixbuf"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS BUGS COPYING ChangeLog
+ dodoc DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+ fi
+}