summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-03 01:07:21 +0000
committerTim Harder <radhermit@gentoo.org>2015-08-03 01:07:21 +0000
commit029d050baea2e5cd20c82449dab2c9d2db5a1578 (patch)
tree85fd2acfa45016dd68eb21c274f097969126ccc7 /x11-wm
parentadd ${S} to PYTHONPATH for doc build (diff)
downloadgentoo-2-029d050baea2e5cd20c82449dab2c9d2db5a1578.tar.gz
gentoo-2-029d050baea2e5cd20c82449dab2c9d2db5a1578.tar.bz2
gentoo-2-029d050baea2e5cd20c82449dab2c9d2db5a1578.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/subtle/ChangeLog10
-rw-r--r--x11-wm/subtle/subtle-0.11.3244.ebuild89
-rw-r--r--x11-wm/subtle/subtle-9999.ebuild27
3 files changed, 115 insertions, 11 deletions
diff --git a/x11-wm/subtle/ChangeLog b/x11-wm/subtle/ChangeLog
index 77c37dbfcb61..f17b1f337874 100644
--- a/x11-wm/subtle/ChangeLog
+++ b/x11-wm/subtle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/subtle
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/ChangeLog,v 1.6 2012/09/18 23:02:48 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/ChangeLog,v 1.7 2015/08/03 01:07:21 radhermit Exp $
+
+*subtle-0.11.3244 (03 Aug 2015)
+
+ 03 Aug 2015; Tim Harder <radhermit@gentoo.org> +subtle-0.11.3244.ebuild,
+ subtle-9999.ebuild:
+ Version bump.
18 Sep 2012; Tim Harder <radhermit@gentoo.org>
files/subtle-0.11.3224-flags.patch:
diff --git a/x11-wm/subtle/subtle-0.11.3244.ebuild b/x11-wm/subtle/subtle-0.11.3244.ebuild
new file mode 100644
index 000000000000..9bc058ac17c7
--- /dev/null
+++ b/x11-wm/subtle/subtle-0.11.3244.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-0.11.3244.ebuild,v 1.1 2015/08/03 01:07:21 radhermit Exp $
+
+EAPI="5"
+USE_RUBY="ruby20 ruby21 ruby22"
+
+inherit ruby-ng toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ EHG_REPO_URI="http://hg.subforge.org/subtle"
+ EHG_CHECKOUT_DIR=${S}/all
+ inherit mercurial
+else
+ SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A manual tiling window manager"
+HOMEPAGE="http://subforge.org/projects/subtle/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
+
+RDEPEND="x11-libs/libX11
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )
+ xpm? ( x11-libs/libXpm )
+ xtest? ( x11-libs/libXtst )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+ruby_add_rdepend "dev-ruby/archive-tar-minitar"
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ mercurial_src_unpack
+ else
+ default
+ fi
+}
+
+each_ruby_configure() {
+ local myconf
+ use debug && myconf+=" debug=yes" || myconf+=" debug=no"
+ use xft && myconf+=" xft=yes" || myconf+=" xft=no"
+ use xinerama && myconf+=" xinerama=yes" || myconf+=" xinerama=no"
+ use xpm && myconf+=" xpm=yes" || myconf+=" xpm=no"
+ use xtest && myconf+=" xtest=yes" || myconf+=" xtest=no"
+ use xrandr && myconf+=" xrandr=yes" || myconf+=" xrandr=no"
+
+ ${RUBY} -S rake -v CC="$(tc-getCC)" destdir="${D}" ${myconf} config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake -v build || die
+}
+
+all_ruby_compile() {
+ use doc && { rake rdoc || die ; }
+}
+
+each_ruby_install() {
+ ${RUBY} -S rake -v install || die
+}
+
+all_ruby_install() {
+ dodir /etc/X11/Sessions
+ cat <<-EOF > "${D}/etc/X11/Sessions/${PN}"
+ #!/bin/sh
+ exec /usr/bin/subtle
+ EOF
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins data/${PN}.desktop
+
+ dodoc AUTHORS NEWS
+
+ use doc && dohtml -r html/*
+}
+
+pkg_postinst() {
+ elog "Note that surserver will currently not work since dev-ruby/datamapper"
+ elog "is not in the tree."
+}
diff --git a/x11-wm/subtle/subtle-9999.ebuild b/x11-wm/subtle/subtle-9999.ebuild
index b6b5e4eed766..41331cc90f61 100644
--- a/x11-wm/subtle/subtle-9999.ebuild
+++ b/x11-wm/subtle/subtle-9999.ebuild
@@ -1,21 +1,26 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-9999.ebuild,v 1.5 2012/06/20 19:40:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/subtle/subtle-9999.ebuild,v 1.6 2015/08/03 01:07:21 radhermit Exp $
-EAPI="4"
-USE_RUBY="ruby19"
+EAPI="5"
+USE_RUBY="ruby20 ruby21 ruby22"
-inherit mercurial ruby-ng toolchain-funcs
+inherit ruby-ng toolchain-funcs
-EHG_REPO_URI="http://hg.subforge.org/subtle"
+if [[ ${PV} == "9999" ]]; then
+ EHG_REPO_URI="http://hg.subforge.org/subtle"
+ EHG_CHECKOUT_DIR=${S}/all
+ inherit mercurial
+else
+ SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A manual tiling window manager"
HOMEPAGE="http://subforge.org/projects/subtle/wiki"
-SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="debug doc +xft xinerama xpm +xrandr +xtest"
RDEPEND="x11-libs/libX11
@@ -31,7 +36,11 @@ ruby_add_rdepend "dev-ruby/archive-tar-minitar"
ruby_add_bdepend "dev-ruby/rake"
all_ruby_unpack() {
- mercurial_src_unpack
+ if [[ ${PV} == "9999" ]]; then
+ mercurial_src_unpack
+ else
+ default
+ fi
}
each_ruby_configure() {