summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-11-01 19:12:01 +0000
committerMarien Zwart <marienz@gentoo.org>2006-11-01 19:12:01 +0000
commit043e72d98539c247415d0a3d651c0e9e55b0bce2 (patch)
tree13a348ea2eb4fa94ed9e7dddf91fdaa5c8ba6deb /x11-wm
parentFix #153002, add myself as maintainer (diff)
downloadgentoo-2-043e72d98539c247415d0a3d651c0e9e55b0bce2.tar.gz
gentoo-2-043e72d98539c247415d0a3d651c0e9e55b0bce2.tar.bz2
gentoo-2-043e72d98539c247415d0a3d651c0e9e55b0bce2.zip
Version bump and a fix for a sandbox violation if dpkg is installed (bug #144025) from Nathan Mahon <gentoo.org@vaevictus.net>.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog11
-rw-r--r--x11-wm/afterstep/afterstep-2.2.2-r1.ebuild141
-rw-r--r--x11-wm/afterstep/afterstep-2.2.3.ebuild141
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.2.2-r13
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-2.2.33
-rw-r--r--x11-wm/afterstep/files/no-alternatives.patch29
6 files changed, 327 insertions, 1 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index ba817ac6b281..22a6f25130f0 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/afterstep
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.57 2006/08/14 15:48:59 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.58 2006/11/01 19:12:01 marienz Exp $
+
+*afterstep-2.2.3 (01 Nov 2006)
+*afterstep-2.2.2-r1 (01 Nov 2006)
+
+ 01 Nov 2006; Marien Zwart <marienz@gentoo.org>
+ +files/no-alternatives.patch, +afterstep-2.2.2-r1.ebuild,
+ +afterstep-2.2.3.ebuild:
+ Version bump and a fix for a sandbox violation if dpkg is installed (bug
+ #144025) from Nathan Mahon <gentoo.org@vaevictus.net>.
*afterstep-2.2.2 (14 Aug 2006)
diff --git a/x11-wm/afterstep/afterstep-2.2.2-r1.ebuild b/x11-wm/afterstep/afterstep-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..e18bfc897dd3
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.2-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.2-r1.ebuild,v 1.1 2006/11/01 19:12:01 marienz Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gif jpeg mmx nls png tiff xinerama"
+
+RDEPEND="virtual/libc
+ media-libs/freetype
+ debug? ( !hppa? ( !ppc? ( dev-util/efence ) ) )
+ png? ( >=media-libs/libpng-1.2.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/AfterStep-${PV}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/no-alternatives.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ if ! use ppc && use debug ; then
+ myconf="${myconf} --with-libefence"
+ fi
+
+ #implied intent of debug means you need the frame pointers.
+ use debug && filter-flags -fomit-frame-pointer
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --with-ungif=no - Use giflib instead of libungif
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable xinerama) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with gif) \
+ $(use_with tiff) \
+ --with-helpcommand="xterm -e man" \
+ --with-ungif=no \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # see bug #31541
+ dodir /usr/share/gnome/wm-properties
+
+ # afterstep tries to detect the current resolution
+ # for documentation generation, causing access violations
+ # for the video device. bug #87356
+ unset DISPLAY
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ # This fixes a bug with shared libraries
+ rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
+ cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm ${D}/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ newins ${S}/AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use AfterStep issue the following commands:"
+ einfo "mv ~/.xinitrc ~/xinitrc.old"
+ einfo "echo afterstep > ~/.xinitrc"
+ echo
+ einfo "If you like AfterStep please vote for it at"
+ einfo "http://www.PLiG.org/xwinman/vote.html !"
+ echo
+}
+
diff --git a/x11-wm/afterstep/afterstep-2.2.3.ebuild b/x11-wm/afterstep/afterstep-2.2.3.ebuild
new file mode 100644
index 000000000000..a01b19bfa0a7
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-2.2.3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.3.ebuild,v 1.1 2006/11/01 19:12:01 marienz Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="AfterStep is a feature rich NeXTish window manager"
+HOMEPAGE="http://www.afterstep.org"
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+
+LICENSE="AFTERSTEP"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gif jpeg mmx nls png tiff xinerama"
+
+RDEPEND="virtual/libc
+ media-libs/freetype
+ debug? ( !hppa? ( !ppc? ( dev-util/efence ) ) )
+ png? ( >=media-libs/libpng-1.2.5 )
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1.0 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ || ( ( x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXrender
+ xinerama? ( x11-libs/libXinerama )
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xextproto
+ x11-proto/xproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )"
+
+S="${WORKDIR}/AfterStep-${PV}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/no-alternatives.patch"
+}
+
+src_compile() {
+ local myconf
+
+ use debug && myconf="--enable-gdb --enable-warn --enable-gprof
+ --enable-audit --enable-trace --enable-trace-x"
+
+ if ! use ppc && use debug ; then
+ myconf="${myconf} --with-libefence"
+ fi
+
+ #implied intent of debug means you need the frame pointers.
+ use debug && filter-flags -fomit-frame-pointer
+
+ # Explanation of configure options
+ # ================================
+ # --with-helpcommand="xterm -e man" - Avoid installing xiterm
+ # --with-xpm - Contained in xfree
+ # --with-ungif=no - Use giflib instead of libungif
+ # --disable-availability - So we can use complete paths for menuitems
+ # --enable-ascp - The AfterStep ControlPanel is abandoned
+
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable mmx mmx-optimization) \
+ $(use_enable xinerama) \
+ $(use_with png) \
+ $(use_with jpeg) \
+ $(use_with gif) \
+ $(use_with tiff) \
+ --with-helpcommand="xterm -e man" \
+ --with-ungif=no \
+ --disable-availability \
+ --disable-staticlibs \
+ --enable-ascp=no \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ # see bug #31541
+ dodir /usr/share/gnome/wm-properties
+
+ # afterstep tries to detect the current resolution
+ # for documentation generation, causing access violations
+ # for the video device. bug #87356
+ unset DISPLAY
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ # This fixes a bug with shared libraries
+ rm ${D}/usr/lib/{libAfterImage.a,libAfterBase.a}
+ cp -pPR ${S}/libAfterImage/libAfterImage.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterBase/libAfterBase.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterConf/libAfterConf.so* ${D}/usr/lib
+ cp -pPR ${S}/libAfterStep/libAfterStep.so* ${D}/usr/lib
+
+ # Create a symlink from MonitorWharf to Wharf
+ rm ${D}/usr/bin/MonitorWharf
+ dosym /usr/bin/Wharf /usr/bin/MonitorWharf
+
+ # Handle the documentation
+ dodoc COPYRIGHT ChangeLog INSTALL NEW* README* TEAM UPGRADE
+ cp -pPR ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -pPR ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/{Makefile*,afterstepdoc.in}
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ newins ${S}/AfterStep.desktop.final AfterStep.desktop
+
+ # For desktop managers like GDM or KDE
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+}
+
+pkg_postinst() {
+ echo
+ einfo "To use AfterStep issue the following commands:"
+ einfo "mv ~/.xinitrc ~/xinitrc.old"
+ einfo "echo afterstep > ~/.xinitrc"
+ echo
+ einfo "If you like AfterStep please vote for it at"
+ einfo "http://www.PLiG.org/xwinman/vote.html !"
+ echo
+}
+
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.2.2-r1 b/x11-wm/afterstep/files/digest-afterstep-2.2.2-r1
new file mode 100644
index 000000000000..24f0c968a1fa
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-2.2.2-r1
@@ -0,0 +1,3 @@
+MD5 dbfe86bfe20c8c377985c7e68232b570 AfterStep-2.2.2.tar.bz2 5458624
+RMD160 0a314423218f138e6041bcae0cfa18b565231a61 AfterStep-2.2.2.tar.bz2 5458624
+SHA256 57657c8374c96aef8a9eeb0aa717aae3a38862bce9c9d389f69378bc8cc9fd65 AfterStep-2.2.2.tar.bz2 5458624
diff --git a/x11-wm/afterstep/files/digest-afterstep-2.2.3 b/x11-wm/afterstep/files/digest-afterstep-2.2.3
new file mode 100644
index 000000000000..a3b09731d7d9
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-2.2.3
@@ -0,0 +1,3 @@
+MD5 c4dd1739a3e76599815d91f0212d1a43 AfterStep-2.2.3.tar.bz2 5611790
+RMD160 dc347d03070588c860b229dcb7eb30440c00aae5 AfterStep-2.2.3.tar.bz2 5611790
+SHA256 6aa1dedb8760abc66ade5a8b29eba03d40d06e0c0c4ec8c2b98f7e986388d8c5 AfterStep-2.2.3.tar.bz2 5611790
diff --git a/x11-wm/afterstep/files/no-alternatives.patch b/x11-wm/afterstep/files/no-alternatives.patch
new file mode 100644
index 000000000000..f2308b07778a
--- /dev/null
+++ b/x11-wm/afterstep/files/no-alternatives.patch
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2006-11-01 12:28:46.000000000 -0500
++++ Makefile.in 2006-11-01 12:29:16.000000000 -0500
+@@ -70,7 +70,8 @@
+
+ module.clean:
+
+-install: install.alternative install.desktop install.wmprops mkdir
++#install: install.alternative install.desktop install.wmprops mkdir
++install: install.desktop install.wmprops mkdir
+ @for I in ${subdirs} ; do if [ -d $$I ]; then (cd $$I; ${MAKE} install || exit 1); fi; done
+
+ install.bin: mkdir.bin
+@@ -85,11 +86,11 @@
+ install.script: mkdir.bin
+ @for I in ${subdirs}; do if [ -d $$I ]; then (cd $$I; ${MAKE} install.script || exit 1); fi; done
+
+-install.alternative:
+- @if update-alternatives --version > /dev/null 2>&1 ; then \
+- update-alternatives --install x-window-manager x-window-manager $(AFTER_BIN_DIR)/afterstep 100; \
+- echo "added AfterStep as an x-window-manager alternative"; \
+- fi
++#install.alternative:
++# @if update-alternatives --version > /dev/null 2>&1 ; then \
++# update-alternatives --install x-window-manager x-window-manager $(AFTER_BIN_DIR)/afterstep 100; \
++# echo "added AfterStep as an x-window-manager alternative"; \
++# fi
+
+
+ install.desktop: AfterStep.desktop.final mkdir.share