summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-04-08 10:54:42 +0000
committerJeroen Roovers <jer@gentoo.org>2013-04-08 10:54:42 +0000
commit3daee633c3932477852272133793d97f60491824 (patch)
treeedf740ed3de3811cb1ac21ef7b6be5d621e8e8f0 /x11-wm
parentLinux patches 3.0.72 and 3.4.39. Patch to fix brightness control on some Thin... (diff)
downloadgentoo-2-3daee633c3932477852272133793d97f60491824.tar.gz
gentoo-2-3daee633c3932477852272133793d97f60491824.tar.bz2
gentoo-2-3daee633c3932477852272133793d97f60491824.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog10
-rw-r--r--x11-wm/ratpoison/files/ratpoison-1.4.5-asneeded.patch4
-rw-r--r--x11-wm/ratpoison/files/ratpoison.el-gentoo.patch4
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.6.ebuild80
4 files changed, 92 insertions, 6 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 8d56ace1495f..4f73d4ab936e 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.83 2011/01/25 02:28:12 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.84 2013/04/08 10:54:42 jer Exp $
+
+*ratpoison-1.4.6 (08 Apr 2013)
+
+ 08 Apr 2013; Jeroen Roovers <jer@gentoo.org> +ratpoison-1.4.6.ebuild,
+ files/ratpoison-1.4.5-asneeded.patch, files/ratpoison.el-gentoo.patch:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org>
files/ratpoison-1.4.4-glibc210.patch:
diff --git a/x11-wm/ratpoison/files/ratpoison-1.4.5-asneeded.patch b/x11-wm/ratpoison/files/ratpoison-1.4.5-asneeded.patch
index bb70665fab8f..4947778bfdd4 100644
--- a/x11-wm/ratpoison/files/ratpoison-1.4.5-asneeded.patch
+++ b/x11-wm/ratpoison/files/ratpoison-1.4.5-asneeded.patch
@@ -2,8 +2,8 @@ Fixing as-needed issues
http://bugs.gentoo.org/show_bug.cgi?id=310727
---- src/Makefile.am
-+++ src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -22,8 +22,9 @@
bin_PROGRAMS = ratpoison
MAINTAINERCLEANFILES = Makefile.in config.h.in
diff --git a/x11-wm/ratpoison/files/ratpoison.el-gentoo.patch b/x11-wm/ratpoison/files/ratpoison.el-gentoo.patch
index d211220e649c..87fb253aea2a 100644
--- a/x11-wm/ratpoison/files/ratpoison.el-gentoo.patch
+++ b/x11-wm/ratpoison/files/ratpoison.el-gentoo.patch
@@ -1,5 +1,5 @@
---- ratpoison.el 2003-11-10 22:30:44.000000000 -0600
-+++ ratpoison.el~ 2003-11-10 22:53:30.676457808 -0600
+--- a/ratpoison.el
++++ b/ratpoison.el
@@ -44,6 +44,8 @@
;; - auto-completion of commands
;; - probably a bunch of other things
diff --git a/x11-wm/ratpoison/ratpoison-1.4.6.ebuild b/x11-wm/ratpoison/ratpoison-1.4.6.ebuild
new file mode 100644
index 000000000000..aff997ec6640
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.6.ebuild,v 1.1 2013/04/08 10:54:42 jer Exp $
+
+EAPI=5
+
+inherit elisp-common eutils
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug emacs +history +xft"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ virtual/perl-PodParser
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+"
+
+SITEFILE=50ratpoison-gentoo.el
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ cd "${S}/contrib"
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with xft) \
+ $(usex history '' --disable-history)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/ratpoison.xsession ratpoison
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop || die
+
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${ED}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}