summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-04-06 01:04:10 +0000
committerNaohiro Aota <naota@gentoo.org>2013-04-06 01:04:10 +0000
commit498567e3071bcee651061003cba80273abb9200b (patch)
treea3cc1e8c34bc0f939f45fdc1fc8d64b93f46a8cd /x11-wm
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-498567e3071bcee651061003cba80273abb9200b.tar.gz
gentoo-2-498567e3071bcee651061003cba80273abb9200b.tar.bz2
gentoo-2-498567e3071bcee651061003cba80273abb9200b.zip
Add upstream patch to use libexecinfo. #438658; Fix non-POSIX configure test.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/ChangeLog10
-rw-r--r--x11-wm/afterstep/afterstep-2.2.11.ebuild11
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.11-configure.patch13
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch84
4 files changed, 112 insertions, 6 deletions
diff --git a/x11-wm/afterstep/ChangeLog b/x11-wm/afterstep/ChangeLog
index d551881a7bdd..3ab07114ce87 100644
--- a/x11-wm/afterstep/ChangeLog
+++ b/x11-wm/afterstep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/afterstep
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.102 2012/07/26 18:04:06 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/ChangeLog,v 1.103 2013/04/06 01:04:10 naota Exp $
+
+ 06 Apr 2013; Naohiro Aota <naota@gentoo.org>
+ +files/afterstep-2.2.11-configure.patch,
+ +files/afterstep-2.2.11-execinfo.patch, afterstep-2.2.11.ebuild:
+ Add upstream patch to use libexecinfo. #438658; Fix non-POSIX configure test.
26 Jul 2012; Anthony G. Basile <blueness@gentoo.org> afterstep-2.2.11.ebuild:
Keyword ~arm
@@ -430,4 +435,3 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
-
diff --git a/x11-wm/afterstep/afterstep-2.2.11.ebuild b/x11-wm/afterstep/afterstep-2.2.11.ebuild
index ebd910220e0b..785ddc8eb625 100644
--- a/x11-wm/afterstep/afterstep-2.2.11.ebuild
+++ b/x11-wm/afterstep/afterstep-2.2.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.11.ebuild,v 1.3 2012/07/26 18:04:06 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/afterstep/afterstep-2.2.11.ebuild,v 1.4 2013/04/06 01:04:10 naota Exp $
EAPI=4
inherit autotools eutils flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="alsa debug dbus gif gtk jpeg mmx nls png svg tiff xinerama"
RDEPEND="media-libs/freetype
@@ -43,6 +43,7 @@ S=${WORKDIR}/AfterStep-${PV}
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.2.9-{alpha,ldflags,libpng15}.patch
+ epatch "${FILESDIR}"/${PN}-2.2.11-{execinfo,configure}.patch
sed -i -e '/^install:/s:install.alternative ::' Makefile.in || die
sed -i -e '/CFLAGS="-O3"/d' libAfter{Base,Image}/configure || die
@@ -54,6 +55,10 @@ src_prepare() {
cp autoconf/config.h.in ./ || die
cp configure ../ || die
popd >/dev/null
+
+ pushd libAfterBase >/dev/null
+ eautoreconf
+ popd >/dev/null
}
src_configure() {
diff --git a/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch b/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch
new file mode 100644
index 000000000000..1ed6bd9394d1
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch
@@ -0,0 +1,13 @@
+diff --git a/autoconf/configure.in b/autoconf/configure.in
+index 4170f98..a16388e 100644
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -105,7 +105,7 @@ AC_ARG_ENABLE(send-postcard-to-developer, [ --enable-send-postcard-to-developer
+ AC_ARG_ENABLE(data-reinstall, [ --enable-data-reinstall will prevent AfterStep from reinstalling image and font files.[[yes]] ],data_reinstall=$enableval,data_reinstall="yes")
+
+ AC_ARG_ENABLE(script, [ --enable-script compile Script module [[yes]] ], enable_script=$enableval,enable_script="yes")
+-AC_ARG_ENABLE(reuse-font, [ --enable-reuse-font enables reuse of loaded font resource by modules (don't use with TrueType fonts !)[[no]] ],[if test x$enableval == "xyes"; then AC_DEFINE(MODULE_REUSE_LOADED_FONT,1,Enables reuse of loaded font resource by modules) fi])
++AC_ARG_ENABLE(reuse-font, [ --enable-reuse-font enables reuse of loaded font resource by modules (don't use with TrueType fonts !)[[no]] ],[if test x$enableval = "xyes"; then AC_DEFINE(MODULE_REUSE_LOADED_FONT,1,Enables reuse of loaded font resource by modules) fi])
+
+ dnl# For FreeBSD, add -I/usr/local/include
+
diff --git a/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch b/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch
new file mode 100644
index 000000000000..61f4f08c082d
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch
@@ -0,0 +1,84 @@
+diff --git a/libAfterBase/configure.in b/libAfterBase/configure.in
+index de055ea..eb5619e 100644
+--- a/libAfterBase/configure.in
++++ b/libAfterBase/configure.in
+@@ -189,6 +189,8 @@ AC_CHECK_HEADERS(elf.h,[AC_CHECK_DECLS([ElfW],,,[#include <link.h>])
+ AC_CHECK_MEMBERS([Elf32_Dyn.d_tag, Elf64_Dyn.d_tag],,,[#include <elf.h>])
+ AC_CHECK_TYPES([Elf64_Addr, Elf32_Addr],,,[#include <elf.h>])])
+
++AC_CHECK_LIB([execinfo], [backtrace], [LIBS="$LIBS -lexecinfo"; lib_execinfo="-lexecinfo"])
++
+ dnl# this is needed for self diagnostic code :
+ AC_CHECK_FUNCS(backtrace_symbols_fd backtrace_symbols backtrace)
+
+@@ -257,6 +257,7 @@ AC_SUBST(lib_file_name)
+ AC_SUBST(with_locale)
+ AC_SUBST(user_ldflags)
+ AC_SUBST(x_libs)
++AC_SUBST(lib_execinfo)
+ AC_SUBST(X_CFLAGS)
+ AC_SUBST(LIBPROG)
+ AC_SUBST(LIBINSTALL)
+diff --git a/libAfterBase/Makefile.in b/libAfterBase/Makefile.in
+index f04be29..c3bacbb 100644
+--- a/libAfterBase/Makefile.in
++++ b/libAfterBase/Makefile.in
+@@ -80,6 +80,7 @@ INCLUDES = $(INCS_X) $(INCS_PRIVATE)
+
+ USER_LD_FLAGS = @user_ldflags@
+ LIBS_X = @x_libs@
++LIB_EXECINFO = @lib_execinfo@
+
+
+ LIBDIR = $(DESTDIR)@libdir@
+@@ -326,7 +327,7 @@ $(LIB_SHARED).$(LIBVERMAJOR): $(LIB_SHARED).$(LIBVER)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+- $(USER_LD_FLAGS) $(LIBS_X) $(LIB_OBJS)
++ $(USER_LD_FLAGS) $(LIB_OBJS) $(LIBS_X) $(LIB_EXECINFO)
+
+ install: install.lib
+
+diff --git a/autoconf/Makefile.defines.in b/autoconf/Makefile.defines.in
+index e6c283f..f8cae5e 100644
+--- a/autoconf/Makefile.defines.in
++++ b/autoconf/Makefile.defines.in
+@@ -40,6 +40,7 @@ LIBS_READLINE = @readline_libs@
+ LIBS_X = @x_libs@
+ LIBS_ALSA = @ALSA_LIBS@
+ LIBS_XEXTS =
++LIB_EXECINFO = @lib_execinfo@
+ LIB_AFTERBASE = @AFTERBASE_LIB@
+ LIB_AFTERIMAGE = @AFTERIMAGE_LIB@
+ LIB_AFTERSTEP = @AFTERSTEP_LIB@
+@@ -53,7 +54,7 @@ LIB_AFTERCONF_STATIC = @AFTERCONF_STATIC_LIB@
+ LIB_ASGTK_STATIC = @ASGTK_STATIC_LIB@
+ LIB_WIDGETS_STATIC = @WIDGETS_STATIC_LIB@
+ LIBS_AFTERIMAGE = @AFTERIMAGE_LIBS@
+-LIBRARIES = $(USER_LD_FLAGS) $(LIBS_PRIVATE) $(LIBS_XEXTS) $(LIBS_X)
++LIBRARIES = $(USER_LD_FLAGS) $(LIBS_PRIVATE) $(LIBS_XEXTS) $(LIBS_X) $(LIB_EXECINFO)
+
+ LIBS_ALL = $(LIBRARIES) $(EXTRA_LIBRARIES)
+
+diff --git a/autoconf/configure.in b/autoconf/configure.in
+index 45add70..4170f98 100644
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -651,6 +651,8 @@ if test "x$send_postcard_to_developer" = "xyes"; then
+ AC_DEFINE(DO_SEND_POSTCARD,1,E-mail installation notification to AfterStep developers)
+ fi
+
++AC_CHECK_LIB([execinfo],[backtrace],[lib_execinfo="-lexecinfo"])
++
+ AC_CANONICAL_TARGET
+ AC_SUBST(build)
+ AC_SUBST(build_os)
+@@ -718,6 +720,7 @@ AC_SUBST(with_desktops)
+ AC_SUBST(with_desktops_1)
+ AC_SUBST(with_deskgeometry)
+ AC_SUBST(no_data_reinstall)
++AC_SUBST(lib_execinfo)
+ dnl# old stuff :
+ AC_SUBST(enable_different_looknfeels)
+ AC_SUBST(enable_pagerbackground)