summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:17:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-13 01:17:29 +0000
commit59f82b343e16079a70b5ec8ee03efbffb4feadc2 (patch)
treecec7542c8b9f376733ba37b3bbb532c6d1d1fbf9 /x11-wm
parentCompile against newer libpng (diff)
downloadgentoo-2-59f82b343e16079a70b5ec8ee03efbffb4feadc2.tar.gz
gentoo-2-59f82b343e16079a70b5ec8ee03efbffb4feadc2.tar.bz2
gentoo-2-59f82b343e16079a70b5ec8ee03efbffb4feadc2.zip
optional USE dependent tiff support
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/afterstep/afterstep-1.8.11-r2.ebuild65
-rw-r--r--x11-wm/afterstep/files/digest-afterstep-1.8.11-r21
2 files changed, 66 insertions, 0 deletions
diff --git a/x11-wm/afterstep/afterstep-1.8.11-r2.ebuild b/x11-wm/afterstep/afterstep-1.8.11-r2.ebuild
new file mode 100644
index 000000000000..2e3c0088c90d
--- /dev/null
+++ b/x11-wm/afterstep/afterstep-1.8.11-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Peter Gavin <pete@gentoo.org>
+
+S=${WORKDIR}/AfterStep-${PV}
+DESCRIPTION="A window manager based on the NeXTStep interface."
+SRC_URI="ftp://ftp.afterstep.org/stable/AfterStep-${PV}.tar.bz2"
+HOMEPAGE="http://www.afterstep.org/"
+
+DEPEND="virtual/glibc virtual/x11
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.1
+ >=media-libs/xpm-3.4k
+ x11-wm/gnustep-env"
+
+RDEPEND="${DEPEND}
+ >=media-sound/sox-12.17.1"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-i18n"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-helpcommand="xterm -e man" \
+ --disable-availability \
+ --disable-staticlibs \
+ --with-xpm \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ install || die
+
+ rm -f ${D}/usr/bin/sessreg
+
+ dodoc COPYRIGHT ChangeLog INSTALL NEW README* TEAM UPGRADE
+ cp -a ${S}/TODO ${D}/usr/share/doc/${PF}/
+ dodir /usr/share/doc/${PF}/html
+ cp -a ${S}/doc/* ${D}/usr/share/doc/${PF}/html
+ rm ${D}/usr/share/doc/${PF}/html/Makefile*
+
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/afterstep
+
+}
diff --git a/x11-wm/afterstep/files/digest-afterstep-1.8.11-r2 b/x11-wm/afterstep/files/digest-afterstep-1.8.11-r2
new file mode 100644
index 000000000000..4bbf31502daa
--- /dev/null
+++ b/x11-wm/afterstep/files/digest-afterstep-1.8.11-r2
@@ -0,0 +1 @@
+MD5 6d8b41b7a642105b4cafc4d3d5f12a46 AfterStep-1.8.11.tar.bz2 1162212