summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-01-29 12:21:49 +0000
committerJeroen Roovers <jer@gentoo.org>2014-01-29 12:21:49 +0000
commit7f0f735935d9e2e03cd9ec5ec365769291fda231 (patch)
tree2e48f1b5532bc7335e4184e9002a7d4adfade679 /x11-wm
parentdev-vcs/git-cola: Fix broken documentation paths, #499658 (diff)
downloadgentoo-2-7f0f735935d9e2e03cd9ec5ec365769291fda231.tar.gz
gentoo-2-7f0f735935d9e2e03cd9ec5ec365769291fda231.tar.bz2
gentoo-2-7f0f735935d9e2e03cd9ec5ec365769291fda231.zip
Add live ebuild.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog9
-rw-r--r--x11-wm/ratpoison/ratpoison-9999.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 9e95c78161bc..8c41bcb42ddc 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.94 2013/10/19 15:29:24 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.95 2014/01/29 12:21:49 jer Exp $
+
+*ratpoison-9999 (29 Jan 2014)
+
+ 29 Jan 2014; Jeroen Roovers <jer@gentoo.org> +ratpoison-9999.ebuild:
+ Add live ebuild.
19 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due desktop-wm removal
diff --git a/x11-wm/ratpoison/ratpoison-9999.ebuild b/x11-wm/ratpoison/ratpoison-9999.ebuild
new file mode 100644
index 000000000000..8583ff8c3558
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-9999.ebuild,v 1.1 2014/01/29 12:21:49 jer Exp $
+
+EAPI=5
+
+inherit autotools elisp-common eutils git-r3
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+EGIT_REPO_URI="git://git.savannah.nongnu.org/ratpoison.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug emacs +history +xft"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ virtual/perl-PodParser
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+"
+
+SITEFILE=50ratpoison-gentoo.el
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-electric-fence \
+ $(use_enable debug) \
+ $(use_with xft) \
+ $(usex history '' --disable-history)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/ratpoison.xsession ratpoison
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop || die
+
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${ED}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}