summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-09 22:38:51 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-09 22:38:51 +0000
commit8bd9bbb228c4ab6dc8e2448084b7c6d17e156b9c (patch)
tree875a23c146444401d2141ebcf00631022256fcbe /x11-wm
parentBump to 0.8-r1. Better defaults for vfat, bug #257745. Fix HAL locking for de... (diff)
downloadgentoo-2-8bd9bbb228c4ab6dc8e2448084b7c6d17e156b9c.tar.gz
gentoo-2-8bd9bbb228c4ab6dc8e2448084b7c6d17e156b9c.tar.bz2
gentoo-2-8bd9bbb228c4ab6dc8e2448084b7c6d17e156b9c.zip
Bump to 2.24.0-r2. Fix a leak misused gslist function, bug #258301. Fix a string leak, bug #258302.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/ChangeLog10
-rw-r--r--x11-wm/metacity/files/metacity-2.24.0-gslist-leak.patch15
-rw-r--r--x11-wm/metacity/files/metacity-2.24.0-string-leak.patch21
-rw-r--r--x11-wm/metacity/metacity-2.24.0-r2.ebuild60
4 files changed, 105 insertions, 1 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index b8eaf28bb2bc..24994d5d01c4 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/metacity
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.222 2009/02/08 21:31:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.223 2009/02/09 22:38:51 eva Exp $
+
+*metacity-2.24.0-r2 (09 Feb 2009)
+
+ 09 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/metacity-2.24.0-gslist-leak.patch,
+ +files/metacity-2.24.0-string-leak.patch, +metacity-2.24.0-r2.ebuild:
+ Bump to 2.24.0-r2. Fix a leak misused gslist function, bug #258301. Fix a
+ string leak, bug #258302.
*metacity-2.24.0-r1 (08 Feb 2009)
diff --git a/x11-wm/metacity/files/metacity-2.24.0-gslist-leak.patch b/x11-wm/metacity/files/metacity-2.24.0-gslist-leak.patch
new file mode 100644
index 000000000000..39c35087e4c7
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.24.0-gslist-leak.patch
@@ -0,0 +1,15 @@
+# https://bugs.gentoo.org/attachment.cgi?id=181415
+diff -up a/src/core/edge-resistance.c b/src/core/edge-resistance.c
+--- a/src/core/edge-resistance.c 2008-09-14 22:39:38.000000000 -0400
++++ b/src/core/edge-resistance.c 2008-09-14 22:43:28.000000000 -0400
+@@ -985,8 +985,8 @@ meta_display_compute_resistance_and_snap
+ cur_window_iter = cur_window_iter->next;
+ }
+ /* Put 'em in bottom to top order */
+- rem_windows = g_slist_reverse (obscuring_windows);
+- rem_win_stacking = g_slist_reverse (window_stacking);
++ rem_windows = obscuring_windows = g_slist_reverse (obscuring_windows);
++ rem_win_stacking = window_stacking = g_slist_reverse (window_stacking);
+
+ /*
+ * 3rd: loop over the windows again, this time getting the edges from
diff --git a/x11-wm/metacity/files/metacity-2.24.0-string-leak.patch b/x11-wm/metacity/files/metacity-2.24.0-string-leak.patch
new file mode 100644
index 000000000000..e2cd71771377
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.24.0-string-leak.patch
@@ -0,0 +1,21 @@
+# https://bugs.gentoo.org/show_bug.cgi?id=258302
+diff -up a/src/ui/ui.c b/src/ui/ui.c
+--- a/src/ui/ui.c 2008-08-18 08:29:07.000000000 -0400
++++ b/src/ui/ui.c 2008-09-15 18:05:20.000000000 -0400
+@@ -657,10 +657,12 @@ meta_text_property_to_utf8 (Display
+ &list);
+
+ if (count == 0)
+- return NULL;
+-
+- retval = list[0];
+- list[0] = g_strdup (""); /* something to free */
++ retval = NULL;
++ else
++ {
++ retval = list[0];
++ list[0] = g_strdup (""); /* something to free */
++ }
+
+ g_strfreev (list);
+
diff --git a/x11-wm/metacity/metacity-2.24.0-r2.ebuild b/x11-wm/metacity/metacity-2.24.0-r2.ebuild
new file mode 100644
index 000000000000..139b855a2ade
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.24.0-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.24.0-r2.ebuild,v 1.1 2009/02/09 22:38:51 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="GNOME default window manager"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=x11-libs/pango-1.2
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXcursor
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libSM
+ x11-libs/libICE
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_enable xinerama)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix compilation on *bsd, bug #256224
+ epatch "${FILESDIR}/${P}-fbsd.patch"
+
+ # Fix crash on login, upstream bug #553980
+ epatch "${FILESDIR}/${P}-crash-login.patch"
+
+ # Fix a leak misused gslist function, bug #258301
+ epatch "${FILESDIR}/${P}-gslist-leak.patch"
+
+ # Fix a string leak, bug #258302
+ epatch "${FILESDIR}/${P}-string-leak.patch"
+}