summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2014-01-25 16:25:57 +0000
committerThomas Sachau <tommy@gentoo.org>2014-01-25 16:25:57 +0000
commit917bae5cce857aee514fd64b05fcda996c3c07c2 (patch)
tree6099d2e2ddabc0c051d5eeb6839c67c890a15674 /x11-wm
parentVersion bump for move to efl-1.8 (diff)
downloadgentoo-2-917bae5cce857aee514fd64b05fcda996c3c07c2.tar.gz
gentoo-2-917bae5cce857aee514fd64b05fcda996c3c07c2.tar.bz2
gentoo-2-917bae5cce857aee514fd64b05fcda996c3c07c2.zip
Version bump for move to efl-1.8
(Portage version: 2.2.6-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/ChangeLog10
-rw-r--r--x11-wm/enlightenment/enlightenment-0.17.6_pre2.ebuild79
2 files changed, 87 insertions, 2 deletions
diff --git a/x11-wm/enlightenment/ChangeLog b/x11-wm/enlightenment/ChangeLog
index 851647028a2e..453971ac8852 100644
--- a/x11-wm/enlightenment/ChangeLog
+++ b/x11-wm/enlightenment/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/enlightenment
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.190 2013/11/13 22:29:07 tommy Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/ChangeLog,v 1.191 2014/01/25 16:25:57 tommy Exp $
+
+*enlightenment-0.17.6_pre2 (25 Jan 2014)
+
+ 25 Jan 2014; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +enlightenment-0.17.6_pre2.ebuild:
+ Version bump for move to efl-1.8
*enlightenment-0.17.5 (13 Nov 2013)
diff --git a/x11-wm/enlightenment/enlightenment-0.17.6_pre2.ebuild b/x11-wm/enlightenment/enlightenment-0.17.6_pre2.ebuild
new file mode 100644
index 000000000000..b8718024960d
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.17.6_pre2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/enlightenment/enlightenment-0.17.6_pre2.ebuild,v 1.1 2014/01/25 16:25:57 tommy Exp $
+
+EAPI=5
+
+inherit autotools enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+#SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+SRC_URI="http://download.enlightenment.org/pre-releases/${P%%_*}/${P%%_*}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0.17/${PV%%_*}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@dialogs +@display +@edgebindings
+ +@interaction +@intl +@keybindings +@menus
+ +@paths +@performance +@randr +@shelves +@theme
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@backlight +@battery +@clock +@comp +@connman +@cpufreq +@dropshadow
+ +@everything +@fileman +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2
+ +@mixer +@msgbus +@notification +@pager +@quickaccess +@shot +@start
+ +@syscon +@systray +@tasks +@temperature +@tiling +@winlist +@wizard +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs +udev ukit ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ || ( >=dev-libs/efl-1.8.3[X,eet,jpeg,png] >=dev-libs/efl-1.8.3[xcb,eet,jpeg,png] )
+ ukit? ( >=dev-libs/e_dbus-1.7.9[udev] )
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P%%_*}
+
+src_prepare() {
+ sed -i "s:1.7.10:1.7.9:g" configure.ac
+ eautoreconf
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF+=(
+ --disable-install-sysactions
+ --disable-elementary
+ $(use_enable doc)
+ --disable-device-hal
+ --enable-emotion
+ --disable-mount-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ --disable-physics
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}