summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-10-09 14:45:30 +0000
committerJim Ramsay <lack@gentoo.org>2007-10-09 14:45:30 +0000
commitaa8f504618d7cab0aecd9f820951a3282545b649 (patch)
tree3442b9ced1a49c930884492fcec50ae402e29867 /x11-wm
parentStable on amd64 wrt bug #193881 (diff)
downloadgentoo-2-aa8f504618d7cab0aecd9f820951a3282545b649.tar.gz
gentoo-2-aa8f504618d7cab0aecd9f820951a3282545b649.tar.bz2
gentoo-2-aa8f504618d7cab0aecd9f820951a3282545b649.zip
New version: 1.0.0 is released! (bug 195197)
(Portage version: 2.1.3.9)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/ChangeLog8
-rw-r--r--x11-wm/fluxbox/files/1.0.0/gentoo_style_location.patch17
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-1.0.03
-rw-r--r--x11-wm/fluxbox/fluxbox-1.0.0.ebuild118
4 files changed, 145 insertions, 1 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 09971375f7b5..220cf4be58b5 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.233 2007/09/25 16:20:35 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.234 2007/10/09 14:45:29 lack Exp $
+
+*fluxbox-1.0.0 (09 Oct 2007)
+
+ 09 Oct 2007; Jim Ramsay <lack@gentoo.org>
+ +files/1.0.0/gentoo_style_location.patch, +fluxbox-1.0.0.ebuild:
+ New version: 1.0.0 is released! (bug 195197)
25 Sep 2007; Raúl Porcel <armin76@gentoo.org>
fluxbox-1.0_rc3_p4983.ebuild:
diff --git a/x11-wm/fluxbox/files/1.0.0/gentoo_style_location.patch b/x11-wm/fluxbox/files/1.0.0/gentoo_style_location.patch
new file mode 100644
index 000000000000..3bf59802ab1f
--- /dev/null
+++ b/x11-wm/fluxbox/files/1.0.0/gentoo_style_location.patch
@@ -0,0 +1,17 @@
+--- util/fluxbox-generate_menu.in.orig 2007-07-13 13:47:11.000000000 -0600
++++ util/fluxbox-generate_menu.in 2007-07-13 13:51:03.000000000 -0600
+@@ -1803,12 +1803,8 @@
+ append_submenu "${FBSETTINGSMENU}"
+ append "[config] (${CONFIGUREMENU})"
+
+- append_menu "[submenu] (${SYSTEMSTYLES}) {${STYLEMENUTITLE}}"
+- append "[stylesdir] (${PREFIX}/share/fluxbox/styles)"
+- append_menu_end
+-
+- append_menu "[submenu] (${USERSTYLES}) {${STYLEMENUTITLE}}"
+- append "[stylesdir] (~/.@pkgprefix@fluxbox@pkgsuffix@/styles)"
++ append_submenu "Styles"
++ append "[include] (/usr/share/fluxbox/menu.d/styles/)"
+ append_menu_end
+
+ # Backgroundmenu
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-1.0.0 b/x11-wm/fluxbox/files/digest-fluxbox-1.0.0
new file mode 100644
index 000000000000..16570da510f1
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-1.0.0
@@ -0,0 +1,3 @@
+MD5 990e276ead0d04421dce4080f485caca fluxbox-1.0.0.tar.bz2 767586
+RMD160 320b11a1cf96a757da079886cd6496b9d84ab202 fluxbox-1.0.0.tar.bz2 767586
+SHA256 3c27672fdd4709d7f5c7968b4197ef704fce82766f51a5bebf411953516794c5 fluxbox-1.0.0.tar.bz2 767586
diff --git a/x11-wm/fluxbox/fluxbox-1.0.0.ebuild b/x11-wm/fluxbox/fluxbox-1.0.0.ebuild
new file mode 100644
index 000000000000..c8e78748df2e
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-1.0.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.0.0.ebuild,v 1.1 2007/10/09 14:45:29 lack Exp $
+
+inherit eutils
+
+IUSE="nls xinerama truetype kde gnome imlib disableslit disabletoolbar"
+
+DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
+
+SRC_URI="mirror://sourceforge/fluxbox/${P}.tar.bz2"
+HOMEPAGE="http://www.fluxbox.org"
+
+# Please note that USE="kde gnome" simply adds support for the respective
+# protocols, and does not depend on external libraries. They do, however,
+# make the binary a fair bit bigger, so we don't want to turn them on unless
+# the user actually wants them.
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libXrandr
+ xinerama? ( x11-libs/libXinerama )
+ x11-apps/xmessage
+ virtual/xft
+ truetype? ( media-libs/freetype )
+ imlib? ( >=media-libs/imlib2-1.2.0 )
+ !<x11-themes/fluxbox-styles-fluxmod-20040809-r1
+ !<=x11-misc/fluxconf-0.9.9"
+DEPEND=">=sys-devel/autoconf-2.52
+ nls? ( sys-devel/gettext )
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ ${RDEPEND}"
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+pkg_setup() {
+ if use imlib ; then
+ if ! built_with_use media-libs/imlib2 X ; then
+ eerror "To build fluxbox with imlib in USE, you need an X enabled"
+ eerror "media-libs/imlib2 . Either recompile imlib2 with the X"
+ eerror "USE flag turned on or disable the imlib USE flag for fluxbox."
+ die "USE=imlib requires imlib2 with USE=X"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to be able to include directories rather than just plain
+ # files in menu [include] items. This patch will allow us to do clever
+ # things with style ebuilds.
+ epatch "${FILESDIR}/${PV}/gentoo_style_location.patch"
+
+ # Add in the Gentoo -r number to fluxbox -version output.
+ if [[ "${PR}" == "r0" ]] ; then
+ suffix="gentoo"
+ else
+ suffix="gentoo-${PR}"
+ fi
+ sed -i \
+ -e "s~\(__fluxbox_version .@VERSION@\)~\1-${suffix}~" \
+ version.h.in || die "version sed failed"
+}
+
+src_compile() {
+ export PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig:/usr/lib/pkgconfig
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable truetype xft) \
+ $(use_enable kde) \
+ $(use_enable gnome) \
+ $(use_enable imlib imlib2) \
+ $(use_enable !disableslit slit ) \
+ $(use_enable !disabletoolbar toolbar ) \
+ --sysconfdir=/etc/X11/${PN} \
+ --with-style=/usr/share/fluxbox/styles/Emerge \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+
+ ebegin "Creating a menu file (may take a while)"
+ mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
+ MENUFILENAME="${S}/data/menu" MENUTITLE="Fluxbox ${PV}" \
+ CHECKINIT="no. go away." HOME="${T}/home" \
+ "${S}/util/fluxbox-generate_menu" -is -ds \
+ || die "menu generation failed"
+ eend $?
+}
+
+src_install() {
+ dodir /usr/share/fluxbox
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README* AUTHORS TODO* ChangeLog NEWS
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/startfluxbox" > "${D}/etc/X11/Sessions/fluxbox"
+ fperms a+x /etc/X11/Sessions/fluxbox
+
+ dodir /usr/share/fluxbox/menu.d
+
+ # Styles menu framework
+ dodir /usr/share/fluxbox/menu.d/styles
+ insinto /usr/share/fluxbox/menu.d/styles
+ doins "${FILESDIR}/styles-menu-fluxbox" || die
+ doins "${FILESDIR}/styles-menu-commonbox" || die
+ doins "${FILESDIR}/styles-menu-user" || die
+}