summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-25 04:41:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-25 04:41:37 +0000
commitb1697f2bc8266155b3fbbfa874a9908b36456ba6 (patch)
tree68554fc87000503983829c45c147303addd1366b /x11-wm
parentupdate deb patchset #97921 (diff)
downloadgentoo-2-b1697f2bc8266155b3fbbfa874a9908b36456ba6.tar.gz
gentoo-2-b1697f2bc8266155b3fbbfa874a9908b36456ba6.tar.bz2
gentoo-2-b1697f2bc8266155b3fbbfa874a9908b36456ba6.zip
Fix building with flex-2.5.31 #110169.
(Portage version: 2.0.53)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/amiwm/ChangeLog8
-rw-r--r--x11-wm/amiwm/amiwm-0.20_p48.ebuild26
-rw-r--r--x11-wm/amiwm/files/amiwm-0.20_p48-flex.patch12
3 files changed, 30 insertions, 16 deletions
diff --git a/x11-wm/amiwm/ChangeLog b/x11-wm/amiwm/ChangeLog
index b7e88f8c7394..126c132bb18c 100644
--- a/x11-wm/amiwm/ChangeLog
+++ b/x11-wm/amiwm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-wm/amiwm
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/amiwm/ChangeLog,v 1.4 2005/05/10 09:06:04 dholm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/amiwm/ChangeLog,v 1.5 2005/12/25 04:41:37 vapier Exp $
+
+ 25 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/amiwm-0.20_p48-flex.patch, amiwm-0.20_p48.ebuild:
+ Fix building with flex-2.5.31 #110169.
10 May 2005; David Holm <dholm@gentoo.org> amiwm-0.20_p48.ebuild:
Added to ~ppc.
diff --git a/x11-wm/amiwm/amiwm-0.20_p48.ebuild b/x11-wm/amiwm/amiwm-0.20_p48.ebuild
index f471ca86064c..a9b013bf3cf5 100644
--- a/x11-wm/amiwm/amiwm-0.20_p48.ebuild
+++ b/x11-wm/amiwm/amiwm-0.20_p48.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/amiwm/amiwm-0.20_p48.ebuild,v 1.5 2005/05/10 09:06:04 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/amiwm/amiwm-0.20_p48.ebuild,v 1.6 2005/12/25 04:41:37 vapier Exp $
+
+inherit eutils
MY_P="${PN}${PV/_p/pl}"
DESCRIPTION="Windowmanager ala Amiga(R) Workbench(R)"
@@ -14,23 +16,19 @@ IUSE=""
DEPEND="virtual/x11"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
-src_compile() {
- econf || die
- emake || die
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-flex.patch #110169
}
src_install() {
dodir /usr/bin
- einstall
-
-# make \
-# prefix=${D}/usr \
-# mandir=${D}/usr/share/man \
-# install || die
+ einstall || die
- rm ${D}/usr/bin/requestchoice
+ rm "${D}"/usr/bin/requestchoice
dosym /usr/lib/amiwm/requestchoice /usr/bin/requestchoice
dosed /usr/lib/amiwm/{Xinitrc,Xsession,Xsession2}
@@ -38,6 +36,6 @@ src_install() {
dodoc INSTALL README*
exeinto /etc/X11/Sessions
- echo "/usr/bin/amiwm" > ${T}/amiwm
- doexe ${T}/amiwm
+ echo "/usr/bin/amiwm" > "${T}"/amiwm
+ doexe "${T}"/amiwm
}
diff --git a/x11-wm/amiwm/files/amiwm-0.20_p48-flex.patch b/x11-wm/amiwm/files/amiwm-0.20_p48-flex.patch
new file mode 100644
index 000000000000..c346fbb0bc08
--- /dev/null
+++ b/x11-wm/amiwm/files/amiwm-0.20_p48-flex.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/110169
+
+--- amiwm/lex.l
++++ amiwm/lex.l
+@@ -6,6 +6,7 @@
+ extern FILE *rcfile;
+ #undef yyin
+ #define yyin rcfile
++#define YY_SKIP_YYWRAP
+ #define yywrap() 1
+ extern int parse_keyword(char *);
+ void fixup_string(char *, char *);