summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-30 21:55:57 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-30 21:55:57 +0000
commite4006df14658da540298c0a10332ac761fab56b8 (patch)
tree48c62842dc31f1ca13834ea46380d3573cbd0cdd /x11-wm
parentadded ~alpha, ~sparc and ~ppc keywords (diff)
downloadgentoo-2-e4006df14658da540298c0a10332ac761fab56b8.tar.gz
gentoo-2-e4006df14658da540298c0a10332ac761fab56b8.tar.bz2
gentoo-2-e4006df14658da540298c0a10332ac761fab56b8.zip
Proper use of USE flags
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/ChangeLog5
-rw-r--r--x11-wm/fvwm/Manifest4
-rw-r--r--x11-wm/fvwm/fvwm-2.5.7.ebuild88
3 files changed, 62 insertions, 35 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 46070937fdee..776da0f4e089 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.15 2003/07/30 20:43:29 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.16 2003/07/30 21:55:48 taviso Exp $
+
+ 30 Jul 2003; Tavis Ormandy <taviso@gentoo.org> fvwm-2.5.7.ebuild:
+ Adding some real options, re-written the whole conf.
*fvwm-2.5.7 (30 Jul 2003)
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index 2177e9f0a790..81c5f29c710b 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,8 +1,8 @@
MD5 616d23339ff772ad286c142eee37efc8 fvwm-2.4.15.ebuild 1167
MD5 640cc8cf1c7b29a974fed717d4460794 fvwm-2.4.14.ebuild 1102
-MD5 ce49756d0b093ae008b2cc59a168286d fvwm-2.5.7.ebuild 1788
+MD5 6294da8fe945a7360a6914144257ff3e fvwm-2.5.7.ebuild 2714
MD5 9b68cbbbdaba95b23665ea98c695e57d fvwm-2.4.16.ebuild 1334
-MD5 7e0c955ab6d0eeab5c1ef4356acc00b6 ChangeLog 2780
+MD5 7ffeb822c0eea195632cc4c2b7aa232b ChangeLog 2904
MD5 beaa1ad08ff661a32c25d1a51c879a8d metadata.xml 450
MD5 ccd8378d86941cb17669e64ca88949c1 fvwm-2.4.8.ebuild 1146
MD5 282c809ddaa59071830b6c8dd9b0a3a1 files/fvwm2 25
diff --git a/x11-wm/fvwm/fvwm-2.5.7.ebuild b/x11-wm/fvwm/fvwm-2.5.7.ebuild
index 57b244f67800..944610f5bfcc 100644
--- a/x11-wm/fvwm/fvwm-2.5.7.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.7.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.4 2003/07/30 20:43:29 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.5 2003/07/30 21:55:48 taviso Exp $
inherit gnuconfig
-IUSE="ncurses gtk gnome oss xinerama"
+IUSE="readline gtk gnome oss xinerama cjk perl nls png"
S=${WORKDIR}/${P}
DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
@@ -15,56 +15,80 @@ SLOT="0"
KEYWORDS="~x86 ~alpha"
LICENSE="GPL-2 FVWM"
-RDEPEND="oss? ( media-sound/rplay )
- >=dev-libs/libstroke-0.4
+RDEPEND="readline? ( >=sys-libs/readline-4.1 )
gtk? ( =x11-libs/gtk+-1.2* )
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
- ncurses? ( >=sys-libs/readline-4.1 )
+ oss? ( media-sound/rplay )
+ perl? ( dev-lang/perl )
+ cjk? ( >=dev-libs/fribidi-0.10.4 )
+ png? ( media-libs/libpng )
+ >=dev-libs/libstroke-0.4
media-libs/fontconfig
- dev-libs/expat
- media-libs/libpng"
-DEPEND="${RDEPEND} sys-devel/automake
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ sys-devel/autoconf
dev-util/pkgconfig"
src_unpack() {
unpack ${A}
- cd ${S}
+
use alpha && gnuconfig_update
+
+ # CFLAGS containing comma will break this, so change it for !
+ sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' ${S}/utils/Makefile.am
+
+ # Xft detection is totally b0rked if using pkg-config, this update from cvs.
+ cp ${FILESDIR}/acinclude.m4 ${S}/acinclude.m4
}
src_compile() {
- local myconf
+ local myconf="--libexecdir=/usr/lib --enable-xft"
+ use readline \
+ || myconf="${myconf} --without-readline-library"
+
+ use gtk \
+ || myconf="${myconf} --disable-gtktest --disable-imlibtest --with-gtk-prefix=/no/dir --with-imlib-prefix=/no/dir"
+
use gnome \
- && myconf="--with-gnome" \
- || myconf="--without-gnome" \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --without-gnome"
use oss \
- && myconf="--with-rplay" \
- || myconf="--without-rplay"
+ || myconf="${myconf} --without-rplay-library"
+ use perl \
+ && myconf="${myconf} --enable-perllib" \
+ || myconf="${myconf} --disable-perllib"
+
use xinerama \
- && myconf="--enable-xinerama" \
- || myconf="--disable-xinerama"
+ && myconf="${myconf} --enable-xinerama" \
+ || myconf="${myconf} --disable-xinerama"
- # CFLAGS containing comma will break this, so change it for !
- sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' \
- ${S}/utils/Makefile.am
+ use cjk \
+ && myconf="${myconf} --enable-multibyte --enable-bidi" \
+ || myconf="${myconf} --disable-multibyte --disable-bidi"
- einfo "Fixing Xft detection..."
- cp ${FILESDIR}/acinclude.m4 ${S}/acinclude.m4
- aclocal
- autoheader
- automake --add-missing
- autoreconf
+ use png \
+ || myconf="${myconf} --without-png-library"
- econf \
- --enable-multibyte \
- --libexecdir=/usr/lib \
- --enable-xft \
- ${myconf} \
- PKG_CONFIG=${ROOT}/usr/bin/pkg-config || die
-
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ einfo "Fixing Xft detection, please wait..."
+ ( einfo " Running aclocal..."
+ aclocal
+ einfo " Running autoheader..."
+ autoheader
+ einfo " Running automake..."
+ automake --add-missing
+ einfo " Running autoreconf..."
+ autoreconf ) 2>/dev/null
+ einfo "Fixed."
+
+ econf ${myconf} PKG_CONFIG=${ROOT}/usr/bin/pkg-config || die
emake || die
}