summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-06-10 15:25:30 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-06-10 15:25:30 +0000
commitf2554cbc1f9d9bb88be70fd304ce4ca085403d1c (patch)
tree3212318d57121841df0405554790f6c7228ac9c1 /x11-wm
parentStable for amd64, wrt bug #551658 (diff)
downloadgentoo-2-f2554cbc1f9d9bb88be70fd304ce4ca085403d1c.tar.gz
gentoo-2-f2554cbc1f9d9bb88be70fd304ce4ca085403d1c.tar.bz2
gentoo-2-f2554cbc1f9d9bb88be70fd304ce4ca085403d1c.zip
Move live ebuild from gnustep overlay
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 00F7AB331B0F097F)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/ChangeLog8
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.6.ebuild4
-rw-r--r--x11-wm/windowmaker/windowmaker-9999.ebuild113
3 files changed, 122 insertions, 3 deletions
diff --git a/x11-wm/windowmaker/ChangeLog b/x11-wm/windowmaker/ChangeLog
index 1d0075b1e347..d39d1eb2911a 100644
--- a/x11-wm/windowmaker/ChangeLog
+++ b/x11-wm/windowmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/windowmaker
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.153 2015/05/27 20:24:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.154 2015/06/10 15:25:30 voyageur Exp $
+
+*windowmaker-9999 (10 Jun 2015)
+
+ 10 Jun 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +windowmaker-9999.ebuild:
+ Move live ebuild from gnustep overlay
27 May 2015; Pacho Ramos <pacho@gentoo.org> windowmaker-0.92.0-r11.ebuild,
windowmaker-0.95.5-r1.ebuild, windowmaker-0.95.6.ebuild:
diff --git a/x11-wm/windowmaker/windowmaker-0.95.6.ebuild b/x11-wm/windowmaker/windowmaker-0.95.6.ebuild
index 32f78ef8958b..03a2457801f7 100644
--- a/x11-wm/windowmaker/windowmaker-0.95.6.ebuild
+++ b/x11-wm/windowmaker/windowmaker-0.95.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.95.6.ebuild,v 1.5 2015/05/27 20:24:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.95.6.ebuild,v 1.6 2015/06/10 15:25:30 voyageur Exp $
EAPI=5
inherit autotools eutils
@@ -23,7 +23,7 @@ DEPEND="media-libs/fontconfig
x11-libs/libXv
gif? ( >=media-libs/giflib-4.1.0-r3 )
imagemagick? ( media-gfx/imagemagick )
- jpeg? ( virtual/jpeg )
+ jpeg? ( virtual/jpeg:0= )
png? ( media-libs/libpng:0= )
tiff? ( media-libs/tiff:0 )
webp? ( media-libs/libwebp )
diff --git a/x11-wm/windowmaker/windowmaker-9999.ebuild b/x11-wm/windowmaker/windowmaker-9999.ebuild
new file mode 100644
index 000000000000..76df89c65d88
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-9999.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-9999.ebuild,v 1.1 2015/06/10 15:25:30 voyageur Exp $
+
+EAPI=5
+inherit autotools eutils git-r3
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="http://www.windowmaker.org/"
+SRC_URI="http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+EGIT_REPO_URI="git://repo.or.cz/wmaker-crm.git"
+EGIT_BRANCH="next"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
+KEYWORDS=""
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ imagemagick? ( media-gfx/imagemagick )
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ webp? ( media-libs/libwebp )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}
+ nls? ( >=sys-devel/gettext-0.10.39 )
+ !app-i18n/scim-anthy[gtk3]"
+
+src_unpack() {
+ # wm-extras
+ unpack ${A}
+
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
+ sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ fi;
+ done;
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # image format types
+ myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
+
+ # non required X capabilities
+ myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
+
+ if use nls; then
+ [[ -z $LINGUAS ]] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ else
+ myconf="${myconf} --disable-locale"
+ fi
+
+ # default settings with $myconf appended
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --with-x \
+ --enable-usermenu \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --localedir="${EPREFIX}"/usr/share/locale \
+ ${myconf}
+
+ cd ../WindowMaker-extra-0.1
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ cd ../WindowMaker-extra-0.1
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
+ README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ emake DESTDIR="${D}" install
+
+ newdoc README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+}