summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-10 18:20:06 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-10 18:20:06 +0000
commitf25b5a27505139ad057a4d7b9bb65a63abe1b25f (patch)
treec5da67e49508960f63148eb877f6b6dcfe872334 /x11-wm
parentMake USE=syslog default on older ebuilds as well, to solve where the logs are... (diff)
downloadgentoo-2-f25b5a27505139ad057a4d7b9bb65a63abe1b25f.tar.gz
gentoo-2-f25b5a27505139ad057a4d7b9bb65a63abe1b25f.tar.bz2
gentoo-2-f25b5a27505139ad057a4d7b9bb65a63abe1b25f.zip
WindowMaker version bump, almost six years after last release
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/windowmaker/ChangeLog12
-rw-r--r--x11-wm/windowmaker/metadata.xml1
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.1.ebuild106
3 files changed, 117 insertions, 2 deletions
diff --git a/x11-wm/windowmaker/ChangeLog b/x11-wm/windowmaker/ChangeLog
index e3b0520541a6..cdde80b7b53b 100644
--- a/x11-wm/windowmaker/ChangeLog
+++ b/x11-wm/windowmaker/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/windowmaker
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.129 2011/11/12 10:36:45 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/ChangeLog,v 1.130 2012/02/10 18:20:06 voyageur Exp $
+
+*windowmaker-0.95.1 (10 Feb 2012)
+
+ 10 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org>
+ +windowmaker-0.95.1.ebuild, metadata.xml:
+ New version! Integrates the compilation fixes/new features of our patchsets,
+ and adds some new features too (tab completion in run dialog, inotify
+ detection of configuration changes...). Fixes bug #398351
12 Nov 2011; Justin Lecher <jlec@gentoo.org> windowmaker-0.92.0-r11.ebuild,
metadata.xml:
diff --git a/x11-wm/windowmaker/metadata.xml b/x11-wm/windowmaker/metadata.xml
index 334bd509da28..f9df3ea64d6c 100644
--- a/x11-wm/windowmaker/metadata.xml
+++ b/x11-wm/windowmaker/metadata.xml
@@ -6,6 +6,7 @@
<flag name="modelock">Enable XKB language status lock support. README
says: "If you don't know what it is you probably don't need
it."</flag>
+ <flag name='xrandr'>Enable XRandR window extension support</flag>
<flag name="vdesktop">Enable dynamic virtual desktop (conflicts with
software that works on the edges of the screen)</flag>
</use>
diff --git a/x11-wm/windowmaker/windowmaker-0.95.1.ebuild b/x11-wm/windowmaker/windowmaker-0.95.1.ebuild
new file mode 100644
index 000000000000..4c8e13a39d99
--- /dev/null
+++ b/x11-wm/windowmaker/windowmaker-0.95.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/windowmaker/windowmaker-0.95.1.ebuild,v 1.1 2012/02/10 18:20:06 voyageur Exp $
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="The fast and light GNUstep window manager"
+HOMEPAGE="http://www.windowmaker.org/"
+# Git snapshot renamed until official one appears
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P/windowm/WindowM}.tar.gz
+ http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gif jpeg nls png tiff modelock xinerama +xrandr"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="media-libs/fontconfig
+ >=x11-libs/libXft-2.1.0
+ x11-libs/libXt
+ x11-libs/libXv
+ gif? ( >=media-libs/giflib-4.1.0-r3 )
+ png? ( media-libs/libpng:0 )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff:0 )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+RDEPEND="${DEPEND}
+ nls? ( >=sys-devel/gettext-0.10.39 )"
+
+S=${WORKDIR}/${P/windowm/WindowM}
+
+src_prepare() {
+ # Fix some paths
+ for file in WindowMaker/*menu* util/wmgenmenu.c; do
+ if [[ -r $file ]] ; then
+ sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
+ sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
+ fi;
+ done;
+
+ # Remove when official tarball is available
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # image format types
+ # xpm is provided by X itself
+ myconf="--enable-xpm $(use_enable png) $(use_enable jpeg) $(use_enable gif) $(use_enable tiff)"
+
+ # non required X capabilities
+ myconf="${myconf} $(use_enable modelock) $(use_enable xrandr) $(use_enable xinerama)"
+
+ if use nls; then
+ [[ -z $LINGUAS ]] && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`"
+ else
+ myconf="${myconf} --disable-locale"
+ fi
+
+ # default settings with $myconf appended
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/X11 \
+ --with-x \
+ --enable-usermenu \
+ --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
+ --with-nlsdir="${EPREFIX}"/usr/share/locale \
+ ${myconf}
+
+ cd ../WindowMaker-extra-0.1
+ econf
+}
+
+src_compile() {
+ emake
+
+ # WindowMaker Extra Package (themes and icons)
+ cd ../WindowMaker-extra-0.1
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
+ README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ emake DESTDIR="${D}" install
+
+ newdoc README README.extra
+
+ # create wmaker session shell script
+ echo "#!/usr/bin/env bash" > wmaker
+ echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
+ exeinto /etc/X11/Sessions/
+ doexe wmaker
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/wmaker.desktop
+ make_desktop_entry /usr/bin/wmaker
+}