summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-19 01:03:48 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-19 01:03:48 +0000
commitf33f85b5ce2efcd03b42db4adfac0e429836c7b6 (patch)
tree4b18ab1821df879526858a24a5a261c1d6754bcc /x11-wm
parentRespect LDFLAGS (bug #337907). Do not hard-wire CC and CFLAGS (or do any of t... (diff)
downloadgentoo-2-f33f85b5ce2efcd03b42db4adfac0e429836c7b6.tar.gz
gentoo-2-f33f85b5ce2efcd03b42db4adfac0e429836c7b6.tar.bz2
gentoo-2-f33f85b5ce2efcd03b42db4adfac0e429836c7b6.zip
Do not install treewm-xprop or treewm-xkill. Instead, point out that the newer versions in the tree may not work with treewm. Respect LDFLAGS (bug #334433), CXX and CXXFLAGS. Remove unneeded dependencies.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/treewm/ChangeLog11
-rw-r--r--x11-wm/treewm/treewm-0.4.5-r1.ebuild61
2 files changed, 70 insertions, 2 deletions
diff --git a/x11-wm/treewm/ChangeLog b/x11-wm/treewm/ChangeLog
index d1cc37fdde16..560b13f6f6a6 100644
--- a/x11-wm/treewm/ChangeLog
+++ b/x11-wm/treewm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/treewm
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/ChangeLog,v 1.19 2009/02/15 22:47:05 loki_val Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/ChangeLog,v 1.20 2010/09/19 01:03:48 jer Exp $
+
+*treewm-0.4.5-r1 (19 Sep 2010)
+
+ 19 Sep 2010; Jeroen Roovers <jer@gentoo.org> +treewm-0.4.5-r1.ebuild:
+ Do not install treewm-xprop or treewm-xkill. Instead, point out that the
+ newer versions in the tree may not work with treewm. Respect LDFLAGS (bug
+ #334433), CXX and CXXFLAGS. Remove unneeded dependencies.
15 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+files/treewm-0.4.5-gcc43.patch, treewm-0.4.5.ebuild:
diff --git a/x11-wm/treewm/treewm-0.4.5-r1.ebuild b/x11-wm/treewm/treewm-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..1900a70d6862
--- /dev/null
+++ b/x11-wm/treewm/treewm-0.4.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/treewm/treewm-0.4.5-r1.ebuild,v 1.1 2010/09/19 01:03:47 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="WindowManager that arranges the windows in a tree (not in a list)"
+SRC_URI="mirror://sourceforge/treewm/${P}.tar.bz2"
+HOMEPAGE="http://treewm.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xf86vidmodeproto"
+
+src_prepare() {
+ # bug 251845
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ # bug 86453
+ sed -i xprop/dsimple.c \
+ -e 's:malloc:Malloc:g' \
+ || die "sed xprop/dsimple.c"
+}
+
+src_compile() {
+ # only compile treewm, not (x11-apps/){xprop,xkill}
+ emake treewm \
+ CXX=$(tc-getCXX) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ PREFIX="/usr" ROOT="${D}" \
+ || die "emake"
+}
+
+src_install() {
+ # only install treewm, not (x11-apps/){xprop,xkill}
+ dobin src/treewm
+ dodoc AUTHORS ChangeLog PROBLEMS README README.tiling TODO default.cfg \
+ sample.cfg
+ insinto /usr/share/pixmaps/treewm
+ doins src/pixmaps/*.xpm
+}
+
+pkg_postinst() {
+ elog "x11-wm/treewm used to install its own versions of x11-apps/xprop and"
+ elog "x11-apps/xkill as treewm-xprop and treewm-xkill respectively, since"
+ elog "they are assumed to be broken in combination with treewm. Since"
+ elog "X(org) has become modular since treewm's last release and are not"
+ elog "installed by default, we can leave those out and simply point out"
+ elog "that it is NOT adviseable to use these programs when using treewm."
+}