summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-21 04:25:16 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-21 04:25:16 +0000
commit6da677d7e40be52410da727e1cdeea5d36040d8a (patch)
tree0610811db302537e10cf31c13cc2c54a160631e7 /xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
parentVersion bump for xfce-4.6.1 release, remove old (diff)
downloadgentoo-2-6da677d7e40be52410da727e1cdeea5d36040d8a.tar.gz
gentoo-2-6da677d7e40be52410da727e1cdeea5d36040d8a.tar.bz2
gentoo-2-6da677d7e40be52410da727e1cdeea5d36040d8a.zip
Version bump for xfce-4.6.1 release, remove old
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild')
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild b/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
new file mode 100644
index 000000000000..d276ac032c6e
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.6.1.ebuild,v 1.1 2009/04/21 04:25:16 darkside Exp $
+
+EAPI="1"
+
+inherit xfce4
+
+xfce4_core
+
+DESCRIPTION="Collection of utils"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug +lock"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libX11
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-base/xfconf-${XFCE_VERSION}
+ dbus? ( dev-libs/dbus-glib )
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable dbus) --with-vendor-info=Gentoo"
+}
+
+src_install() {
+ xfce4_src_install
+
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}/Gentoo"
+
+ dodir /etc/X11/Sessions
+ echo startxfce4 > "${D}/etc/X11/Sessions/Xfce4"
+ fperms 755 /etc/X11/Sessions/Xfce4
+}
+
+pkg_postinst() {
+ elog
+ elog "Run Xfce4 from your favourite Display Manager by using"
+ elog "XSESSION=\"Xfce4\" in /etc/rc.conf"
+ elog
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"