summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2004-04-18 05:18:33 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2004-04-18 05:18:33 +0000
commitd2262aaa1c69028a871fa16036834b90bd23f9f0 (patch)
treea6f472669794bb0f6c345627dda3af9ebb35a368 /xfce-base/xfce-utils
parentAdded ~ppc and ~sparc to KEYWORDS. (Manifest recommit) (diff)
downloadgentoo-2-d2262aaa1c69028a871fa16036834b90bd23f9f0.tar.gz
gentoo-2-d2262aaa1c69028a871fa16036834b90bd23f9f0.tar.bz2
gentoo-2-d2262aaa1c69028a871fa16036834b90bd23f9f0.zip
Bugfix release of xfce4.
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog7
-rw-r--r--xfce-base/xfce-utils/files/digest-xfce-utils-4.0.51
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.0.5.ebuild39
3 files changed, 46 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 71a69c79ddb2..fcbe69d5be75 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.21 2004/04/17 21:17:04 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.22 2004/04/18 05:18:33 bcowan Exp $
+
+*xfce-utils-4.0.5 (18 Apr 2004)
+
+ 18 Apr 2004; Brad Cowan <bcowan@gentoo.org> xfce-utils-4.0.5.ebuild:
+ Bugfix release of xfce4.
17 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> xfce-utils-4.0.0.ebuild,
xfce-utils-4.0.1.ebuild, xfce-utils-4.0.2.ebuild, xfce-utils-4.0.3.ebuild,
diff --git a/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.5 b/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.5
new file mode 100644
index 000000000000..75e987091980
--- /dev/null
+++ b/xfce-base/xfce-utils/files/digest-xfce-utils-4.0.5
@@ -0,0 +1 @@
+MD5 105e906b6f21a9360cc9a898dfb28604 xfce-utils-4.0.5.tar.gz 967057
diff --git a/xfce-base/xfce-utils/xfce-utils-4.0.5.ebuild b/xfce-base/xfce-utils/xfce-utils-4.0.5.ebuild
new file mode 100644
index 000000000000..67fb871768e2
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.0.5.ebuild,v 1.1 2004/04/18 05:18:33 bcowan Exp $
+
+IUSE="X gtkhtml gnome"
+
+DESCRIPTION="Xfce4 utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://hannelore.f1.fhtw-berlin.de/mirrors/xfce4/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64 ~hppa ~mips"
+
+RDEPEND=">=x11-libs/gtk+-2.0.6
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+ use gtkhtml && myconf="${myconf} --enable-gtkhtml"
+ use gnome && myconf="${myconf} --enable-gdm"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}